summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2015-05-27 01:35:06 +0000
committerAnthony G. Basile <blueness@gentoo.org>2015-05-27 01:35:06 +0000
commit4b6df8c66c466708e4e89d39513fea3ebb1c3ebf (patch)
treef1c48936bce81fd9e3c8198f6fa2332fe51cb82d
parentBump. (diff)
downloadgentoo-2-4b6df8c66c466708e4e89d39513fea3ebb1c3ebf.tar.gz
gentoo-2-4b6df8c66c466708e4e89d39513fea3ebb1c3ebf.tar.bz2
gentoo-2-4b6df8c66c466708e4e89d39513fea3ebb1c3ebf.zip
Version bump
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 0xF52D4BBA)
-rw-r--r--net-p2p/bitcoind/ChangeLog7
-rw-r--r--net-p2p/bitcoind/bitcoind-0.10.2.ebuild77
2 files changed, 83 insertions, 1 deletions
diff --git a/net-p2p/bitcoind/ChangeLog b/net-p2p/bitcoind/ChangeLog
index c3ed30de9ddc..5bac69d3de10 100644
--- a/net-p2p/bitcoind/ChangeLog
+++ b/net-p2p/bitcoind/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-p2p/bitcoind
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/bitcoind/ChangeLog,v 1.104 2015/03/14 19:41:34 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/bitcoind/ChangeLog,v 1.105 2015/05/27 01:35:06 blueness Exp $
+
+*bitcoind-0.10.2 (27 May 2015)
+
+ 27 May 2015; Anthony G. Basile <blueness@gentoo.org> +bitcoind-0.10.2.ebuild:
+ Version bump
14 Mar 2015; Anthony G. Basile <blueness@gentoo.org>
bitcoind-0.10.0-r1.ebuild:
diff --git a/net-p2p/bitcoind/bitcoind-0.10.2.ebuild b/net-p2p/bitcoind/bitcoind-0.10.2.ebuild
new file mode 100644
index 000000000000..551744600c4e
--- /dev/null
+++ b/net-p2p/bitcoind/bitcoind-0.10.2.ebuild
@@ -0,0 +1,77 @@
+# Copyright 2010-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/bitcoind/bitcoind-0.10.2.ebuild,v 1.1 2015/05/27 01:35:06 blueness Exp $
+
+EAPI=5
+
+BITCOINCORE_COMMITHASH="d8ac90184254fea3a7f4991fd0529dfbd750aea0"
+BITCOINCORE_LJR_PV="0.10.1"
+BITCOINCORE_LJR_DATE="20150428"
+BITCOINCORE_IUSE="examples ljr logrotate test upnp +wallet xt zeromq"
+BITCOINCORE_POLICY_PATCHES="cpfp dcmp rbf spamfilter"
+BITCOINCORE_NEED_LEVELDB=1
+BITCOINCORE_NEED_LIBSECP256K1=1
+inherit bash-completion-r1 bitcoincore user systemd
+
+DESCRIPTION="Original Bitcoin crypto-currency wallet for automated services"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ logrotate? (
+ app-admin/logrotate
+ )
+"
+DEPEND="${RDEPEND}"
+
+pkg_setup() {
+ local UG='bitcoin'
+ enewgroup "${UG}"
+ enewuser "${UG}" -1 -1 /var/lib/bitcoin "${UG}"
+}
+
+src_prepare() {
+ epatch "${FILESDIR}/0.10.0-openrc-compat.patch"
+ bitcoincore_src_prepare
+}
+
+src_configure() {
+ # NOTE: --enable-zmq actually disables it
+ bitcoincore_conf \
+ --with-daemon
+}
+
+src_install() {
+ bitcoincore_src_install
+
+ insinto /etc/bitcoin
+ newins "${FILESDIR}/bitcoin.conf" bitcoin.conf
+ fowners bitcoin:bitcoin /etc/bitcoin/bitcoin.conf
+ fperms 600 /etc/bitcoin/bitcoin.conf
+
+ newconfd "contrib/init/bitcoind.openrcconf" ${PN}
+ newinitd "contrib/init/bitcoind.openrc" ${PN}
+ systemd_dounit "${FILESDIR}/bitcoind.service"
+
+ keepdir /var/lib/bitcoin/.bitcoin
+ fperms 700 /var/lib/bitcoin
+ fowners bitcoin:bitcoin /var/lib/bitcoin/
+ fowners bitcoin:bitcoin /var/lib/bitcoin/.bitcoin
+ dosym /etc/bitcoin/bitcoin.conf /var/lib/bitcoin/.bitcoin/bitcoin.conf
+
+ dodoc doc/assets-attribution.md doc/tor.md
+ doman contrib/debian/manpages/{bitcoind.1,bitcoin.conf.5}
+
+ newbashcomp contrib/${PN}.bash-completion ${PN}
+
+ if use examples; then
+ docinto examples
+ dodoc -r contrib/{bitrpc,qos,spendfrom,tidy_datadir.sh}
+ fi
+
+ if use logrotate; then
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}/bitcoind.logrotate-r1" bitcoind
+ fi
+}