summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-03-17 23:18:08 +0000
committerMike Frysinger <vapier@gentoo.org>2006-03-17 23:18:08 +0000
commit40b405e1a97f191ad2d640e5f490b5e54fc41e6e (patch)
tree28fdb76c6cdfcd339e07f27eee33cbd1a3c88ab3
parentversion bump (diff)
downloadgentoo-2-40b405e1a97f191ad2d640e5f490b5e54fc41e6e.tar.gz
gentoo-2-40b405e1a97f191ad2d640e5f490b5e54fc41e6e.tar.bz2
gentoo-2-40b405e1a97f191ad2d640e5f490b5e54fc41e6e.zip
old
(Portage version: 2.1_pre6-r3)
-rw-r--r--sys-libs/readline/files/digest-readline-5.1-r24
-rw-r--r--sys-libs/readline/readline-5.1-r2.ebuild105
2 files changed, 0 insertions, 109 deletions
diff --git a/sys-libs/readline/files/digest-readline-5.1-r2 b/sys-libs/readline/files/digest-readline-5.1-r2
deleted file mode 100644
index 5c42d958cce4..000000000000
--- a/sys-libs/readline/files/digest-readline-5.1-r2
+++ /dev/null
@@ -1,4 +0,0 @@
-MD5 7ee5a692db88b30ca48927a13fd60e46 readline-5.1.tar.gz 2030276
-MD5 63faf622820ca0828131c8b5aeac1e6a readline51-001 2042
-RMD160 93dd36106f68682c4dc73a9b1ecf62bf7943fae4 readline51-001 2042
-SHA256 2c9786b231a454504c3f38361af6fd74e61789bc1009eba5fb2447b5a3ac5774 readline51-001 2042
diff --git a/sys-libs/readline/readline-5.1-r2.ebuild b/sys-libs/readline/readline-5.1-r2.ebuild
deleted file mode 100644
index 809f5cf01f72..000000000000
--- a/sys-libs/readline/readline-5.1-r2.ebuild
+++ /dev/null
@@ -1,105 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/readline/readline-5.1-r2.ebuild,v 1.8 2006/01/05 11:20:30 flameeyes Exp $
-
-inherit eutils multilib toolchain-funcs
-
-# Official patches
-# See ftp://ftp.cwru.edu/pub/bash/readline-5.1-patches/
-PLEVEL=1
-
-DESCRIPTION="Another cute console display library"
-HOMEPAGE="http://cnswww.cns.cwru.edu/php/chet/readline/rltop.html"
-SRC_URI="mirror://gnu/readline/${P}.tar.gz
- $(for ((i=1; i<=PLEVEL; i++)); do
- printf 'ftp://ftp.cwru.edu/pub/bash/readline-%s-patches/readline%s-%03d\n' \
- ${PV} ${PV/\.} ${i}
- printf 'mirror://gnu/bash/readline-%s-patches/readline%s-%03d\n' \
- ${PV} ${PV/\.} ${i}
- done)"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc-macos ~ppc64 ~s390 ~sh ~sparc ~x86"
-IUSE=""
-
-# We must be certain that we have a bash that is linked
-# to its internal readline, else we may get problems.
-RDEPEND=">=sys-libs/ncurses-5.2-r2"
-DEPEND="${RDEPEND}
- >=app-shells/bash-2.05b-r2"
-
-src_unpack() {
- unpack ${P}.tar.gz
-
- cd "${S}"
- # Official patches
- local i
- for ((i=1; i<=PLEVEL; i++)); do
- epatch "${DISTDIR}"/${PN}${PV/\.}-$(printf '%03d' ${i})
- done
- epatch "${FILESDIR}"/bash-3.0-etc-inputrc.patch
- epatch "${FILESDIR}"/${PN}-5.0-no_rpath.patch
- epatch "${FILESDIR}"/${P}-cleanups.patch
- epatch "${FILESDIR}"/${P}-rlfe-build.patch #116483
- epatch "${FILESDIR}"/${P}-rlfe-uclibc.patch
- epatch "${FILESDIR}/${P}-rlfe-libutil.patch"
-
- ln -s ../.. examples/rlfe/readline
-
- # force ncurses linking #71420
- sed -i -e 's:^SHLIB_LIBS=:SHLIB_LIBS=-lncurses:' support/shobj-conf || die "sed"
-}
-
-src_compile() {
- # the --libdir= is needed because if lib64 is a directory, it will default
- # to using that... even if CONF_LIBDIR isnt set or we're using a version
- # of portage without CONF_LIBDIR support.
- econf --with-curses --libdir=/usr/$(get_libdir) || die
- emake || die
-
- if ! tc-is-cross-compiler; then
- cd examples/rlfe
- econf || die
- emake || die "make rlfe failed"
- fi
-}
-
-src_install() {
- make DESTDIR="${D}" install || die
- dodir /$(get_libdir)
-
- if ! use userland_Darwin ; then
- mv "${D}"/usr/$(get_libdir)/*.so* "${D}"/$(get_libdir)
- chmod a+rx "${D}"/$(get_libdir)/*.so*
-
- # Bug #4411
- gen_usr_ldscript libreadline.so
- gen_usr_ldscript libhistory.so
- fi
-
- if ! tc-is-cross-compiler; then
- dobin examples/rlfe/rlfe || die
- fi
-
- dodoc CHANGELOG CHANGES README USAGE NEWS
- docinto ps
- dodoc doc/*.ps
- dohtml -r doc
-}
-
-pkg_preinst() {
- # Backwards compatibility #29865
- if [[ -e ${ROOT}/$(get_libdir)/libreadline.so.4 ]] ; then
- cp -pPR "${ROOT}"/$(get_libdir)/libreadline.so.4* "${D}"/$(get_libdir)/
- touch "${D}"/$(get_libdir)/libreadline.so.4*
- fi
-}
-
-pkg_postinst() {
- if [[ -e ${ROOT}/$(get_libdir)/libreadline.so.4 ]] ; then
- ewarn "Your old readline libraries have been copied over."
- ewarn "You should run 'revdep-rebuild --library libreadline.so.4' asap."
- ewarn "Once you have, you can safely delete /$(get_libdir)/libreadline.so.4*"
- fi
-}