summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBryan Stine <battousai@gentoo.org>2005-07-31 05:21:10 +0000
committerBryan Stine <battousai@gentoo.org>2005-07-31 05:21:10 +0000
commit3e7e4418c6dfc227ebbd579661f6db28d4f63ded (patch)
treef87b3492b569f8cfed1a74043d01a1866782eb00
parentStable amd64 (diff)
downloadgentoo-2-3e7e4418c6dfc227ebbd579661f6db28d4f63ded.tar.gz
gentoo-2-3e7e4418c6dfc227ebbd579661f6db28d4f63ded.tar.bz2
gentoo-2-3e7e4418c6dfc227ebbd579661f6db28d4f63ded.zip
Bump to 3.0.2, major patch updates.
(Portage version: 2.0.51.22-r1)
-rw-r--r--app-admin/bastille/ChangeLog9
-rw-r--r--app-admin/bastille/bastille-3.0.2.ebuild58
-rw-r--r--app-admin/bastille/files/bastille-3.0.2-firewall.init42
-rw-r--r--app-admin/bastille/files/digest-bastille-3.0.22
4 files changed, 110 insertions, 1 deletions
diff --git a/app-admin/bastille/ChangeLog b/app-admin/bastille/ChangeLog
index 1324a0424016..6b78601fecf8 100644
--- a/app-admin/bastille/ChangeLog
+++ b/app-admin/bastille/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-admin/bastille
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/bastille/ChangeLog,v 1.15 2005/04/21 14:12:44 blubb Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/bastille/ChangeLog,v 1.16 2005/07/31 05:21:10 battousai Exp $
+
+*bastille-3.0.2 (31 Jul 2005)
+
+ 31 Jul 2005; Bryan Stine <battousai@gentoo.org>
+ +files/bastille-3.0.2-firewall.init, +bastille-3.0.2.ebuild:
+ Bump to 3.0.2. Major patch updates. Also added new preset configuration
+ files, based on the retrofitted configs from the original distribution.
21 Apr 2005; Simon Stelling <blubb@gentoo.org> bastille-2.1.1-r3.ebuild:
stable on amd64
diff --git a/app-admin/bastille/bastille-3.0.2.ebuild b/app-admin/bastille/bastille-3.0.2.ebuild
new file mode 100644
index 000000000000..a6d1341ad241
--- /dev/null
+++ b/app-admin/bastille/bastille-3.0.2.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/bastille/bastille-3.0.2.ebuild,v 1.1 2005/07/31 05:21:10 battousai Exp $
+
+inherit eutils
+
+PATCHVER=0.1
+MY_PN=${PN/b/B}
+MY_P=${MY_PN}-${PV}
+S=${WORKDIR}/${MY_PN}
+DESCRIPTION="Bastille-Linux is a security hardening tool"
+HOMEPAGE="http://bastille-linux.org/"
+SRC_URI="mirror://sourceforge/${PN}-linux/${MY_P}.tar.bz2
+ mirror://gentoo/${P}-gentoo-${PATCHVER}.patch.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 ppc ~sparc alpha amd64"
+IUSE="X"
+
+RDEPEND="net-firewall/iptables
+ app-admin/logrotate
+ dev-perl/Curses
+ net-firewall/psad
+ X? ( dev-perl/perl-tk )"
+
+src_unpack() {
+ unpack ${A}
+ epatch ${WORKDIR}/${P}-gentoo-${PATCHVER}.patch
+
+ cd ${S}
+ cp ${FILESDIR}/bastille-${PV}-firewall.init ./bastille-firewall
+ chmod a+x Install.sh bastille-ipchains bastille-netfilter
+}
+
+src_install() {
+
+ cd ${S}
+ DESTDIR=${D} ./Install.sh
+
+ # Example configs
+ cd ${S}
+ insinto /usr/share/Bastille
+ doins *.config
+
+ exeinto /etc/init.d && newexe ${FILESDIR}/${P}-firewall.init ${PN}-firewall
+
+ # Documentation
+ cd ${S}
+ dodoc *.txt BUGS Change* README*
+}
+
+pkg_postinst() {
+ einfo "Please be aware that when using the Server Lax, Server Moderate, or"
+ einfo "Server Paranoia configurations, you may need to use InteractiveBastille"
+ einfo "to set any advanced network information, such as masquerading and"
+ einfo "internal interfaces, if you plan to use them."
+}
diff --git a/app-admin/bastille/files/bastille-3.0.2-firewall.init b/app-admin/bastille/files/bastille-3.0.2-firewall.init
new file mode 100644
index 000000000000..5537418db804
--- /dev/null
+++ b/app-admin/bastille/files/bastille-3.0.2-firewall.init
@@ -0,0 +1,42 @@
+#!/sbin/runscript
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/bastille/files/bastille-3.0.2-firewall.init,v 1.1 2005/07/31 05:21:10 battousai Exp $
+
+opts="start stop"
+BASTILLEPREFIX="/usr/share/Bastille"
+
+depend() {
+ need logger
+}
+
+start() {
+ # "Borrowed" from the original bastille-firewall init script ((c) P. Watkins)
+ REALSCRIPT=${BASTILLEPREFIX}/bastille-ipchains
+ if [ -n "$(uname -r | awk -F. ' $1 == 2 && $2 > 2 {print}')" ]; then
+ # We are using Linux 2.3 or newer; use the netfilter script if available
+ if [ -x ${BASTILLEPREFIX}/bastille-netfilter ]; then
+ REALSCRIPT=${BASTILLEPREFIX}/bastille-netfilter
+ fi
+ fi
+
+ ebegin "Starting bastille-firewall"
+ $REALSCRIPT start
+ eend $? "Failed to start bastille-firewall"
+}
+
+stop() {
+ # "Borrowed" from the original bastille-firewall init script ((c) P. Watkins)
+ REALSCRIPT=${BASTILLEPREFIX}/bastille-ipchains
+ if [ -n "$(uname -r | awk -F. ' $1 == 2 && $2 > 2 {print}')" ]; then
+ # We are using Linux 2.3 or newer; use the netfilter script if available
+ if [ -x ${BASTILLEPREFIX}/bastille-netfilter ]; then
+ REALSCRIPT=${BASTILLEPREFIX}/bastille-netfilter
+ fi
+ fi
+
+ ebegin "Stopping bastille-firewall"
+ $REALSCRIPT stop
+ eend $? "Failed to stop bastille-firewall"
+}
+
diff --git a/app-admin/bastille/files/digest-bastille-3.0.2 b/app-admin/bastille/files/digest-bastille-3.0.2
new file mode 100644
index 000000000000..7db9702f0c71
--- /dev/null
+++ b/app-admin/bastille/files/digest-bastille-3.0.2
@@ -0,0 +1,2 @@
+MD5 660f3cbcff517e7c9957f3f0248ff337 Bastille-3.0.2.tar.bz2 328161
+MD5 15e5d3d52bb431da818b3f87d88e8b98 bastille-3.0.2-gentoo-0.1.patch.bz2 16334