summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-06-29 20:17:43 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-06-29 20:17:43 +0000
commit3c40e3136b8c33c31fadeeb8502b85fc9d423599 (patch)
treee5c2cea7f0ad1ff86efb93feaedfccde21968c90
parentDrop obsolete X flag from IUSE (diff)
downloadgentoo-2-3c40e3136b8c33c31fadeeb8502b85fc9d423599.tar.gz
gentoo-2-3c40e3136b8c33c31fadeeb8502b85fc9d423599.tar.bz2
gentoo-2-3c40e3136b8c33c31fadeeb8502b85fc9d423599.zip
Fix building with -Wl,--as-needed wrt #246729 by Diego E. Pettenò.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
-rw-r--r--app-accessibility/gnopernicus/ChangeLog8
-rw-r--r--app-accessibility/gnopernicus/files/gnopernicus-1.0.7-asneeded.patch18
-rw-r--r--app-accessibility/gnopernicus/gnopernicus-1.0.7.ebuild16
3 files changed, 35 insertions, 7 deletions
diff --git a/app-accessibility/gnopernicus/ChangeLog b/app-accessibility/gnopernicus/ChangeLog
index bbdc0026fd41..4d3d61e2dc72 100644
--- a/app-accessibility/gnopernicus/ChangeLog
+++ b/app-accessibility/gnopernicus/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-accessibility/gnopernicus
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/gnopernicus/ChangeLog,v 1.102 2008/11/23 17:49:10 patrick Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/gnopernicus/ChangeLog,v 1.103 2010/06/29 20:17:43 ssuominen Exp $
+
+ 29 Jun 2010; Samuli Suominen <ssuominen@gentoo.org>
+ gnopernicus-1.0.7.ebuild, +files/gnopernicus-1.0.7-asneeded.patch:
+ Fix building with -Wl,--as-needed wrt #246729 by Diego E. Pettenò.
23 Nov 2008; Patrick Lauer <patrick@gentoo.org> gnopernicus-1.0.7.ebuild:
Fixing homepage
diff --git a/app-accessibility/gnopernicus/files/gnopernicus-1.0.7-asneeded.patch b/app-accessibility/gnopernicus/files/gnopernicus-1.0.7-asneeded.patch
new file mode 100644
index 000000000000..0e9d1e4fcc8b
--- /dev/null
+++ b/app-accessibility/gnopernicus/files/gnopernicus-1.0.7-asneeded.patch
@@ -0,0 +1,18 @@
+--- speech/test/Makefile.am
++++ speech/test/Makefile.am
+@@ -3,14 +3,13 @@
+ noinst_PROGRAMS = tester
+
+ tester_SOURCES = tester.c
+-tester_LDFLAGS = $(LIBSRS_LIBS)
+
+ INCLUDES = -I$(srcdir)/../libsrs \
+ -I$(top_srcdir)/srconf/libsrconf \
+ $(LIBSRS_CFLAGS) \
+ -DG_LOG_DOMAIN=\"gnopernicus\"
+
+-LDADD = ../libsrs/libsrs.la ../../srconf/libsrconf/libsrconf.la ../../srutil/libsrutil.la
++LDADD = $(LIBSRS_LIBS) ../libsrs/libsrs.la ../../srconf/libsrconf/libsrconf.la ../../srutil/libsrutil.la
+
+
+ EXTRA_DIST = srsml.xml
diff --git a/app-accessibility/gnopernicus/gnopernicus-1.0.7.ebuild b/app-accessibility/gnopernicus/gnopernicus-1.0.7.ebuild
index dab4cf78da23..6cc2c0f7c6fa 100644
--- a/app-accessibility/gnopernicus/gnopernicus-1.0.7.ebuild
+++ b/app-accessibility/gnopernicus/gnopernicus-1.0.7.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/gnopernicus/gnopernicus-1.0.7.ebuild,v 1.10 2008/11/23 17:49:10 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/gnopernicus/gnopernicus-1.0.7.ebuild,v 1.11 2010/06/29 20:17:43 ssuominen Exp $
-inherit gnome2
+EAPI=2
+inherit autotools eutils gnome2
DESCRIPTION="Software tools for blind and visually impaired"
HOMEPAGE="http://www.baum.ro/index.php?language=en&pagina=produse&subpag=gnopernicus"
@@ -25,16 +26,21 @@ RDEPEND=">=gnome-base/gconf-2.6.1
>=app-accessibility/gnome-mag-0.11.7
>=gnome-extra/libgail-gnome-1.0
brltty? ( >=app-accessibility/brltty-3.6 )"
-
DEPEND="${RDEPEND}
>=dev-util/intltool-0.29
>=dev-util/pkgconfig-0.9
app-text/scrollkeeper
+ dev-util/gtk-doc-am
doc? ( >=dev-util/gtk-doc-1 )"
DOCS="AUTHORS ChangeLog NEWS README"
pkg_setup() {
- G2CONF="$(use_enable ipv6) \
+ G2CONF="$(use_enable ipv6)
$(use_enable brltty)"
}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-asneeded.patch
+ eautoreconf
+}