summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2008-08-08 23:20:11 +0000
committerUlrich Müller <ulm@gentoo.org>2008-08-08 23:20:11 +0000
commit30a61f4a633880f6a88d5600f604c85f396b7041 (patch)
tree668bca610a45bf47602ccbfd86861bd7b6f7130f
parentRemove old. (diff)
downloadgentoo-2-30a61f4a633880f6a88d5600f604c85f396b7041.tar.gz
gentoo-2-30a61f4a633880f6a88d5600f604c85f396b7041.tar.bz2
gentoo-2-30a61f4a633880f6a88d5600f604c85f396b7041.zip
Initial import, bug 228723, from Emacs overlay.
(Portage version: 2.2_rc6/cvs/Linux 2.6.25-gentoo-r6 i686)
-rw-r--r--app-emacs/bongo/ChangeLog11
-rw-r--r--app-emacs/bongo/Manifest6
-rw-r--r--app-emacs/bongo/bongo-20070619.ebuild55
-rw-r--r--app-emacs/bongo/files/50bongo-gentoo.el6
-rw-r--r--app-emacs/bongo/files/bongo-20070619-fix-require.patch11
-rw-r--r--app-emacs/bongo/metadata.xml33
6 files changed, 122 insertions, 0 deletions
diff --git a/app-emacs/bongo/ChangeLog b/app-emacs/bongo/ChangeLog
new file mode 100644
index 000000000000..5410efce3590
--- /dev/null
+++ b/app-emacs/bongo/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for app-emacs/bongo
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/bongo/ChangeLog,v 1.1 2008/08/08 23:20:10 ulm Exp $
+
+*bongo-20070619 (08 Aug 2008)
+
+ 08 Aug 2008; Ulrich Mueller <ulm@gentoo.org> +files/50bongo-gentoo.el,
+ +files/bongo-20070619-fix-require.patch, +metadata.xml,
+ +bongo-20070619.ebuild:
+ Initial import, bug 228723, from Emacs overlay. Ebuild contributed by me.
+
diff --git a/app-emacs/bongo/Manifest b/app-emacs/bongo/Manifest
new file mode 100644
index 000000000000..63ec80db1613
--- /dev/null
+++ b/app-emacs/bongo/Manifest
@@ -0,0 +1,6 @@
+AUX 50bongo-gentoo.el 193 RMD160 2f2df265a712a2955d95c6b6a9f9c8d0e75345bc SHA1 db2b13cb5a6dda0df9c5552ddcf742a17bd4ae8a SHA256 268d57ad3d84870af45d87c1a060df2a5e06b11127d24b140a41614e6be4866e
+AUX bongo-20070619-fix-require.patch 224 RMD160 e4a1ce68d5fc982251d9bbbaa1d2aed417c20ece SHA1 0badaea162b26bfd54cd5d72de73e4417b033c1a SHA256 3570a83fa4c77e99f761475937587e4d0485661896adc79159fdebd44a04a879
+DIST bongo-20070619.tar.bz2 97341 RMD160 84fbc62b64541b2d19ab0100a944ef6d2dab98d8 SHA1 59a84838ea6550f6b128b3e84dacd6c9ce3d57ef SHA256 a4758e6f60e32f90aa0416c5f5a522dc8edb131ce4aa76212b542b941e12a4d8
+EBUILD bongo-20070619.ebuild 1300 RMD160 3a8117621d5819e38275168eddb5d284a89cc085 SHA1 38f7e4546dd02fc7e5b3105c8f9ea70c5d15f77a SHA256 46303e51a5a5d852d3dbdd30a635106729494ade353d0de848d4fd1fd76e4868
+MISC ChangeLog 381 RMD160 01c18ba3d0650eb99fa640f1847767540a8c7b82 SHA1 933da49cb7aa9983606422933864e63dec420e82 SHA256 1721c828ba1a0077f0b0e4829e6fb0af867d15065abfd9a8a526467f89759414
+MISC metadata.xml 1605 RMD160 37c101e5e660f8fcb341ba32633e13eb8f6cb12c SHA1 d1994fccafc1d6c96eb5df8e1abfbf096e4183d7 SHA256 abec0c0a30b4c9580b2560167739abed06a22bf06ae9fe83eea23c1a94afddb9
diff --git a/app-emacs/bongo/bongo-20070619.ebuild b/app-emacs/bongo/bongo-20070619.ebuild
new file mode 100644
index 000000000000..a4a598c8fc02
--- /dev/null
+++ b/app-emacs/bongo/bongo-20070619.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/bongo/bongo-20070619.ebuild,v 1.1 2008/08/08 23:20:10 ulm Exp $
+
+NEED_EMACS=22
+
+inherit elisp eutils
+
+DESCRIPTION="Buffer-oriented media player for Emacs"
+HOMEPAGE="http://www.brockman.se/software/bongo/"
+# Darcs snapshot of http://www.brockman.se/software/bongo/
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="GPL-2 FDL-1.2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+# NOTE: Bongo can use almost anything for playing media files, therefore
+# the dependency possibilities are so broad that we refrain from including
+# any media players explicitly in DEPEND/RDEPEND.
+
+DEPEND="app-emacs/volume"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}"
+SITEFILE=50${PN}-gentoo.el
+DOCS="NEWS README tree-from-tags.rb"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # We need Emacs 22 for image-load-path anyway, so don't bother with 21.
+ rm -f bongo-emacs21.el
+
+ epatch "${FILESDIR}/${P}-fix-require.patch"
+}
+
+src_compile() {
+ elisp_src_compile
+ makeinfo bongo.texinfo || die "makeinfo failed"
+}
+
+src_install() {
+ elisp_src_install
+
+ insinto "${SITEETC}/${PN}"
+ doins *.pbm *.png || die "doins failed"
+
+ # Requires additional dependency ruby-taglib; install in doc for now.
+ #dobin tree-from-tags.rb || die "dobin failed"
+
+ doinfo bongo.info || die "doinfo failed"
+}
diff --git a/app-emacs/bongo/files/50bongo-gentoo.el b/app-emacs/bongo/files/50bongo-gentoo.el
new file mode 100644
index 000000000000..34745b82d048
--- /dev/null
+++ b/app-emacs/bongo/files/50bongo-gentoo.el
@@ -0,0 +1,6 @@
+
+;;; bongo site-lisp configuration
+
+(add-to-list 'load-path "@SITELISP@")
+(add-to-list 'image-load-path "@SITEETC@" t)
+(autoload 'bongo "bongo" "Start Bongo by switching to a Bongo buffer." t)
diff --git a/app-emacs/bongo/files/bongo-20070619-fix-require.patch b/app-emacs/bongo/files/bongo-20070619-fix-require.patch
new file mode 100644
index 000000000000..6b3e6ff588df
--- /dev/null
+++ b/app-emacs/bongo/files/bongo-20070619-fix-require.patch
@@ -0,0 +1,11 @@
+--- bongo-orig/bongo.el 2007-06-19 16:51:37.000000000 +0200
++++ bongo/bongo.el 2008-06-22 15:30:23.000000000 +0200
+@@ -67,7 +67,7 @@
+
+ ;;; Code:
+
+-(eval-when-compile
++(eval-and-compile
+ (require 'cl)
+ (require 'rx))
+
diff --git a/app-emacs/bongo/metadata.xml b/app-emacs/bongo/metadata.xml
new file mode 100644
index 000000000000..a65893303f93
--- /dev/null
+++ b/app-emacs/bongo/metadata.xml
@@ -0,0 +1,33 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>emacs</herd>
+<longdescription>
+ Bongo is a buffer-oriented media player for Emacs, contemporary with and
+ comparable to <pkg>app-emacs/emms</pkg>.
+
+ Notable features of Bongo include
+ * separate playlist and library buffers (each of which you may have any
+ number — even zero of both is okay if you don’t need playlist
+ functionality),
+ * hierarchical buffers with collapsable sections for each artist and album,
+ * familiar Emacs bindings for editing Bongo buffers (edit playlists much
+ like you would regular text),
+ * a nice visual seeking interface doubling as a progress meter (hit ‘s’),
+ * a visual audio volume control (<pkg>app-emacs/volume</pkg>, which is
+ actually a stand-alone package),
+ * built-in support for playing and retrieving information about audio CDs,
+ * built-in support for submitting information to Last.fm using
+ ‘lastfmsubmitd’,
+ * the ability to perform arbitrary actions (stopping playback is a simple
+ example) once playback reaches certain points in the playlist, using
+ so-called “action tracks”,
+ * an XMMS-like keymap for XMMS refugees,
+ * zero-configuration, out-of-the-box rock’n’roll action.
+
+ Bongo currently comes with backends for VLC, mpg321, ogg123, speexdec,
+ TiMidity and MikMod. All backends support pausing and resuming, but only VLC
+ and mpg321 support interactive seeking. Defining your own non-interactive
+ backends is very simple.
+</longdescription>
+</pkgmetadata>