summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLance Albertson <ramereth@gentoo.org>2011-03-09 18:37:10 +0000
committerLance Albertson <ramereth@gentoo.org>2011-03-09 18:37:10 +0000
commit2b47c9c298107db0ef5f02d18236c6383b8ffc93 (patch)
treeb12749af70a609d12cd6e51596714004565748c8
parentversion bump (diff)
downloadgentoo-2-2b47c9c298107db0ef5f02d18236c6383b8ffc93.tar.gz
gentoo-2-2b47c9c298107db0ef5f02d18236c6383b8ffc93.tar.bz2
gentoo-2-2b47c9c298107db0ef5f02d18236c6383b8ffc93.zip
version bump
(Portage version: 2.1.9.25/cvs/Linux x86_64)
-rw-r--r--app-admin/mcollective/ChangeLog8
-rw-r--r--app-admin/mcollective/mcollective-1.1.3.ebuild59
2 files changed, 66 insertions, 1 deletions
diff --git a/app-admin/mcollective/ChangeLog b/app-admin/mcollective/ChangeLog
index 2026af7f9c14..fb7bdb135014 100644
--- a/app-admin/mcollective/ChangeLog
+++ b/app-admin/mcollective/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-admin/mcollective
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/mcollective/ChangeLog,v 1.1 2011/03/01 02:18:33 ramereth Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/mcollective/ChangeLog,v 1.2 2011/03/09 18:37:10 ramereth Exp $
+
+*mcollective-1.1.3 (09 Mar 2011)
+
+ 09 Mar 2011; Lance Albertson <ramereth@gentoo.org>
+ +mcollective-1.1.3.ebuild:
+ Version bump
*mcollective-1.0.1 (01 Mar 2011)
diff --git a/app-admin/mcollective/mcollective-1.1.3.ebuild b/app-admin/mcollective/mcollective-1.1.3.ebuild
new file mode 100644
index 000000000000..a0ec3f848e7f
--- /dev/null
+++ b/app-admin/mcollective/mcollective-1.1.3.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/mcollective/mcollective-1.1.3.ebuild,v 1.1 2011/03/09 18:37:09 ramereth Exp $
+
+EAPI="2"
+
+USE_RUBY="ruby18 ree18"
+
+inherit ruby-ng
+
+DESCRIPTION="Framework to build server orchestration or parallel job execution
+systems"
+HOMEPAGE="http://marionette-collective.org/"
+SRC_URI="http://puppetlabs.com/downloads/mcollective/${P}.tgz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="doc +client"
+
+DEPEND=""
+RDEPEND="dev-ruby/stomp"
+
+src_compile() {
+ einfo "nothing to compile"
+}
+
+each_ruby_install() {
+ doruby -r lib/*
+ insinto /usr/share/mcollective
+ doins -r plugins
+ use client && dosbin mc-* mco
+ newsbin mcollectived.rb mcollectived
+ if use doc ; then
+ dohtml -r doc/*
+ insinto /usr/share/doc/${P}/ext
+ doins -r ext/*
+ fi
+ newinitd "${FILESDIR}"/mcollectived.initd mcollectived
+ insinto /etc/mcollective
+ cd etc
+ for cfg in *.dist ; do
+ newins "${cfg}" "${cfg%%.dist}"
+ dosed "s:^libdir.*:libdir = /usr/share/mcollective/plugins:" \
+ /etc/mcollective/${cfg%%.dist}
+ done
+}
+
+pkg_postinst() {
+ einfo "Mcollective requires a stomp server installed and functioning before"
+ einfo "you can use it. The recommended server to use is ActiveMQ [1] but"
+ einfo "any other stomp compatible server should work."
+ einfo
+ einfo "It is recommended you read the \'getting started\' guide [2] if this"
+ einfo "is a new installation"
+ einfo
+ einfo "[1] http://activemq.apache.org/"
+ einfo "[2] http://code.google.com/p/mcollective/wiki/GettingStarted"
+}