summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarien Zwart <marienz@gentoo.org>2005-11-27 22:13:48 +0000
committerMarien Zwart <marienz@gentoo.org>2005-11-27 22:13:48 +0000
commit2b3e44f3719657ec206d99ec2d8f0eae8884c5f9 (patch)
treec810bfe4af18fb300e2390036c38dead08d463b3
parentstable on ppc64 (diff)
downloadgentoo-2-2b3e44f3719657ec206d99ec2d8f0eae8884c5f9.tar.gz
gentoo-2-2b3e44f3719657ec206d99ec2d8f0eae8884c5f9.tar.bz2
gentoo-2-2b3e44f3719657ec206d99ec2d8f0eae8884c5f9.zip
Version bump to 2.0.1 for people who cannot use 2.1.0 for some reason (based on the 2.1.0 ebuild, not the 2.0.0 ebuild, bug #80639)
(Portage version: 2.0.53_rc7)
-rw-r--r--dev-python/twisted/ChangeLog8
-rw-r--r--dev-python/twisted/Manifest2
-rw-r--r--dev-python/twisted/files/digest-twisted-2.0.11
-rw-r--r--dev-python/twisted/twisted-2.0.1.ebuild101
4 files changed, 111 insertions, 1 deletions
diff --git a/dev-python/twisted/ChangeLog b/dev-python/twisted/ChangeLog
index 13c2d0096b8c..8a1171db64ad 100644
--- a/dev-python/twisted/ChangeLog
+++ b/dev-python/twisted/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/twisted
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted/ChangeLog,v 1.53 2005/11/23 18:27:14 marienz Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted/ChangeLog,v 1.54 2005/11/27 22:13:48 marienz Exp $
+
+*twisted-2.0.1 (27 Nov 2005)
+
+ 27 Nov 2005; Marien Zwart <marienz@gentoo.org> +twisted-2.0.1.ebuild:
+ Version bump to 2.0.1 for people who cannot use 2.1.0 for some reason (based
+ on the 2.1.0 ebuild, not the 2.0.0 ebuild, bug #80639)
23 Nov 2005; Marien Zwart <marienz@gentoo.org> twisted-2.1.0.ebuild:
Clean up after running the tests.
diff --git a/dev-python/twisted/Manifest b/dev-python/twisted/Manifest
index 9971689e5da9..6caa7679001d 100644
--- a/dev-python/twisted/Manifest
+++ b/dev-python/twisted/Manifest
@@ -2,6 +2,7 @@ MD5 86a97a92a62ab4e3bd1c1d2aae314e5b ChangeLog 10657
MD5 9e8836d4aec3a1a4f688add9c6c64877 files/digest-twisted-1.2.0 74
MD5 387f6df81a68c591e6f30fe8878d964b files/digest-twisted-1.3.0 74
MD5 48ff6eb1136ce5dd8f785e589a7723d5 files/digest-twisted-2.0.0 67
+MD5 1d3126a7c14d292951e51397db90bc83 files/digest-twisted-2.0.1 67
MD5 2b9136e1ddf2b7467c5f6a71d87f90c2 files/digest-twisted-2.1.0 67
MD5 7ec438488427334851e2eb977e4d8073 files/twistd.conf 277
MD5 ca8f49d9aaa78d3814f75d8d2d861469 files/twistd.init 545
@@ -12,4 +13,5 @@ MD5 f21532a778f6bd2aa2879327084e8aa5 metadata.xml 492
MD5 b334a51322c3da107d175c71db5c5b68 twisted-1.2.0.ebuild 996
MD5 742e8cfdb91ef5a2685eb8734f209c41 twisted-1.3.0.ebuild 1061
MD5 7d5efe87283a25e3cf2f87d1a0e0c8b5 twisted-2.0.0.ebuild 899
+MD5 f3a67bd8e92c42b4e2a9d9ca9dd844cb twisted-2.0.1.ebuild 2909
MD5 6b2ba4eb2cb562c8c94627d2327ec98e twisted-2.1.0.ebuild 3204
diff --git a/dev-python/twisted/files/digest-twisted-2.0.1 b/dev-python/twisted/files/digest-twisted-2.0.1
new file mode 100644
index 000000000000..841c022999ed
--- /dev/null
+++ b/dev-python/twisted/files/digest-twisted-2.0.1
@@ -0,0 +1 @@
+MD5 6cf0ebb84731f8c2c45ea125efda77fe Twisted-2.0.1.tar.bz2 1061899
diff --git a/dev-python/twisted/twisted-2.0.1.ebuild b/dev-python/twisted/twisted-2.0.1.ebuild
new file mode 100644
index 000000000000..fcd4e474acf6
--- /dev/null
+++ b/dev-python/twisted/twisted-2.0.1.ebuild
@@ -0,0 +1,101 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted/twisted-2.0.1.ebuild,v 1.1 2005/11/27 22:13:48 marienz Exp $
+
+inherit eutils distutils versionator
+
+MY_P=Twisted-${PV}
+
+DESCRIPTION="An asynchronous networking framework written in Python"
+HOMEPAGE="http://www.twistedmatrix.com/"
+SRC_URI="http://tmrc.mit.edu/mirror/twisted/Twisted/$(get_version_component_range 1-2)/${MY_P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE="gtk serial crypt"
+
+DEPEND=">=dev-lang/python-2.2
+ >=net-zope/zopeinterface-3.0.1
+ serial? ( dev-python/pyserial )
+ crypt? ( >=dev-python/pyopenssl-0.5.1 )
+ gtk? ( >=dev-python/pygtk-1.99* )"
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS="ChangeLog CREDITS INSTALL NEWS README"
+
+src_install() {
+ distutils_src_install
+
+ # get rid of this to prevent collision-protect from killing us. it
+ # is regenerated in pkg_postinst.
+ rm "${D}/usr/$(get_libdir)"/python*/site-packages/twisted/plugins/dropin.cache
+
+ # weird pattern to avoid installing the index.xhtml page
+ doman doc/man/*.?
+ insinto /usr/share/doc/${PF}
+ doins -r $(find doc -mindepth 1 -maxdepth 1 -not -name man)
+
+ # workaround for a possible portage bug
+ mkdir -p "${D}/etc/conf.d/"
+ newconfd "${FILESDIR}/twistd.conf" twistd
+ newinitd "${FILESDIR}/twistd.init" twistd
+
+ # zsh completion
+ insinto /usr/share/zsh/site-functions/
+ doins twisted/python/_twisted_zsh_stub
+}
+
+update_plugin_cache() {
+ python_version
+ local tpath="${ROOT}usr/$(get_libdir)/python${PYVER}/site-packages/twisted"
+ # we have to remove the cache or removed plugins won't be removed
+ # from the cache (http://twistedmatrix.com/bugs/issue926)
+ [[ -e "${tpath}/plugins/dropin.cache" ]] && rm -f "${tpath}/plugins/dropin.cache"
+ if [[ -e "${tpath}/plugin.py" ]]; then
+ # twisted is still installed, update.
+ # we have to use getPlugIns here for <=twisted-2.0.1 compatibility
+ einfo "Regenerating plugin cache"
+ python -c "from twisted.plugin import IPlugin, getPlugIns;list(getPlugIns(IPlugin))"
+ fi
+}
+
+pkg_postinst() {
+ distutils_pkg_postinst
+ update_plugin_cache
+ einfo
+ einfo "If you upgraded from twisted 1.3 or earlier you may want to"
+ einfo
+ einfo " # emerge twisted-sumo"
+ einfo
+ einfo "to get all of the packages back."
+ einfo
+}
+
+pkg_postrm() {
+ distutils_pkg_postrm
+ update_plugin_cache
+}
+
+src_test() {
+ python_version
+
+ if has_version ">=dev-lang/python-2.3"; then
+ "${python}" setup.py install --root="${T}/tests" --no-compile || die
+ else
+ "${python}" setup.py install --root="${T}/tests" || die
+ fi
+
+ cd "${T}/tests/usr/$(get_libdir)/python${PYVER}/site-packages/" || die
+
+ # prevent it from pulling in plugins from already installed
+ # twisted packages
+ rm twisted/plugins/__init__.py || die
+
+ # an empty file doesn't work because the tests check for
+ # docstrings in all packages
+ echo "'''plugins stub'''" > twisted/plugins/__init__.py || die
+
+ "${T}"/tests/usr/bin/trial -R twisted || die "trial failed"
+}