summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2009-01-05 22:01:44 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2009-01-05 22:01:44 +0000
commit25334fedda1ba9c12c13365cf4a99d7c152dc318 (patch)
tree93deac2e49fe6d29a4d3162862893cc4e9fc6a68
parentamd64/x86 stable, bug #251173 (diff)
downloadgentoo-2-25334fedda1ba9c12c13365cf4a99d7c152dc318.tar.gz
gentoo-2-25334fedda1ba9c12c13365cf4a99d7c152dc318.tar.bz2
gentoo-2-25334fedda1ba9c12c13365cf4a99d7c152dc318.zip
Bump to 2.6.2.
(Portage version: 2.2_rc20/cvs/Linux 2.6.24-gentoo-r8-mactel x86_64)
-rw-r--r--dev-cpp/bakery/ChangeLog9
-rw-r--r--dev-cpp/bakery/bakery-2.6.2.ebuild49
2 files changed, 56 insertions, 2 deletions
diff --git a/dev-cpp/bakery/ChangeLog b/dev-cpp/bakery/ChangeLog
index e98afaeac00e..e7ce920bedb6 100644
--- a/dev-cpp/bakery/ChangeLog
+++ b/dev-cpp/bakery/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-cpp/bakery
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/bakery/ChangeLog,v 1.9 2008/06/30 21:19:52 eva Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/bakery/ChangeLog,v 1.10 2009/01/05 22:01:44 eva Exp $
+
+*bakery-2.6.2 (05 Jan 2009)
+
+ 05 Jan 2009; Gilles Dartiguelongue <eva@gentoo.org> +bakery-2.6.2.ebuild:
+ Bump to 2.6.2.
*bakery-2.4.4 (30 Jun 2008)
diff --git a/dev-cpp/bakery/bakery-2.6.2.ebuild b/dev-cpp/bakery/bakery-2.6.2.ebuild
new file mode 100644
index 000000000000..efe57f85071a
--- /dev/null
+++ b/dev-cpp/bakery/bakery-2.6.2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/bakery/bakery-2.6.2.ebuild,v 1.1 2009/01/05 22:01:44 eva Exp $
+
+inherit gnome2
+
+DESCRIPTION="Bakery is a C++ Framework for creating GNOME applications using gtkmm."
+HOMEPAGE="http://bakery.sourceforge.net/"
+LICENSE="GPL-2"
+
+SLOT="2.6"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="doc examples"
+
+RDEPEND=">=dev-cpp/gtkmm-2.10
+ >=dev-cpp/gconfmm-2.6
+ >=dev-cpp/libglademm-2.4
+ >=dev-cpp/libxmlpp-2.8
+ >=dev-cpp/glibmm-2.16"
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.25
+ >=dev-util/pkgconfig-0.12"
+
+DOCS="AUTHORS COPYING ChangeLog INSTALL NEWS README"
+
+pkg_setup() {
+ G2CONF="${G2CONF} --disable-option-checking --disable-maemo"
+}
+
+src_unpack() {
+ gnome2_src_unpack
+
+ #sed -i "/AM_INIT/ a \AM_MAINTAINER_MODE" configure.in || \
+ # die "sed maintainer-mode failed"
+
+ # should be configured via configure switch
+ if ! use examples ; then
+ sed 's/^\(SUBDIRS =.*\)examples\(.*\)$/\1\2/' \
+ -i Makefile.am Makefile.in || \
+ die "sed Makefile.am failed"
+ fi
+
+ #eautoreconf
+}
+
+src_install() {
+ gnome2_src_install
+ use doc && dohtml docs/*.html docs/reference/*.html
+}