summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2012-05-22 03:47:18 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2012-05-22 03:47:18 +0000
commit234c6345cf2ede87b396d46156a1cc9983e2bee5 (patch)
tree548fc97ac0a6c669267b311bb8a995a4b0c7e600
parentFix parallel build failure #416987 (diff)
downloadgentoo-2-234c6345cf2ede87b396d46156a1cc9983e2bee5.tar.gz
gentoo-2-234c6345cf2ede87b396d46156a1cc9983e2bee5.tar.bz2
gentoo-2-234c6345cf2ede87b396d46156a1cc9983e2bee5.zip
Version bump with completion improvements.
(Portage version: 2.2.0_alpha107/cvs/Linux x86_64)
-rw-r--r--x11-libs/gtksourceview/ChangeLog8
-rw-r--r--x11-libs/gtksourceview/gtksourceview-3.4.2.ebuild60
2 files changed, 67 insertions, 1 deletions
diff --git a/x11-libs/gtksourceview/ChangeLog b/x11-libs/gtksourceview/ChangeLog
index b1d4446764c4..31fa8b6f6750 100644
--- a/x11-libs/gtksourceview/ChangeLog
+++ b/x11-libs/gtksourceview/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-libs/gtksourceview
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtksourceview/ChangeLog,v 1.225 2012/05/15 23:27:13 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtksourceview/ChangeLog,v 1.226 2012/05/22 03:47:18 tetromino Exp $
+
+*gtksourceview-3.4.2 (22 May 2012)
+
+ 22 May 2012; Alexandre Rostovtsev <tetromino@gentoo.org>
+ +gtksourceview-3.4.2.ebuild:
+ Version bump with completion improvements.
15 May 2012; Alexis Ballier <aballier@gentoo.org>
gtksourceview-2.10.5-r2.ebuild, gtksourceview-3.4.1.ebuild:
diff --git a/x11-libs/gtksourceview/gtksourceview-3.4.2.ebuild b/x11-libs/gtksourceview/gtksourceview-3.4.2.ebuild
new file mode 100644
index 000000000000..30b73e2892a9
--- /dev/null
+++ b/x11-libs/gtksourceview/gtksourceview-3.4.2.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtksourceview/gtksourceview-3.4.2.ebuild,v 1.1 2012/05/22 03:47:18 tetromino Exp $
+
+EAPI="4"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+
+inherit gnome2 virtualx
+
+DESCRIPTION="A text widget implementing syntax highlighting and other features"
+HOMEPAGE="http://projects.gnome.org/gtksourceview/"
+
+LICENSE="GPL-2"
+SLOT="3.0"
+IUSE="doc glade +introspection"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-solaris"
+
+# Note: has native OSX support, prefix teams, attack!
+RDEPEND=">=x11-libs/gtk+-3.4:3[introspection?]
+ >=dev-libs/libxml2-2.6:2
+ >=dev-libs/glib-2.32:2
+ glade? ( >=dev-util/glade-3.9:3.10 )
+ introspection? ( >=dev-libs/gobject-introspection-0.9.0 )"
+DEPEND="${RDEPEND}
+ >=sys-devel/gettext-0.17
+ >=dev-util/intltool-0.40
+ virtual/pkgconfig
+ doc? ( >=dev-util/gtk-doc-1.11 )"
+
+pkg_setup() {
+ DOCS="AUTHORS ChangeLog HACKING MAINTAINERS NEWS README"
+ G2CONF="${G2CONF}
+ --disable-deprecations
+ --enable-providers
+ $(use_enable glade glade-catalog)
+ $(use_enable introspection)"
+}
+
+src_prepare() {
+ gnome2_src_prepare
+
+ sed -i -e 's:--warn-all::' gtksourceview/Makefile.in || die
+
+ # Skip broken test until upstream bug #621383 is solved
+ sed -e "/guess-language/d" \
+ -e "/get-language/d" \
+ -i tests/test-languagemanager.c || die
+}
+
+src_test() {
+ Xemake check
+}
+
+src_install() {
+ gnome2_src_install
+
+ insinto /usr/share/${PN}-3.0/language-specs
+ doins "${FILESDIR}"/2.0/gentoo.lang
+}