summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAli Polatel <hawking@gentoo.org>2008-01-31 15:30:33 +0000
committerAli Polatel <hawking@gentoo.org>2008-01-31 15:30:33 +0000
commit117618029b57a537cf193e63438f75f73d2104ab (patch)
treef9eff30e83125274ffe7c6e6a35a3ffa3a26e0a3
parentStable on ppc wrt bug 208032 (diff)
downloadgentoo-2-117618029b57a537cf193e63438f75f73d2104ab.tar.gz
gentoo-2-117618029b57a537cf193e63438f75f73d2104ab.tar.bz2
gentoo-2-117618029b57a537cf193e63438f75f73d2104ab.zip
Version bump. Use distutils_src_unpack. Added patch to fix the tests. Run tests with --verbose because it takes quite a bit of time.
(Portage version: 2.1.4)
-rw-r--r--dev-python/paramiko/ChangeLog11
-rw-r--r--dev-python/paramiko/files/paramiko-1.7.2-tests_cleanup.patch30
-rw-r--r--dev-python/paramiko/paramiko-1.7.2.ebuild41
3 files changed, 80 insertions, 2 deletions
diff --git a/dev-python/paramiko/ChangeLog b/dev-python/paramiko/ChangeLog
index baf1da8694a5..d12d71d77019 100644
--- a/dev-python/paramiko/ChangeLog
+++ b/dev-python/paramiko/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-python/paramiko
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/paramiko/ChangeLog,v 1.26 2007/04/12 17:35:05 welp Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/paramiko/ChangeLog,v 1.27 2008/01/31 15:30:32 hawking Exp $
+
+*paramiko-1.7.2 (31 Jan 2008)
+
+ 31 Jan 2008; Ali Polatel <hawking@gentoo.org>
+ +files/paramiko-1.7.2-tests_cleanup.patch, +paramiko-1.7.2.ebuild:
+ Version bump. Use distutils_src_unpack. Added patch to fix the tests. Run
+ tests with --verbose because it takes quite a bit of time.
12 Apr 2007; <welp@gentoo.org> paramiko-1.6.3.ebuild:
Stable on amd64
diff --git a/dev-python/paramiko/files/paramiko-1.7.2-tests_cleanup.patch b/dev-python/paramiko/files/paramiko-1.7.2-tests_cleanup.patch
new file mode 100644
index 000000000000..3ca6814a9b4f
--- /dev/null
+++ b/dev-python/paramiko/files/paramiko-1.7.2-tests_cleanup.patch
@@ -0,0 +1,30 @@
+diff -ur -x '*.pyc' -x '*.log' paramiko-1.7.2/test.py paramiko-1.7.2-fixed/test.py
+--- paramiko-1.7.2/test.py 2007-02-13 04:52:19.000000000 +0200
++++ paramiko-1.7.2-fixed/test.py 2008-01-31 16:34:04.000000000 +0200
+@@ -140,6 +140,13 @@
+ filter = '|'.join(args)
+ suite = filter_suite_by_re(suite, filter)
+ runner.run(suite)
++ if options.use_sftp:
++ # Final cleanup
++ from test_sftp import get_sftp, get_tc
++ sftp = get_sftp()
++ tc = get_tc()
++ sftp.close()
++ tc.close()
+
+
+ if __name__ == '__main__':
+diff -ur -x '*.pyc' -x '*.log' paramiko-1.7.2/tests/test_sftp.py paramiko-1.7.2-fixed/tests/test_sftp.py
+--- paramiko-1.7.2/tests/test_sftp.py 2007-02-13 05:01:32.000000000 +0200
++++ paramiko-1.7.2-fixed/tests/test_sftp.py 2008-01-31 16:32:52.000000000 +0200
+@@ -75,6 +75,9 @@
+ global sftp
+ return sftp
+
++def get_tc():
++ global tc
++ return tc
+
+ class SFTPTest (unittest.TestCase):
+
diff --git a/dev-python/paramiko/paramiko-1.7.2.ebuild b/dev-python/paramiko/paramiko-1.7.2.ebuild
new file mode 100644
index 000000000000..229230472091
--- /dev/null
+++ b/dev-python/paramiko/paramiko-1.7.2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/paramiko/paramiko-1.7.2.ebuild,v 1.1 2008/01/31 15:30:32 hawking Exp $
+
+NEED_PYTHON=2.3
+
+inherit distutils eutils
+
+DESCRIPTION="SSH2 implementation for Python"
+HOMEPAGE="http://www.lag.net/paramiko/"
+SRC_URI="http://www.lag.net/paramiko/download/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~sparc ~x86 ~x86-fbsd"
+IUSE="doc examples"
+
+RDEPEND=">=dev-python/pycrypto-1.9_alpha6"
+DEPEND="${RDEPEND}"
+
+src_unpack() {
+ distutils_src_unpack
+
+ epatch "${FILESDIR}"/${PN}-1.6.3-no-setuptools.patch
+ epatch "${FILESDIR}"/${P}-tests_cleanup.patch
+}
+
+src_install() {
+ distutils_src_install
+
+ use doc && dohtml -r docs/*
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r demos
+ fi
+}
+
+src_test() {
+ "${python}" test.py --verbose || die "tests failed"
+}