summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2008-03-27 23:24:13 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2008-03-27 23:24:13 +0000
commit04560db8fe98261132bd5d0bc104772142a91d08 (patch)
tree884c68874e0e74a0cfc0b676c7e9b5523f28239a
parentadd gnome-extra/evolution-exchange to GNOME 2.22 mask (diff)
downloadgentoo-2-04560db8fe98261132bd5d0bc104772142a91d08.tar.gz
gentoo-2-04560db8fe98261132bd5d0bc104772142a91d08.tar.bz2
gentoo-2-04560db8fe98261132bd5d0bc104772142a91d08.zip
New version for GNOME 2.22. Lots of bug fixes, uses glib's base64 implementation in place of camel's one, moved to libsoup-2.4 API.
(Portage version: 2.1.4.4)
-rw-r--r--gnome-extra/evolution-exchange/ChangeLog9
-rw-r--r--gnome-extra/evolution-exchange/evolution-exchange-2.22.0.ebuild46
2 files changed, 54 insertions, 1 deletions
diff --git a/gnome-extra/evolution-exchange/ChangeLog b/gnome-extra/evolution-exchange/ChangeLog
index 573b6c4c9623..4cddac9c44a8 100644
--- a/gnome-extra/evolution-exchange/ChangeLog
+++ b/gnome-extra/evolution-exchange/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for gnome-extra/evolution-exchange
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/evolution-exchange/ChangeLog,v 1.58 2008/03/09 07:57:37 leio Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/evolution-exchange/ChangeLog,v 1.59 2008/03/27 23:24:13 eva Exp $
+
+*evolution-exchange-2.22.0 (27 Mar 2008)
+
+ 27 Mar 2008; Gilles Dartiguelongue <eva@gentoo.org>
+ +evolution-exchange-2.22.0.ebuild:
+ New version for GNOME 2.22. Lots of bug fixes, uses glib's base64
+ implementation in place of camel's one, moved to libsoup-2.4 API.
*evolution-exchange-2.12.3-r1 (09 Mar 2008)
diff --git a/gnome-extra/evolution-exchange/evolution-exchange-2.22.0.ebuild b/gnome-extra/evolution-exchange/evolution-exchange-2.22.0.ebuild
new file mode 100644
index 000000000000..90b3c876e8b0
--- /dev/null
+++ b/gnome-extra/evolution-exchange/evolution-exchange-2.22.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/evolution-exchange/evolution-exchange-2.22.0.ebuild,v 1.1 2008/03/27 23:24:13 eva Exp $
+EAPI="1"
+
+inherit gnome2 eutils
+
+DESCRIPTION="Evolution module for connecting to Microsoft Exchange"
+HOMEPAGE="http://www.novell.com/products/desktop/features/evolution.html"
+LICENSE="GPL-2"
+
+SLOT="2.0"
+KEYWORDS="~amd64 ~hppa ~ppc ~sparc ~x86"
+IUSE="debug doc static"
+
+RDEPEND="
+ >=mail-client/evolution-2.21.90
+ >=dev-libs/glib-2.15.3
+ >=x11-libs/gtk+-2.10
+ >=gnome-base/gconf-2.0
+ >=gnome-base/libbonobo-2.20.3
+ >=gnome-base/libglade-2.0
+ >=gnome-base/libgnomeui-2.0
+ dev-libs/libxml2
+ net-libs/libsoup:2.4
+ >=gnome-extra/evolution-data-server-2.22
+ >=net-nds/openldap-2.1.30-r2"
+
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.35.5
+ dev-util/pkgconfig
+ doc? ( >=dev-util/gtk-doc-1 )"
+
+DOCS="AUTHORS ChangeLog NEWS README"
+
+pkg_setup() {
+ G2CONF="${G2CONF} $(use_with debug e2k-debug)"
+
+ if ! built_with_use gnome-extra/evolution-data-server ldap || ! built_with_use gnome-extra/evolution-data-server kerberos; then
+ eerror "Please re-emerge gnome-extra/evolution-data-server with"
+ eerror "the use flags ldap and kerberos."
+ die
+ fi
+
+ G2CONF="${G2CONF} $(use_with static static-ldap) --with-openldap"
+}