summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--acct-group/flexlm/flexlm-0.ebuild6
-rw-r--r--acct-group/schedule/schedule-0.ebuild6
-rw-r--r--acct-user/flexlm/flexlm-0.ebuild11
-rw-r--r--acct-user/schedule/schedule-0.ebuild9
-rw-r--r--app-admin/flexlm/flexlm-9.5-r4.ebuild (renamed from app-admin/flexlm/flexlm-9.5-r3.ebuild)3
-rw-r--r--metadata/pkg_desc_index4
-rw-r--r--sys-apps/schedule/schedule-8.0.1-r2.ebuild (renamed from sys-apps/schedule/schedule-8.0.1-r1.ebuild)5
7 files changed, 21 insertions, 23 deletions
diff --git a/acct-group/flexlm/flexlm-0.ebuild b/acct-group/flexlm/flexlm-0.ebuild
index b19d8b07..d906f768 100644
--- a/acct-group/flexlm/flexlm-0.ebuild
+++ b/acct-group/flexlm/flexlm-0.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit user
+inherit acct-group
KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 ~riscv s390 sparc x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
SLOT=0
@@ -12,6 +12,4 @@ SRC_URI=
LICENSE=
IUSE=
-pkg_postinst() {
- enewgroup flexlm
-}
+ACCT_GROUP_ID=-1
diff --git a/acct-group/schedule/schedule-0.ebuild b/acct-group/schedule/schedule-0.ebuild
index aef6d7d3..4add803e 100644
--- a/acct-group/schedule/schedule-0.ebuild
+++ b/acct-group/schedule/schedule-0.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit user
+inherit acct-group
KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 ~riscv s390 sparc x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
SLOT=0
@@ -12,6 +12,4 @@ SRC_URI=
LICENSE=
IUSE=
-pkg_postinst() {
- use prefix || enewgroup schedule
-}
+ACCT_GROUP_ID=-1
diff --git a/acct-user/flexlm/flexlm-0.ebuild b/acct-user/flexlm/flexlm-0.ebuild
index c4618443..8329b3cc 100644
--- a/acct-user/flexlm/flexlm-0.ebuild
+++ b/acct-user/flexlm/flexlm-0.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit user
+inherit acct-user
KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 ~riscv s390 sparc x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
SLOT=0
@@ -11,8 +11,9 @@ HOMEPAGE=
SRC_URI=
LICENSE=
IUSE=
-DEPEND="acct-group/schedule"
-pkg_postinst() {
- enewuser flexlm -1 /bin/bash /opt/flexlm flexlm
-}
+ACCT_USER_ID=-1
+ACCT_USER_GROUPS=( ${PN} )
+ACCT_USER_HOME=/opt/flexlm
+ACCT_USER_SHELL=/bin/bash
+acct-user_add_deps
diff --git a/acct-user/schedule/schedule-0.ebuild b/acct-user/schedule/schedule-0.ebuild
index e3145b19..84a020e4 100644
--- a/acct-user/schedule/schedule-0.ebuild
+++ b/acct-user/schedule/schedule-0.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit user
+inherit acct-user
KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 ~riscv s390 sparc x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
SLOT=0
@@ -11,8 +11,7 @@ HOMEPAGE=
SRC_URI=
LICENSE=
IUSE=
-DEPEND="acct-group/schedule"
-pkg_postinst() {
- use prefix || enewuser schedule -1 -1 -1 schedule
-}
+ACCT_USER_ID=-1
+ACCT_USER_GROUPS=( ${PN} )
+acct-user_add_deps
diff --git a/app-admin/flexlm/flexlm-9.5-r3.ebuild b/app-admin/flexlm/flexlm-9.5-r4.ebuild
index 3295a668..2c30d753 100644
--- a/app-admin/flexlm/flexlm-9.5-r3.ebuild
+++ b/app-admin/flexlm/flexlm-9.5-r4.ebuild
@@ -21,8 +21,9 @@ LICENSE="all-rights-reserved GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="doc"
-DEPEND="acct-group/flexlm
+IDEPEND="acct-group/flexlm
acct-user/flexlm"
+RDEPEND="${IDEPEND}"
QA_PREBUILT="
opt/flexlm/bin/lmgrd
diff --git a/metadata/pkg_desc_index b/metadata/pkg_desc_index
index 64a94f13..3e0228c7 100644
--- a/metadata/pkg_desc_index
+++ b/metadata/pkg_desc_index
@@ -2,7 +2,7 @@ acct-group/flexlm 0: Group for app-admin/flexlm
acct-group/schedule 0: Group for sys-apps/schedule
acct-user/flexlm 0: User for app-admin/flexlm
acct-user/schedule 0: User for sys-apps/schedule
-app-admin/flexlm 9.5-r3: Macrovision FLEXlm license manager and utils
+app-admin/flexlm 9.5-r4: Macrovision FLEXlm license manager and utils
app-admin/sudox 10.0-r1: wrapper for sudo which can pass X authority data and deal with screen and tmux
app-arch/archwrap 12.1: A collection of POSIX shell scripts to invoke archiver programs
app-arch/bzwc 5.1-r1: A POSIX shell wrapper for wc, supporting compressed files (xz, lzma, bz2, gz)
@@ -97,7 +97,7 @@ sys-apps/less 608: Excellent text file viewer, optionally with additional select
sys-apps/man 1.6g-r4: Standard commands to read man pages
sys-apps/openrc-wrapper 2.4: Use openrc init scripts with systemd or other init systems
sys-apps/paxopen 1.2: A wrapper script to set PAX kernel variables to an insecure/safe state
-sys-apps/schedule 8.0.1-r1: script to schedule jobs in a multiuser multitasking environment
+sys-apps/schedule 8.0.1-r2: script to schedule jobs in a multiuser multitasking environment
sys-apps/starter 3.0-r1: POSIX shell script and function to schedule commands
sys-apps/systemd-tmpfiles-openrc 1: openrc init-files for systemd-tmpfiles from sys-apps/systemd
sys-block/parted 2.4-r3: Create, destroy, resize, check, copy partitions and file systems
diff --git a/sys-apps/schedule/schedule-8.0.1-r1.ebuild b/sys-apps/schedule/schedule-8.0.1-r2.ebuild
index 3569eeee..131ca0ab 100644
--- a/sys-apps/schedule/schedule-8.0.1-r1.ebuild
+++ b/sys-apps/schedule/schedule-8.0.1-r2.ebuild
@@ -19,8 +19,11 @@ IUSE=""
OPTIONAL_RDEPEND="|| ( >=dev-lang/perl-5.14 virtual/perl-Term-ANSIColor )
dev-perl/Crypt-Rijndael"
+IDEPEND="acct-group/schedule
+ acct-user/schedule"
RDEPEND=">=dev-lang/perl-5.12
!<sys-apps/openrc-0.13
+ ${IDEPEND}
${OPTIONAL_RDEPEND}"
# || ( >=dev-lang/perl-5.10.1 >=virtual/perl-version-0.77 )
# || ( >=dev-lang/perl-5.1 virtual/perl-File-Path )
@@ -28,8 +31,6 @@ RDEPEND=">=dev-lang/perl-5.12
# || ( >=dev-lang/perl-5.6.1 >=virtual/perl-Getopt-Long-2.24 )
# || ( >=dev-lang/perl-5.6.0 >=virtual/perl-IO-1.190.0 )
# || ( >=dev-lang/perl-5.9.4 virtual/perl-Digest-SHA) # for encryption
-DEPEND="acct-group/schedule
- acct-user/schedule"
DISABLE_AUTOFORMATTING="true"
DOC_CONTENTS="It is recommended to put a lengthy passphrase into the first line