summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2010-03-28 12:13:38 +0200
committerMartin Väth <vaeth@mathematik.uni-wuerzburg.de>2010-03-28 12:13:38 +0200
commit3c20a4557767ea27aef7df1f4443dada90d06138 (patch)
treeb8bf2e2934314313ed99330577d4906b79d8f5aa /net-dialup
downloadmv-3c20a4557767ea27aef7df1f4443dada90d06138.tar.gz
mv-3c20a4557767ea27aef7df1f4443dada90d06138.tar.bz2
mv-3c20a4557767ea27aef7df1f4443dada90d06138.zip
Import of the mv overlay
Diffstat (limited to 'net-dialup')
-rw-r--r--net-dialup/accounting/ChangeLog7
-rw-r--r--net-dialup/accounting/Manifest6
-rw-r--r--net-dialup/accounting/accounting-1.59.38-r2.ebuild67
-rw-r--r--net-dialup/accounting/files/ip-down.sh3
-rw-r--r--net-dialup/accounting/files/ip-up.sh4
-rw-r--r--net-dialup/accounting/metadata.xml9
-rw-r--r--net-dialup/martian/ChangeLog8
-rw-r--r--net-dialup/martian/Manifest4
-rw-r--r--net-dialup/martian/martian-20080625.ebuild63
-rw-r--r--net-dialup/martian/metadata.xml9
10 files changed, 180 insertions, 0 deletions
diff --git a/net-dialup/accounting/ChangeLog b/net-dialup/accounting/ChangeLog
new file mode 100644
index 00000000..7bbacaef
--- /dev/null
+++ b/net-dialup/accounting/ChangeLog
@@ -0,0 +1,7 @@
+# ChangeLog for net-dialup/accounting
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header $
+
+ 28 Mar 2010; Martin Väth <martin@mvath.de>
+ accounting-1.59.38-r2.ebuild:
+ import with minor changes from a personal overlay.
diff --git a/net-dialup/accounting/Manifest b/net-dialup/accounting/Manifest
new file mode 100644
index 00000000..df3dfdd8
--- /dev/null
+++ b/net-dialup/accounting/Manifest
@@ -0,0 +1,6 @@
+AUX ip-down.sh 109 RMD160 6e9e230aa5ea0497f32a93c0bdb0f000fc4431ce SHA1 f16fe455e04f0b28d70a80f17149c86f01dc057c SHA256 8aab51ac919fa62332f52a03ed2874bd9b25d7abd42110f0c44b895fcccd5a33
+AUX ip-up.sh 142 RMD160 d1966b48de496c5ffc7e74e01520e1c065107436 SHA1 0142b743b822ef2c3f3c443c29375453e9604665 SHA256 cefb883c89eacd2ef9d8ca7c2d722ad25f39df8bbd6982ff17a3fd60cf680b3e
+DIST smpppd-1.59-38.src.rpm 156352 RMD160 7cc99062ea13daa1342e78977753b5833aa22ba5 SHA1 37d5d2788180041c6ef5f8417b42970133ca9c23 SHA256 e9fdc45ceda76ac32efebfbb06f56b0eb7f3d2e3a7f7f982f67d867167af578b
+EBUILD accounting-1.59.38-r2.ebuild 1982 RMD160 83d737ec3c795e8d1a2a3ff6b57c4139103cbc38 SHA1 86bc32a5e0460cfa62ddf72b47c582d591d38ff6 SHA256 d26b9a79e82d8e0cf1b2b237efeb355ab8306842a36afb7ac867df4b37d56f98
+MISC ChangeLog 270 RMD160 0c5cb48b71241ba0132b6268bf03b7cedb14d798 SHA1 24bd9154ed746956c57d68ef06a10522538b3813 SHA256 9fa4047743c3a96e63faa77d37923d7271551a91a9794a0208adfbca76d06656
+MISC metadata.xml 274 RMD160 a46806846cb114b1d2889ac05c409164bc276800 SHA1 ec26b2018eda8c918c3d1b2ef99d7a8ba4b70dfe SHA256 b0e2d9479aa7d1b3025efa320ddc30ee2e2df365c159b0bfec02b8019d2628d8
diff --git a/net-dialup/accounting/accounting-1.59.38-r2.ebuild b/net-dialup/accounting/accounting-1.59.38-r2.ebuild
new file mode 100644
index 00000000..6ee5c777
--- /dev/null
+++ b/net-dialup/accounting/accounting-1.59.38-r2.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header $
+
+inherit rpm
+RESTRICT="mirror"
+
+MY_PN="smpppd"
+MY_PV="${PV%.*}"
+MY_P="${MY_PN}-${MY_PV}-${PV##*.}"
+S="${WORKDIR}/${MY_PN}-${MY_PV}"
+DESCRIPTION="Give statistics about dialup connections. Originally part of SuSE's smpppd"
+HOMEPAGE="http://www.opensuse.org"
+SRC_URI="http://download.opensuse.org/distribution/10.2/repo/src-oss/suse/src/${MY_P}.src.rpm"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+test -z "${ACCOUNTING_LOG}" && ACCOUNTING_LOG="/var/log/accounting.log"
+
+CDIR="${S}/smpppd"
+DDIR="${S}/doc"
+
+DEPEND=">=net-dialup/ppp-2.4.4-r13"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ rpm_src_unpack
+ echo "#define VERSION ${MY_PV}" >"${CDIR}"/config.h
+ sed -i -e's!^\(#define ACCOUNTING_LOG \).*$!\1"'"${ACCOUNTING_LOG}"'"!' \
+ "${CDIR}"/defines.h
+ sed -i -e's!/var/log/[^.]*\.log!'"${ACCOUNTING_LOG}"'!' \
+ "${DDIR}"/accounting.1
+ sed -i -e '/#include <string>/i#include <cstring>' "${CDIR}"/parse.h
+ sed -i -e '/#include <string>/i#include <cstring>\n#include <cstdlib>\n#include <algorithm>' "${CDIR}"/utils.h
+ sed -i -e '/#include <string>/i#include <cstdlib>' "${CDIR}"/accounting.h
+}
+
+src_compile() {
+ cd "${CDIR}"
+ g++ ${CXXFLAGS} ${LDFLAGS} -o accounting \
+ accounting.cc utils.cc format.cc parse.cc tempus.cc filter.cc \
+ || die "compiling failed"
+}
+
+new_sedbin() {
+ dodir "${2%/*}"
+ sed -e "s!ACCOUNTING_LOG!${ACCOUNTING_LOG}!" -- "${1}" >"${D}/${2}"
+ fperms 755 "${2}"
+}
+
+src_install() {
+ cd "${CDIR}"
+ dobin accounting
+ cd "${DDIR}"
+ doman accounting.1
+ new_sedbin "${FILESDIR}"/ip-up.sh /etc/ppp/ip-up.d/80-accounting.sh
+ new_sedbin "${FILESDIR}"/ip-down.sh /etc/ppp/ip-down.d/10-accounting.sh
+}
+
+pkg_postinst() {
+ ewarn "The accounting tool only interprets ${ACCOUNTING_LOG}"
+ ewarn "This file is updated by scripts in /etc/ppp/ip-up.d and /etc/ppp/ip-down.d"
+ ewarn "You might want to modify these scripts (e.g. add provider info)."
+}
diff --git a/net-dialup/accounting/files/ip-down.sh b/net-dialup/accounting/files/ip-down.sh
new file mode 100644
index 00000000..10074598
--- /dev/null
+++ b/net-dialup/accounting/files/ip-down.sh
@@ -0,0 +1,3 @@
+#! /bin/sh
+echo `/bin/date --utc +'%F %X'` "${1}" d om "${BYTES_RCVD}" "${BYTES_SENT}" \
+ >>'ACCOUNTING_LOG'
diff --git a/net-dialup/accounting/files/ip-up.sh b/net-dialup/accounting/files/ip-up.sh
new file mode 100644
index 00000000..fa5618c0
--- /dev/null
+++ b/net-dialup/accounting/files/ip-up.sh
@@ -0,0 +1,4 @@
+#! /bin/sh
+[ -z "${PROVIDER}" ] && PROVIDER='Gentoo'
+echo `/bin/date --utc +'%F %X'` "${1}" u om "\"${PROVIDER} ${1}\"" \
+ >>'ACCOUNTING_LOG'
diff --git a/net-dialup/accounting/metadata.xml b/net-dialup/accounting/metadata.xml
new file mode 100644
index 00000000..0366721c
--- /dev/null
+++ b/net-dialup/accounting/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+ <maintainer>
+ <email>martin@mvath.de</email>
+ <name>Martin Väth</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/net-dialup/martian/ChangeLog b/net-dialup/martian/ChangeLog
new file mode 100644
index 00000000..b6f027b6
--- /dev/null
+++ b/net-dialup/martian/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for net-dialup/martian
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header $
+
+ 28 Mar 2010; Martin Väth <martin@mvath.de>
+ martian-20080625.ebuild:
+ import with minor changes from a personal overlay.
+ See bug 285016
diff --git a/net-dialup/martian/Manifest b/net-dialup/martian/Manifest
new file mode 100644
index 00000000..51c3cc09
--- /dev/null
+++ b/net-dialup/martian/Manifest
@@ -0,0 +1,4 @@
+DIST martian-full-20080625.tar.gz 274510 RMD160 8110832e140d21e58ee5a6149f8143f8bf063821 SHA1 bc3bae2fe5a7519e37645be787ec45b313044150 SHA256 66761d2735bc59252e26535f08f9c7f4fa9bc5475d799fa06fc1781ab115cd91
+EBUILD martian-20080625.ebuild 1646 RMD160 0c689ce82e593aac2263c315020b8951126fb9a1 SHA1 85360ef6df77c3915e5b6706c63df2e2e0c8c5bb SHA256 043bbc1985bf18b8948b2b7219e4342775e0ade2c73488f54800fed02ace2575
+MISC ChangeLog 279 RMD160 2fc94f55f7bed8b80b3a9d4393e4c13f7e9d33d0 SHA1 75b9f12fa978ba51822087ce937b702c6d717f9e SHA256 270c0ac24bf870986d51635d52c6b3ad1b879d8f56c3b868cc6133f7d922b6f8
+MISC metadata.xml 274 RMD160 a46806846cb114b1d2889ac05c409164bc276800 SHA1 ec26b2018eda8c918c3d1b2ef99d7a8ba4b70dfe SHA256 b0e2d9479aa7d1b3025efa320ddc30ee2e2df365c159b0bfec02b8019d2628d8
diff --git a/net-dialup/martian/martian-20080625.ebuild b/net-dialup/martian/martian-20080625.ebuild
new file mode 100644
index 00000000..036be39b
--- /dev/null
+++ b/net-dialup/martian/martian-20080625.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header $
+
+inherit linux-mod eutils
+
+ARCHRUMP="${PN}-full-${PV}"
+DESCRIPTION="Winmodems with Lucent Apollo (ISA) and Mars (PCI) chipsets"
+HOMEPAGE="http://linmodems.technion.ac.il/"
+SRC_URI="http://linmodems.technion.ac.il/packages/ltmodem/kernel-2.6/martian/${ARCHRUMP}.tar.gz"
+
+LICENSE="GPL-2 AgereSystems-WinModem"
+KEYWORDS="-* ~x86"
+IUSE=""
+
+RESTRICT="mirror strip"
+
+DEPEND=""
+RDEPEND=""
+
+S="${WORKDIR}/${ARCHRUMP}"
+
+MODULE_NAMES="martian_dev(ltmodem::kmodule)"
+CONFIG_CHECK="SERIAL_8250"
+SERIAL_8250_ERROR="This driver requires you to compile your kernel with serial core (CONFIG_SERIAL_8250) support."
+
+pkg_setup() {
+ linux-mod_pkg_setup
+
+ if kernel_is 2 4; then
+ eerror "This driver works only with 2.6 kernels!"
+ die "unsupported kernel detected"
+ fi
+
+ BUILD_TARGETS="all"
+ BUILD_PARAMS="KERNEL_DIR='${KV_DIR}' SUBLEVEL='${KV_PATCH}'"
+}
+
+src_install() {
+ # install kernel module
+ linux-mod_src_install
+ dosbin modem/martian_modem
+}
+
+pkg_postinst() {
+ linux-mod_pkg_postinst
+
+ if [ "$ROOT" = "/" ]; then
+ /sbin/update-modules
+ fi
+
+ ewarn
+ ewarn "To make the modem available modprobe martian_dev and run \"martian_modem\"."
+ ewarn "This will make the modem available as /dev/ttySM0."
+ ewarn "When using wvdial add \"Carrier Check = no\" line."
+
+ if linux_chkconfig_present SMP ; then
+ ewarn
+ ewarn "Please note that Linux support for SMP (symmetric multi processor)"
+ ewarn "is reported to be incompatible with this driver!"
+ ewarn "In case it doesn't work, you should try first to disable CONFIG_SMP in your kernel."
+ fi
+}
diff --git a/net-dialup/martian/metadata.xml b/net-dialup/martian/metadata.xml
new file mode 100644
index 00000000..0366721c
--- /dev/null
+++ b/net-dialup/martian/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+ <maintainer>
+ <email>martin@mvath.de</email>
+ <name>Martin Väth</name>
+ </maintainer>
+</pkgmetadata>