summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2022-10-19 22:11:38 +0200
committerMartin Väth <martin@mvath.de>2022-10-19 22:11:38 +0200
commit04a175ee7c3ce884f8ace8c32406323f5ef6cdab (patch)
tree25051c02ff020f62b2995a39c9cefe935d15278a /acct-user
parentx11-libs/gtk+: Revision bump. x11-misc/gtkdialog: Copy from gentoo repository (diff)
downloadmv-04a175ee7c3ce884f8ace8c32406323f5ef6cdab.tar.gz
mv-04a175ee7c3ce884f8ace8c32406323f5ef6cdab.tar.bz2
mv-04a175ee7c3ce884f8ace8c32406323f5ef6cdab.zip
Avoid user.eclass. Fix deps for acct-{group,user} packages
Signed-off-by: Martin Väth <martin@mvath.de>
Diffstat (limited to 'acct-user')
-rw-r--r--acct-user/flexlm/flexlm-0.ebuild11
-rw-r--r--acct-user/schedule/schedule-0.ebuild9
2 files changed, 10 insertions, 10 deletions
diff --git a/acct-user/flexlm/flexlm-0.ebuild b/acct-user/flexlm/flexlm-0.ebuild
index c4618443..8329b3cc 100644
--- a/acct-user/flexlm/flexlm-0.ebuild
+++ b/acct-user/flexlm/flexlm-0.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit user
+inherit acct-user
KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 ~riscv s390 sparc x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
SLOT=0
@@ -11,8 +11,9 @@ HOMEPAGE=
SRC_URI=
LICENSE=
IUSE=
-DEPEND="acct-group/schedule"
-pkg_postinst() {
- enewuser flexlm -1 /bin/bash /opt/flexlm flexlm
-}
+ACCT_USER_ID=-1
+ACCT_USER_GROUPS=( ${PN} )
+ACCT_USER_HOME=/opt/flexlm
+ACCT_USER_SHELL=/bin/bash
+acct-user_add_deps
diff --git a/acct-user/schedule/schedule-0.ebuild b/acct-user/schedule/schedule-0.ebuild
index e3145b19..84a020e4 100644
--- a/acct-user/schedule/schedule-0.ebuild
+++ b/acct-user/schedule/schedule-0.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit user
+inherit acct-user
KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 ~riscv s390 sparc x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
SLOT=0
@@ -11,8 +11,7 @@ HOMEPAGE=
SRC_URI=
LICENSE=
IUSE=
-DEPEND="acct-group/schedule"
-pkg_postinst() {
- use prefix || enewuser schedule -1 -1 -1 schedule
-}
+ACCT_USER_ID=-1
+ACCT_USER_GROUPS=( ${PN} )
+acct-user_add_deps