aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/workerpool')
-rw-r--r--dev-python/workerpool/Manifest1
-rw-r--r--dev-python/workerpool/metadata.xml10
-rw-r--r--dev-python/workerpool/workerpool-0.9.2.ebuild61
3 files changed, 72 insertions, 0 deletions
diff --git a/dev-python/workerpool/Manifest b/dev-python/workerpool/Manifest
new file mode 100644
index 0000000..a81e394
--- /dev/null
+++ b/dev-python/workerpool/Manifest
@@ -0,0 +1 @@
+DIST workerpool-0.9.2.tar.gz 7747 SHA256 ab2eaf05e236140c62c7411d13ecc4ddedc365966282719a35afc53043c00f82 SHA512 d5ce36ff48b297adb40baf40a53823cc8b6e39b0c7eb880541dffb5ea1d0849e50c344e63f1ac3089d51fc1fe6e73ff2a26df03f9d68f24980222fe3ef7f01c5 WHIRLPOOL 093221fb442abe017591fa79b85abbd1824b63ec89aaf62eb87cb50975dd5164cd3a1ef36c51336e2dcb97aef3fdd18695691e73bfaaa168077172bcc5a49db3
diff --git a/dev-python/workerpool/metadata.xml b/dev-python/workerpool/metadata.xml
new file mode 100644
index 0000000..5f2cb6b
--- /dev/null
+++ b/dev-python/workerpool/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <maintainer><email>tampakrap@gentoo.org</email></maintainer>
+ <maintainer>
+ <email>johneed@hotmail.com,della5@iinet.com.au</email>
+ <name>Ian Delaney aka idella4 proxy maintainer</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-python/workerpool/workerpool-0.9.2.ebuild b/dev-python/workerpool/workerpool-0.9.2.ebuild
new file mode 100644
index 0000000..6d3720c
--- /dev/null
+++ b/dev-python/workerpool/workerpool-0.9.2.ebuild
@@ -0,0 +1,61 @@
+#Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header:
+
+EAPI="4"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="*-jython"
+DISTUTILS_SRC_TEST=nosetests
+# package supports python3, tests don't
+#PYTHON_TESTS_RESTRICTED_ABIS="3.*"
+inherit distutils
+
+DESCRIPTION="Module for distributing jobs to a pool of worker threads."
+HOMEPAGE="http://github.com/shazow/workerpool"
+SRC_URI="http://pypi.python.org/packages/source/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test examples"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/setuptool"
+
+src_prepare() {
+ # python3 can be used but not with tests
+ checkabi() {
+ local exit_status=0
+ if use test && [[ $(python_get_version --major) == 3 ]]; then
+ # Green from einfo more readable than in red from eerror.
+ einfo ""
+ einfo "tests do not support python3"
+ einfo "tests can be run with python2"
+ einfo ""
+ exit_status=1
+ return $exit_status
+ fi
+ }
+ python_execute_function checkabi
+ distutils_src_prepare
+}
+
+src_compile() {
+ distutils_src_compile
+}
+
+src_test() {
+ # point distutils_src_test to tests
+ distutils_src_test -v test
+}
+
+src_install() {
+ distutils_src_install
+
+ if use examples; then
+ docompress -x usr/share/doc/${P}/samples
+ insinto usr/share/doc/${P}/
+ doins -r samples
+ fi
+}