aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/lcms/lcms-1.19-r2.ebuild')
-rw-r--r--media-libs/lcms/lcms-1.19-r2.ebuild130
1 files changed, 0 insertions, 130 deletions
diff --git a/media-libs/lcms/lcms-1.19-r2.ebuild b/media-libs/lcms/lcms-1.19-r2.ebuild
deleted file mode 100644
index 69ab7f6..0000000
--- a/media-libs/lcms/lcms-1.19-r2.ebuild
+++ /dev/null
@@ -1,130 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-EAPI="5"
-
-PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} )
-
-# autoreconf needs to update python macros for py3 support.
-AUTOTOOLS_AUTORECONF=1
-AUTOTOOLS_PRUNE_LIBTOOL_FILES="modules"
-
-inherit autotools-multilib python-r1
-
-DESCRIPTION="A lightweight, speed optimized color management engine"
-HOMEPAGE="http://www.littlecms.com/"
-SRC_URI="http://www.littlecms.com/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="jpeg python static-libs tiff zlib"
-
-RDEPEND="
- tiff? ( media-libs/tiff:0[${MULTILIB_USEDEP}] )
- jpeg? ( virtual/jpeg:0[${MULTILIB_USEDEP}] )
- zlib? ( sys-libs/zlib[${MULTILIB_USEDEP}] )
- python? ( ${PYTHON_DEPS} )
- abi_x86_32? (
- !<=app-emulation/emul-linux-x86-baselibs-20131008-r1
- !app-emulation/emul-linux-x86-baselibs[-abi_x86_32(-)]
- )
-"
-DEPEND="${RDEPEND}
- python? ( >=dev-lang/swig-1.3.31 )
-"
-
-PATCHES=(
- "${FILESDIR}/${P}-disable_static_modules.patch"
- "${FILESDIR}/${P}-implicit.patch"
- "${FILESDIR}/${P}-fix-swig-destructor.patch"
- "${FILESDIR}/${P}-fix-python3.2.patch"
-)
-
-src_prepare() {
- # Breaks out-of-source build, only corresponding .in file is needed
- rm include/icc34.h || die 'rm failed'
-
- autotools-multilib_src_prepare
-
- # run swig to regenerate lcms_wrap.cxx and lcms.py (bug #148728)
- if use python; then
- cd python || die
- bash swig_lcms || die
- fi
-}
-
-_pywrap() {
- local CFLAGS="${CFLAGS} $(python_get_CFLAGS)"
- local CXXFLAGS="${CXXFLAGS} $(python_get_CFLAGS)"
- export CFLAGS CXXFLAGS
- [[ -d "${BUILD_DIR}" ]] || { mkdir -p "${BUILD_DIR}" || die ; }
- multilib-build_run_in_build_dir "$@"
-}
-
-src_configure() {
- local myeconfargs=(
- $(use_enable static-libs static)
- $(use_with jpeg)
- $(use_with tiff)
- $(use_with zlib)
- )
-
- autotools-multilib_src_configure --without-python
-}
-
-ehook autotools-multilib-best-abi-post_src_configure bestabi_pyconfigure
-bestabi_pyconfigure() {
- local othereconfargs=(
- $(
- for othereconfarg in "${othereconfargs[@]}" ; do
- [[ ${othereconfarg} == --without-python ]] || \
- echo "${othereconfarg}"
- done
- )
- )
- use python && \
- python_foreach_impl \
- _pywrap \
- econf "${myeconfargs[@]}" "${othereconfargs[@]}" --with-python
-}
-
-ehook autotools-multilib-best-abi-post_src_compile bestabi_pycompile
-bestabi_pycompile() {
- use python && \
- python_foreach_impl \
- _pywrap \
- emake "${myemakeargs[@]}" "${otheremakeargs[@]}" -C python \
- top_builddir="${BUILD_DIR}"
-}
-
-ehook autotools-multilib-per-abi-pre_src_test cptestbed
-cptestbed() {
- cp "${S}"/testbed/*icm ${BUILD_DIR}/testbed/ || die
- return 0
-}
-
-src_install() {
- autotools-multilib_src_install \
- BINDIR="${ED}"/usr/bin
-
- dodoc AUTHORS README.1ST INSTALL NEWS doc/{LCMSAPI,TUTORIAL}.TXT
-
- insinto /usr/share/lcms/profiles
- doins testbed/*.icm
-}
-
-ehook autotools-multilib-best-abi-post_src_install bestabi_pyinstall
-bestabi_pyinstall() {
- if use python; then
- python_foreach_impl \
- _pywrap \
- emake "${myemakeinstallargs[@]}" "${otheremakeinstallargs[@]}" \
- -C python top_builddir="${BUILD_DIR}"
-
- python_foreach_impl \
- _pywrap \
- python_optimize
- fi
-}