summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/xml-security-c/xml-security-c-1.7.3.ebuild')
-rw-r--r--dev-libs/xml-security-c/xml-security-c-1.7.3.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-libs/xml-security-c/xml-security-c-1.7.3.ebuild b/dev-libs/xml-security-c/xml-security-c-1.7.3.ebuild
new file mode 100644
index 0000000..40ceb34
--- /dev/null
+++ b/dev-libs/xml-security-c/xml-security-c-1.7.3.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Apache C++ XML security libraries"
+HOMEPAGE="https://santuario.apache.org/"
+SRC_URI="mirror://apache/santuario/c-library/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug examples libressl nss static-libs xalan"
+
+RDEPEND=">=dev-libs/xerces-c-3.1
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ nss? ( dev-libs/nss )
+ xalan? ( dev-libs/xalan-c )"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+PATCHES=(
+ "${FILESDIR}/${PN}-1.6.1-nss-compilation-fix.patch"
+ "${FILESDIR}/${PN}-1.7.3-fix-c++14.patch"
+ "${FILESDIR}/${PN}-1.7.3_openssl1.1.patch"
+)
+
+DOCS=( CHANGELOG.txt NOTICE.txt )
+
+src_configure() {
+ econf \
+ --with-openssl \
+ $(use_enable static-libs static) \
+ $(use_enable debug) \
+ $(use_with xalan) \
+ $(use_with nss)
+}
+
+src_install() {
+ default
+ if use examples ; then
+ docinto examples
+ dodoc xsec/samples/*.cpp
+ fi
+}