summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/gawk')
-rw-r--r--sys-apps/gawk/gawk-4.1.4.ebuild8
1 files changed, 7 insertions, 1 deletions
diff --git a/sys-apps/gawk/gawk-4.1.4.ebuild b/sys-apps/gawk/gawk-4.1.4.ebuild
index 7aa9f006e6e8..0d421fbc32a5 100644
--- a/sys-apps/gawk/gawk-4.1.4.ebuild
+++ b/sys-apps/gawk/gawk-4.1.4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -31,6 +31,12 @@ src_prepare() {
sed -i \
-e '/check-recursive all-recursive: check-for-shared-lib-support/d' \
extension/Makefile.in || die
+ # fix standards conflict on Solaris
+ if [[ ${CHOST} == *-solaris* ]] ; then
+ sed -i \
+ -e '/\<_XOPEN_SOURCE\>/s/$/600/' \
+ extension/inplace.c || die
+ fi
}
src_configure() {