summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/list-remote-forwards/Manifest2
-rw-r--r--net-mail/list-remote-forwards/files/list-remote-forwards-0.0.1-ghc84.patch26
-rw-r--r--net-mail/list-remote-forwards/list-remote-forwards-0.0.3.ebuild (renamed from net-mail/list-remote-forwards/list-remote-forwards-0.0.1-r2.ebuild)19
3 files changed, 5 insertions, 42 deletions
diff --git a/net-mail/list-remote-forwards/Manifest b/net-mail/list-remote-forwards/Manifest
index 90f3106e81b1..8070a53751a5 100644
--- a/net-mail/list-remote-forwards/Manifest
+++ b/net-mail/list-remote-forwards/Manifest
@@ -1 +1 @@
-DIST list-remote-forwards-0.0.1.tar.gz 25869 BLAKE2B decfd8b5d4fcbd5e278f9c58f79687aa33cc91d4d4907ff7a29fe6b745ff49c073e3beaf2876ec071f4ed1099b4575cacb8194049add04c0aa8ebeff3338293e SHA512 b6d8c0e8a72e3dcbc62c00b291da99da6c37c853997c367eb60db128db327c1f862e9dc6d9ad4028aad2e0cec9acc96add28d85d4b22508e1fd00a65bb9b0317
+DIST list-remote-forwards-0.0.3.tar.gz 26495 BLAKE2B 7bc0a02133dfabe0f27c7ed861bbb994757eadb4d55d369fdd143da7ef03fcadf7d1f11bb034fc8ade7dc879d4b615a3ae5ed44a1ed5af3e10f1aaffcd79210a SHA512 833bb0a3fda76b43d0004d7906c54aa21920f1db8ff50fc2c0d1da6f98dd49310041fa7101050108cb6cb803084fff0673316a1ce86224d35ba09e8060864a9d
diff --git a/net-mail/list-remote-forwards/files/list-remote-forwards-0.0.1-ghc84.patch b/net-mail/list-remote-forwards/files/list-remote-forwards-0.0.1-ghc84.patch
deleted file mode 100644
index bf21a42d5973..000000000000
--- a/net-mail/list-remote-forwards/files/list-remote-forwards-0.0.1-ghc84.patch
+++ /dev/null
@@ -1,26 +0,0 @@
---- a/src/OptionalConfiguration.hs
-+++ b/src/OptionalConfiguration.hs
-@@ -31,2 +31,3 @@ import System.IO.Error ( catchIOError )
- import MxList ( MxList(..) )
-+import qualified Data.Semigroup as S
-
-@@ -59,2 +60,19 @@ merge_maybes (Just _) (Just y) = Just y
-
-+instance S.Semigroup OptionalConfiguration where
-+ cfg1 <> cfg2 =
-+ OptionalConfiguration
-+ (merge_maybes (database cfg1) (database cfg2))
-+ (merge_maybes (domain_query cfg1) (domain_query cfg2))
-+ all_excluded_mx
-+ (merge_maybes (forward_query cfg1) (forward_query cfg2))
-+ (merge_maybes (host cfg1) (host cfg2))
-+ (merge_maybes (password cfg1) (password cfg2))
-+ (merge_maybes (port cfg1) (port cfg2))
-+ (merge_maybes (username cfg1) (username cfg2))
-+ where
-+ -- Use only the latter exclude_mx if there are any.
-+ all_excluded_mx =
-+ exclude_mx $ if (null (get_mxs $ exclude_mx cfg2))
-+ then cfg1
-+ else cfg2
-
diff --git a/net-mail/list-remote-forwards/list-remote-forwards-0.0.1-r2.ebuild b/net-mail/list-remote-forwards/list-remote-forwards-0.0.3.ebuild
index 5f826c60fefc..3f6ac736d824 100644
--- a/net-mail/list-remote-forwards/list-remote-forwards-0.0.1-r2.ebuild
+++ b/net-mail/list-remote-forwards/list-remote-forwards-0.0.3.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
# ebuild generated by hackport 0.4.4
@@ -12,16 +12,14 @@ DESCRIPTION="List all remote forwards for mail accounts stored in a database"
HOMEPAGE="https://hackage.haskell.org/package/list-remote-forwards"
SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
-LICENSE="GPL-3"
+LICENSE="AGPL-3"
SLOT="0"
KEYWORDS="~amd64 ~ppc64 ~x86"
IUSE=""
-RESTRICT=test # Ambiguous packages: dns-3.0.2 resolv-0.1.1.1
-
RDEPEND=""
DEPEND="${RDEPEND}
- >=dev-haskell/cabal-1.16.0
+ >=dev-haskell/cabal-3.0.0
>=dev-haskell/cmdargs-0.10
>=dev-haskell/configurator-0.2
>=dev-haskell/dns-1.4
@@ -32,20 +30,11 @@ DEPEND="${RDEPEND}
>=dev-haskell/tasty-0.8
>=dev-haskell/tasty-hunit-0.8
>=dev-haskell/tasty-quickcheck-0.8
- >=dev-lang/ghc-7.6.1
+ >=dev-lang/ghc-9.0.0
test? ( >=dev-haskell/doctest-0.9
>=dev-haskell/filemanip-0.3.6 )
"
-PATCHES=(
- "${FILESDIR}"/${P}-ghc84.patch
-)
-
-src_prepare() {
- sed -i -e "/-optc-O3/d" -e "/-optc-march=native/d" "${PN}.cabal" || die
- default
-}
-
src_install() {
haskell-cabal_src_install
doman "${S}/doc/man1/${PN}.1"