summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-mail/mswatch/mswatch-1.2.0-r1.ebuild')
-rw-r--r--net-mail/mswatch/mswatch-1.2.0-r1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/net-mail/mswatch/mswatch-1.2.0-r1.ebuild b/net-mail/mswatch/mswatch-1.2.0-r1.ebuild
new file mode 100644
index 000000000000..06d3a3d17125
--- /dev/null
+++ b/net-mail/mswatch/mswatch-1.2.0-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit linux-info ltprune
+
+DESCRIPTION="A utility to watch mailstores for changes and initiate mailbox syncs"
+HOMEPAGE="http://mswatch.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="static-libs"
+
+RDEPEND=">=dev-libs/glib-2.6:2"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+"
+
+CONFIG_CHECK="~INOTIFY_USER"
+ERROR_INOTIFY_USER="${P} requires in-kernel inotify support."
+
+PATCHES=(
+ "${FILESDIR}"/${P}-gcc47.patch
+ "${FILESDIR}"/${P}-gcc6.patch
+)
+
+src_configure() {
+ econf \
+ --with-notify=inotify \
+ --enable-shared \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ prune_libtool_files
+}