summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-plugins/swh-plugins/files/swh-plugins-0.4.15-riceitdown.patch')
-rw-r--r--media-plugins/swh-plugins/files/swh-plugins-0.4.15-riceitdown.patch23
1 files changed, 23 insertions, 0 deletions
diff --git a/media-plugins/swh-plugins/files/swh-plugins-0.4.15-riceitdown.patch b/media-plugins/swh-plugins/files/swh-plugins-0.4.15-riceitdown.patch
new file mode 100644
index 000000000000..f514425e2a94
--- /dev/null
+++ b/media-plugins/swh-plugins/files/swh-plugins-0.4.15-riceitdown.patch
@@ -0,0 +1,23 @@
+Index: swh-plugins-0.4.15/configure.in
+===================================================================
+--- swh-plugins-0.4.15.orig/configure.in
++++ swh-plugins-0.4.15/configure.in
+@@ -99,12 +99,12 @@ else
+ AC_MSG_WARN([Can't find architecture specifaction in CFLAGS, picking one from build host CPU type])
+ AC_MSG_WARN([May result in non-portable code])
+ dnl For gcc use:
+- MACHINE="-march=${build_cpu}"
+- if test ${build_cpu} = "powerpc"; then MACHINE=""; fi
+- if test ${build_cpu} = "powerpc64"; then MACHINE=""; fi
+- if test ${build_cpu} = "x86_64"; then MACHINE=""; fi
+-
+- CFLAGS="$CFLAGS -Wall -O3 -fomit-frame-pointer -fstrength-reduce -funroll-loops -ffast-math -fPIC -DPIC ${MACHINE} ${USE_SSE} ${DARWIN_CFLAGS}"
++ # MACHINE="-march=${build_cpu}"
++ # if test ${build_cpu} = "powerpc"; then MACHINE=""; fi
++ # if test ${build_cpu} = "powerpc64"; then MACHINE=""; fi
++ # if test ${build_cpu} = "x86_64"; then MACHINE=""; fi
++ #
++ # CFLAGS="$CFLAGS -Wall -O3 -fomit-frame-pointer -fstrength-reduce -funroll-loops -ffast-math -fPIC -DPIC ${MACHINE} ${USE_SSE} ${DARWIN_CFLAGS}"
+
+ dnl For Intel's C compiler use:
+ dnl CC="icc"