summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-plasma/plasma-integration')
-rw-r--r--kde-plasma/plasma-integration/Manifest1
-rw-r--r--kde-plasma/plasma-integration/plasma-integration-5.12.3.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/kde-plasma/plasma-integration/Manifest b/kde-plasma/plasma-integration/Manifest
index 6fe664238465..d7affa0dda67 100644
--- a/kde-plasma/plasma-integration/Manifest
+++ b/kde-plasma/plasma-integration/Manifest
@@ -1,2 +1,3 @@
DIST plasma-integration-5.11.5.tar.xz 55856 BLAKE2B 4c1d56f9de0007d369eeca5f7a992f95ac9a7853ad30f80b86a762b2ba88a5c87cd0861590e640466314edc4436052063be7e9718754a73388eb60baa253285f SHA512 2e14b0bae19e344dd0ddd27b48ddf9f9075b773c295b58a35b05d0c9d11c1573821ec1c25ae33da4e3a4091386301aef15c51f4d1163aa195a1de5f3ea1844c4
DIST plasma-integration-5.12.2.tar.xz 53432 BLAKE2B 80290cb001b19ebea676fea4f8087ab681b0ecf03201e8f2111bf1a55f4c89097f7809f90facb7b2ab9e7946d74208312eb773d26ccfb8fa662380c12c5e11e1 SHA512 19b3ad0a47631b8c61c4b23ba6d88007d105742ed1223ef027d9e72d8549d51dc1473499300967471224bcd43bdc205a39650cdc4a551bf8e006af5c271b62d4
+DIST plasma-integration-5.12.3.tar.xz 53756 BLAKE2B 37bec063aa8a7d82746a60ecfc6205af744aa5a3e35562f72a8dce52a1bab19923e78742ea9373206143a92456d967ced92532205d43f72d56b8ece35d9c1860 SHA512 135ad3803d76a2e069404655c37ff152496e380c1e8b7bc4a18a620979822520b11a4753c59389f9be08cf401b6c6375ece46aa10cfb55ea9cc34b3b06dbf51a
diff --git a/kde-plasma/plasma-integration/plasma-integration-5.12.3.ebuild b/kde-plasma/plasma-integration/plasma-integration-5.12.3.ebuild
new file mode 100644
index 000000000000..1d60d9295f03
--- /dev/null
+++ b/kde-plasma/plasma-integration/plasma-integration-5.12.3.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="Qt Platform Theme integration plugins for the Plasma workspaces"
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE=""
+
+DEPEND="
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kjobwidgets)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep kwayland)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kwindowsystem)
+ $(add_frameworks_dep kxmlgui)
+ $(add_plasma_dep breeze)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui 'dbus' '' '5=')
+ $(add_qt_dep qtquickcontrols2)
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtx11extras)
+ x11-libs/libXcursor
+ x11-libs/libxcb
+"
+RDEPEND="${DEPEND}
+ media-fonts/hack
+ media-fonts/noto
+"
+
+# requires running kde environment
+RESTRICT+=" test"