summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/evolution-data-server/evolution-data-server-3.52.4-r2.ebuild (renamed from gnome-extra/evolution-data-server/evolution-data-server-3.52.4-r1.ebuild)17
-rw-r--r--gnome-extra/evolution-data-server/metadata.xml1
2 files changed, 13 insertions, 5 deletions
diff --git a/gnome-extra/evolution-data-server/evolution-data-server-3.52.4-r1.ebuild b/gnome-extra/evolution-data-server/evolution-data-server-3.52.4-r2.ebuild
index 56a0d678f6fd..9ddadc5e8348 100644
--- a/gnome-extra/evolution-data-server/evolution-data-server-3.52.4-r1.ebuild
+++ b/gnome-extra/evolution-data-server/evolution-data-server-3.52.4-r2.ebuild
@@ -14,7 +14,7 @@ SLOT="0/64-11-21-4-3-27-2-27-4-0" # subslot = libcamel-1.2/libebackend-1.2/libeb
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
-IUSE="berkdb +gnome-online-accounts +gtk gtk-doc +introspection ldap kerberos oauth-gtk3 oauth-gtk4 vala +weather"
+IUSE="berkdb +gnome-online-accounts +gtk gtk-doc +introspection ldap kerberos oauth-gtk3 oauth-gtk4 sound vala +weather"
REQUIRED_USE="
oauth-gtk3? ( gtk )
oauth-gtk4? ( gtk )
@@ -42,9 +42,11 @@ RDEPEND="
gtk? (
>=x11-libs/gtk+-3.20:3
>=gui-libs/gtk-4.4:4
- || (
- media-libs/libcanberra-gtk3
- >=media-libs/libcanberra-0.25[gtk3(-)]
+ sound? (
+ || (
+ media-libs/libcanberra-gtk3
+ >=media-libs/libcanberra-0.25[gtk3(-)]
+ )
)
oauth-gtk3? ( >=net-libs/webkit-gtk-2.34.0:4.1 )
@@ -127,7 +129,6 @@ src_configure() {
-DENABLE_SMIME=ON
-DENABLE_GTK=$(usex gtk)
-DENABLE_GTK4=$(usex gtk)
- -DENABLE_CANBERRA=$(usex gtk)
-DENABLE_OAUTH2_WEBKITGTK=$(usex oauth-gtk3)
-DENABLE_OAUTH2_WEBKITGTK4=$(usex oauth-gtk4)
-DENABLE_EXAMPLES=OFF
@@ -140,6 +141,12 @@ src_configure() {
-DENABLE_VALA_BINDINGS=$(usex vala)
-DENABLE_TESTS=$(usex test)
)
+ if use gtk && use sound; then
+ mycmakeargs+=( -DENABLE_CANBERRA=ON )
+ else
+ mycmakeargs+=( -DENABLE_CANBERRA=OFF )
+ fi
+
cmake_src_configure
}
diff --git a/gnome-extra/evolution-data-server/metadata.xml b/gnome-extra/evolution-data-server/metadata.xml
index d705ce69fe9e..06224757e5a5 100644
--- a/gnome-extra/evolution-data-server/metadata.xml
+++ b/gnome-extra/evolution-data-server/metadata.xml
@@ -10,6 +10,7 @@
<flag name="gnome-online-accounts">Enable <pkg>net-libs/gnome-online-accounts</pkg> based Google authentication support</flag>
<flag name="oauth-gtk3">Enable internal OAuth2 authentication for GTK+3 applications (libedataserverui-*.so) support for Google and Outlook.com. If gnome-online-accounts is enabled and used, this is not necessary, but both can be supported at the same time with different setup at runtime</flag>
<flag name="oauth-gtk4">Enable internal OAuth2 authentication for GTK 4 applications (libedataserverui4-*.so) support for Google and Outlook.com. If gnome-online-accounts is enabled and used, this is not necessary, but both can be supported at the same time with different setup at runtime</flag>
+ <flag name="sound">Sound notification support through <pkg>media-libs/libcanberra-gtk3</pkg> (does nothing without USE=gtk)</flag>
<flag name="weather">Enable optional weather calendar support</flag>
</use>
<upstream>