summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/utidylib')
-rw-r--r--dev-python/utidylib/utidylib-0.6-r1.ebuild6
-rw-r--r--dev-python/utidylib/utidylib-0.7.ebuild2
2 files changed, 4 insertions, 4 deletions
diff --git a/dev-python/utidylib/utidylib-0.6-r1.ebuild b/dev-python/utidylib/utidylib-0.6-r1.ebuild
index 9f3834f74caa..3b82a2b1f546 100644
--- a/dev-python/utidylib/utidylib-0.6-r1.ebuild
+++ b/dev-python/utidylib/utidylib-0.6-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7,8,9} )
+PYTHON_COMPAT=( python3_{8,9} )
MY_P="uTidylib-${PV}"
inherit distutils-r1
@@ -28,7 +28,7 @@ DEPEND="
dev-python/six[${PYTHON_USEDEP}]
"
RDEPEND="
- app-text/tidy-html5
+ || ( app-text/tidy-html5 >=app-text/htmltidy-5.0.0 )
"
RESTRICT="!test? ( test )"
diff --git a/dev-python/utidylib/utidylib-0.7.ebuild b/dev-python/utidylib/utidylib-0.7.ebuild
index bf5039557621..d6947dea0a0e 100644
--- a/dev-python/utidylib/utidylib-0.7.ebuild
+++ b/dev-python/utidylib/utidylib-0.7.ebuild
@@ -16,7 +16,7 @@ LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~arm64 ~ppc ~ppc64 ~x86"
-RDEPEND="app-text/tidy-html5"
+RDEPEND="|| ( app-text/tidy-html5 >=app-text/htmltidy-5.0.0 )"
DEPEND="dev-python/six[${PYTHON_USEDEP}]"
distutils_enable_tests pytest