summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/gkeys')
-rw-r--r--app-crypt/gkeys/Manifest1
-rw-r--r--app-crypt/gkeys/gkeys-0.1-r1.ebuild53
-rw-r--r--app-crypt/gkeys/gkeys-9999.ebuild67
-rw-r--r--app-crypt/gkeys/metadata.xml8
4 files changed, 129 insertions, 0 deletions
diff --git a/app-crypt/gkeys/Manifest b/app-crypt/gkeys/Manifest
new file mode 100644
index 000000000000..9d9030f31546
--- /dev/null
+++ b/app-crypt/gkeys/Manifest
@@ -0,0 +1 @@
+DIST gkeys-0.1.tar.bz2 40987 SHA256 b1e99873d1f966837eeb83b82d9289f6a6414de5a8467586b88d466800528524 SHA512 7da21ffc652ae95b308c8e8cd57754ad45b9414626b95d38b69867704df5def0a18cdb25934962e4a6109feeddbd1bbd8ac47f445b2977a869993b00771e79c5 WHIRLPOOL adc258dbc7955bf05f31106d16d1d4bd247517bd16d5562f1757e14a274d69c05b6749d83a94029caadd3704003f18cf8ca0e5985d6fbd498204ef36c91c4950
diff --git a/app-crypt/gkeys/gkeys-0.1-r1.ebuild b/app-crypt/gkeys/gkeys-0.1-r1.ebuild
new file mode 100644
index 000000000000..6dde42badd63
--- /dev/null
+++ b/app-crypt/gkeys/gkeys-0.1-r1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+PYTHON_COMPAT=(python{2_7,3_3,3_4})
+
+inherit distutils-r1
+
+DESCRIPTION="An OpenPGP/GPG key management tool for seed files and keyrings"
+HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Gentoo-keys"
+SRC_URI="http://dev.gentoo.org/~dolsen/releases/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+KEYWORDS="~amd64 ~arm ~x86"
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ app-crypt/gnupg
+ >=dev-python/pyGPG-0.1[${PYTHON_USEDEP}]
+ >=dev-python/ssl-fetch-0.3[${PYTHON_USEDEP}]
+ dev-python/snakeoil[${PYTHON_USEDEP}]
+ >=app-crypt/gentoo-keys-201501052117
+ "
+
+python_install_all() {
+ distutils-r1_python_install_all
+ keepdir /var/log/gkeys
+ fperms g+w /var/log/gkeys
+}
+
+pkg_preinst() {
+ chgrp users "${D}"/var/log/gkeys
+}
+
+pkg_postinst() {
+ einfo "Fetching Gentoo Developer seed file..."
+ gkeys fetch-seed -C gentoo-devs || die "Unable to fetch seeds"
+ einfo "This is experimental software."
+ einfo "The API's it installs should be considered unstable"
+ einfo "and are subject to change."
+ einfo
+ einfo "Please file any enhancement requests, or bugs"
+ einfo "at https://bugs.gentoo.org"
+ einfo "We are also on IRC @ #gentoo-keys of the Freenode network"
+ einfo
+ ewarn "There may be some Python 3 compatibility issues still."
+ ewarn "Please help us debug, fix and report them in Bugzilla."
+}
diff --git a/app-crypt/gkeys/gkeys-9999.ebuild b/app-crypt/gkeys/gkeys-9999.ebuild
new file mode 100644
index 000000000000..0f149c9ef0f0
--- /dev/null
+++ b/app-crypt/gkeys/gkeys-9999.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+PYTHON_COMPAT=(python{2_7,3_3,3_4})
+
+#EGIT_PROJECT="gentoo-keys.git"
+EGIT_BRANCH="master"
+
+inherit distutils-r1 git-r3
+
+EGIT_REPO_URI="git://anongit.gentoo.org/proj/gentoo-keys.git"
+
+DESCRIPTION="An OpenPGP/GPG key management tool and python libs"
+HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Gentoo-keys"
+SRC_URI=""
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+KEYWORDS=""
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ app-crypt/gnupg
+ =dev-python/pyGPG-9999[${PYTHON_USEDEP}]
+ =dev-python/ssl-fetch-9999[${PYTHON_USEDEP}]
+ dev-python/snakeoil[${PYTHON_USEDEP}]
+ >=app-crypt/gentoo-keys-201501052117
+ "
+
+S="${WORKDIR}/$P/gkeys"
+
+python_prepare_all() {
+ distutils-r1_python_prepare_all
+ # copy these 2 into our subdir from the master level
+ cp ../LICENSE ./ || die "cp LICENSE failed"
+ cp ../README.md ./ || die "cp README.me failed"
+ cp -R ../py2man ./ || die "cp-R py2man failed"
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ keepdir /var/log/gkeys
+ fperms g+w /var/log/gkeys
+}
+
+pkg_preinst() {
+ chgrp users "${D}"/var/log/gkeys
+}
+
+pkg_postinst() {
+ einfo
+ einfo "This is experimental software."
+ einfo "The API's it installs should be considered unstable"
+ einfo "and are subject to change."
+ einfo
+ einfo "Please file any enhancement requests, or bugs"
+ einfo "at https://bugs.gentoo.org"
+ einfo "We are also on IRC @ #gentoo-keys of the freenode network"
+ einfo
+ ewarn "There may be some python 3 compatibility issues still."
+ ewarn "Please help debug/fix/report them in bugzilla."
+}
diff --git a/app-crypt/gkeys/metadata.xml b/app-crypt/gkeys/metadata.xml
new file mode 100644
index 000000000000..cdb5f20cd868
--- /dev/null
+++ b/app-crypt/gkeys/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>gkeys@gentoo.org</email>
+ <name>Gentoo-keys Project Team</name>
+ </maintainer>
+</pkgmetadata>