summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/httpauth/httpauth-0.3.ebuild14
1 files changed, 3 insertions, 11 deletions
diff --git a/dev-python/httpauth/httpauth-0.3.ebuild b/dev-python/httpauth/httpauth-0.3.ebuild
index ec763d1968cc..5bff2d382521 100644
--- a/dev-python/httpauth/httpauth-0.3.ebuild
+++ b/dev-python/httpauth/httpauth-0.3.ebuild
@@ -3,7 +3,8 @@
EAPI=7
-PYTHON_COMPAT=( pypy3 python3_{6,7} )
+PYTHON_COMPAT=( pypy3 python3_{6,7,8} )
+DISTUTILS_USE_SETUPTOOLS=no
inherit distutils-r1
@@ -14,14 +15,5 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="ISC"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-BDEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( dev-python/nose[${PYTHON_USEDEP}] )
-"
-
-python_test() {
- nosetests -v tests.py || die "tests failed with ${EPYTHON}"
-}
+distutils_enable_tests nose