summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-wm/selectwm/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-wm/selectwm/files')
-rw-r--r--x11-wm/selectwm/files/selectwm-0.4.1-enable-deprecated-gtk.patch11
-rw-r--r--x11-wm/selectwm/files/selectwm-0.4.1-glibc-2.10.patch21
-rw-r--r--x11-wm/selectwm/files/selectwm-0.4.1-nostrip.patch15
3 files changed, 47 insertions, 0 deletions
diff --git a/x11-wm/selectwm/files/selectwm-0.4.1-enable-deprecated-gtk.patch b/x11-wm/selectwm/files/selectwm-0.4.1-enable-deprecated-gtk.patch
new file mode 100644
index 000000000000..df7f9e437b45
--- /dev/null
+++ b/x11-wm/selectwm/files/selectwm-0.4.1-enable-deprecated-gtk.patch
@@ -0,0 +1,11 @@
+--- selectwm-0.4.1.orig/src/define.h 2007-09-30 21:48:25.000000000 +0200
++++ selectwm-0.4.1/src/define.h 2007-09-30 22:01:53.000000000 +0200
+@@ -1,8 +1,5 @@
+ #include "config.h"
+
+-#define GTK_DISABLE_DEPRECATED
+-#define G_DISABLE_DEPRECATED
+-
+ #ifdef ENABLE_NLS
+ # include <libintl.h>
+ # undef _
diff --git a/x11-wm/selectwm/files/selectwm-0.4.1-glibc-2.10.patch b/x11-wm/selectwm/files/selectwm-0.4.1-glibc-2.10.patch
new file mode 100644
index 000000000000..4353d5e36662
--- /dev/null
+++ b/x11-wm/selectwm/files/selectwm-0.4.1-glibc-2.10.patch
@@ -0,0 +1,21 @@
+diff -Naurp selectwm-0.4.1-orig/src/options.c selectwm-0.4.1/src/options.c
+--- selectwm-0.4.1-orig/src/options.c 2009-07-26 14:46:44.092880624 -0600
++++ selectwm-0.4.1/src/options.c 2009-07-26 14:46:11.484940363 -0600
+@@ -32,7 +32,7 @@
+ #include "miscui.h"
+ #include "modify.h"
+
+-static GString *getline (FILE *fichier) {
++static GString *selectwm_getline (FILE *fichier) {
+ GString *temp;
+ gchar buf[128];
+
+@@ -64,7 +64,7 @@ static gint read_config_file (config *se
+ }
+ buf = g_string_new ("");
+ while (!feof (config)) {
+- buf = getline (config);
++ buf = selectwm_getline (config);
+
+ if (buf->len > 0 && buf->str[0] != '#') {
+ if (g_strrstr (buf->str, ":")) {
diff --git a/x11-wm/selectwm/files/selectwm-0.4.1-nostrip.patch b/x11-wm/selectwm/files/selectwm-0.4.1-nostrip.patch
new file mode 100644
index 000000000000..d5300c9f94a7
--- /dev/null
+++ b/x11-wm/selectwm/files/selectwm-0.4.1-nostrip.patch
@@ -0,0 +1,15 @@
+Respect CFLAGS, don't strip binaries
+
+http://bugs.gentoo.org/show_bug.cgi?id=252124
+
+--- src/Makefile.am
++++ src/Makefile.am
+@@ -10,5 +10,6 @@
+ modify.c modify.h \
+ misc.h define.h
+
+-LIBS = @GTK_LIBS@
+-AM_CFLAGS = -s -O2 -Wall @GTK_CFLAGS@ -DLOCALEDIR=\"$(datadir)/locale\"
++selectwm_LDADD = @GTK_LIBS@
++selectwm_CFLAGS = @GTK_CFLAGS@
++selectwm_CPPFLAGS = -DLOCALEDIR=\"$(datadir)/locale\"