summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authortastytea <gentoo@tastytea.de>2024-02-20 20:19:30 +0100
committerViorel Munteanu <ceamac@gentoo.org>2024-02-22 16:52:14 +0200
commit96865bb3ba35ade3fa643004326b6392cfca90d0 (patch)
tree727f0679e387170d6299fcdaeea86baa9235336a /www-apps/hugo
parentdev-util/mingw64-toolchain: prevent sys/sdt.h (systemtap) detection (diff)
downloadgentoo-96865bb3ba35ade3fa643004326b6392cfca90d0.tar.gz
gentoo-96865bb3ba35ade3fa643004326b6392cfca90d0.tar.bz2
gentoo-96865bb3ba35ade3fa643004326b6392cfca90d0.zip
www-apps/hugo: add 0.123.0
Signed-off-by: tastytea <gentoo@tastytea.de> Closes: https://github.com/gentoo/gentoo/pull/35447 Signed-off-by: Viorel Munteanu <ceamac@gentoo.org>
Diffstat (limited to 'www-apps/hugo')
-rw-r--r--www-apps/hugo/Manifest2
-rw-r--r--www-apps/hugo/files/hugo-0.123.0-skip-some-tests.patch65
-rw-r--r--www-apps/hugo/hugo-0.123.0.ebuild101
3 files changed, 168 insertions, 0 deletions
diff --git a/www-apps/hugo/Manifest b/www-apps/hugo/Manifest
index 3640d510a87e..e3f2d13edafe 100644
--- a/www-apps/hugo/Manifest
+++ b/www-apps/hugo/Manifest
@@ -2,3 +2,5 @@ DIST hugo-0.121.0-vendor.tar.xz 6682060 BLAKE2B 7aabdd97eada6b83e0e7bebe632f7b46
DIST hugo-0.121.0.tar.gz 21036266 BLAKE2B a924e2ad2fc4a5c690bf3bdd2e837add543119632f3055117a73455555bc78996b9f3eeb42c94694135a8f174aced72fea359ca39ca3ed76673b2284dc641d60 SHA512 99566167e74e1eda996ca54b0284a56a1bcd6c69f60d4461faa3bcca2f0c2d499b5e4de806a78576b5ec7691aa6d81fb66b6f088a25255fc9496d1f65d37d2ac
DIST hugo-0.121.2-vendor.tar.xz 6683208 BLAKE2B d4be99aaf686c79cfda28c3ed4d1023b5012f57375835dfca0311761dfc2a47499dc5095d64d010c111a2e09dec92741e6b7bea0f81900749778c0a403c255c2 SHA512 c15d37d0b07cc57425b1be3fdcaf887e13b38e911b355691fae3ba505eed4041dd6fc8c28925d71a4f8fd89900b8d9da105aa489c72109826611aca36dcb88b7
DIST hugo-0.121.2.tar.gz 21074668 BLAKE2B 06e42bcba49e9e2329ae1b76cc76caf2ac83e13f067533e07cd5471c064ecc402fb7cffaa21df4e20514d96bcfb7f16b4ff078ab23b84506a4ccfc423b21afca SHA512 717da396fa887995e455c1cc7cfc21c535583ba70cb90bcb15ea47e389aa636e9ffa4f66b28bf313f225579e40bc2864ef9da6ebf00d006b3a1ca68f38a47673
+DIST hugo-0.123.0-vendor.tar.xz 6613120 BLAKE2B 4ccf23139eea6cf3d262092234735b9c8faa705b4ffeead73f439ea3703579c3287b82304b201b0ac9d6457c30c9105b77d6ef7916f7a6a814f8763f7c65453a SHA512 21911b4c15e4fd1241f5aaedd307240ca1e90f5fed25363d4cea410c31259fae5d41a6f3a6feaad6a22c596f6aec69095ed11b2194735aeac2a2c8412fdf8042
+DIST hugo-0.123.0.tar.gz 21034964 BLAKE2B 0d1c22d7e8ce71f574cefb1209da82a3de93e6d162ed19cfa950acc159514e5dbc2bd21a6b6116887408a4a257e9f36d6a4a8ad5bb64d5c44db60eccb3238702 SHA512 8835b620d480e86df3a315b101d131b3defde29b21628ba48fe805c1af2625600a5c0fe64ebbab48c8ca56310d5d3aae3c98c27f116a5044ce171a68c072006d
diff --git a/www-apps/hugo/files/hugo-0.123.0-skip-some-tests.patch b/www-apps/hugo/files/hugo-0.123.0-skip-some-tests.patch
new file mode 100644
index 000000000000..c6b075998caf
--- /dev/null
+++ b/www-apps/hugo/files/hugo-0.123.0-skip-some-tests.patch
@@ -0,0 +1,65 @@
+From 1a3938e8c133573f35abe58edd42204575aeffeb Mon Sep 17 00:00:00 2001
+From: tastytea <tastytea@tastytea.de>
+Date: Fri, 8 Sep 2023 20:01:03 +0200
+Subject: [PATCH] skip some tests
+
+reasons:
+ - needs to be in a git repo
+ - needs special test dependencies
+ - requires network access
+---
+ modules/client_test.go | 4 ++++
+ .../resource_factories/create/create_integration_test.go | 1 +
+ 2 files changed, 5 insertions(+)
+
+diff --git a/modules/client_test.go b/modules/client_test.go
+index ea910580f..b957ba984 100644
+--- a/modules/client_test.go
++++ b/modules/client_test.go
+@@ -68,6 +68,7 @@ github.com/gohugoio/hugoTestModules1_darwin/modh2_2@v1.4.0 github.com/gohugoio/h
+ }
+
+ c.Run("All", func(c *qt.C) {
++ c.Skip("Test dependencies not available")
+ client, clean := newClient(c, func(cfg *ClientConfig) {
+ cfg.ModuleConfig = DefaultModuleConfig
+ }, defaultImport)
+@@ -107,6 +108,7 @@ project github.com/gohugoio/hugoTestModules1_darwin/modh2_2_2@v1.3.0+vendor
+ })
+
+ c.Run("IgnoreVendor", func(c *qt.C) {
++ c.Skip("Test dependencies not available")
+ client, clean := newClient(
+ c, func(cfg *ClientConfig) {
+ cfg.ModuleConfig = DefaultModuleConfig
+@@ -125,6 +127,7 @@ project github.com/gohugoio/hugoTestModules1_darwin/modh2_2_2@v1.3.0+vendor
+ })
+
+ c.Run("NoVendor", func(c *qt.C) {
++ c.Skip("Test dependencies not available")
+ mcfg := DefaultModuleConfig
+ mcfg.NoVendor = "**"
+ client, clean := newClient(
+@@ -144,6 +147,7 @@ project github.com/gohugoio/hugoTestModules1_darwin/modh2_2_2@v1.3.0+vendor
+ })
+
+ c.Run("VendorClosest", func(c *qt.C) {
++ c.Skip("Test dependencies not available")
+ mcfg := DefaultModuleConfig
+ mcfg.VendorClosest = true
+
+diff --git a/resources/resource_factories/create/create_integration_test.go b/resources/resource_factories/create/create_integration_test.go
+index 61bc17adb..13cd6f33f 100644
+--- a/resources/resource_factories/create/create_integration_test.go
++++ b/resources/resource_factories/create/create_integration_test.go
+@@ -25,6 +25,7 @@ import (
+ )
+
+ func TestGetRemoteHead(t *testing.T) {
++ t.Skip("Requires network access")
+ files := `
+ -- config.toml --
+ [security]
+--
+2.43.0
+
diff --git a/www-apps/hugo/hugo-0.123.0.ebuild b/www-apps/hugo/hugo-0.123.0.ebuild
new file mode 100644
index 000000000000..f7559ea691b9
--- /dev/null
+++ b/www-apps/hugo/hugo-0.123.0.ebuild
@@ -0,0 +1,101 @@
+# Copyright 2018-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module shell-completion
+
+DESCRIPTION="Fast static HTML and CSS website generator"
+HOMEPAGE="https://gohugo.io https://github.com/gohugoio/hugo"
+SRC_URI="
+ https://github.com/gohugoio/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ https://tastytea.de/files/gentoo/${P}-vendor.tar.xz
+"
+
+# NOTE: To create the vendor tarball, run:
+# `go mod vendor && cd .. && tar -caf ${P}-vendor.tar.xz ${P}/vendor`
+
+LICENSE="Apache-2.0 BSD BSD-2 MIT MPL-2.0 Unlicense"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~loong ~riscv ~x86"
+IUSE="doc +extended test"
+
+BDEPEND="
+ >=dev-lang/go-1.21.6
+ test? (
+ dev-python/docutils
+ dev-ruby/asciidoctor
+ virtual/pandoc
+ )
+"
+RDEPEND="
+ extended? (
+ dev-libs/libsass:=
+ >=media-libs/libwebp-1.3.2:=
+ )
+"
+DEPEND="${RDEPEND}"
+
+RESTRICT="!test? ( test )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.121.0-unbundle-libwebp-and-libsass.patch
+ "${FILESDIR}"/${PN}-0.123.0-skip-some-tests.patch
+)
+
+src_configure() {
+ export CGO_ENABLED=1
+ export CGO_CFLAGS="${CFLAGS}"
+ export CGO_CPPFLAGS="${CPPFLAGS}"
+ export CGO_CXXFLAGS="${CXXFLAGS}"
+ export CGO_LDFLAGS="${LDFLAGS}"
+ export MY_BUILD_FLAGS="$(usev extended "-tags extended")"
+
+ default
+}
+
+src_prepare() {
+ # wants to run command that require network access
+ rm testscripts/commands/mod{,_vendor,__disable,_get,_get_u,_npm{,_withexisting}}.txt || die
+
+ default
+}
+
+src_compile() {
+ mkdir -pv bin || die
+ ego build -ldflags "-X github.com/gohugoio/hugo/common/hugo.vendorInfo=gentoo:${PVR}" \
+ ${MY_BUILD_FLAGS} -o "${S}/bin/hugo"
+
+ bin/hugo gen man --dir man || die
+
+ mkdir -pv completions || die
+ bin/hugo completion bash > completions/hugo || die
+ bin/hugo completion fish > completions/hugo.fish || die
+ bin/hugo completion zsh > completions/_hugo || die
+
+ if use doc ; then
+ bin/hugo gen doc --dir doc || die
+ fi
+}
+
+src_test() {
+ ego test "./..." ${MY_BUILD_FLAGS}
+}
+
+src_install() {
+ dobin bin/*
+ doman man/*
+
+ dobashcomp completions/${PN}
+ dofishcomp completions/${PN}.fish
+ dozshcomp completions/_${PN}
+
+ if use doc ; then
+ dodoc -r doc/*
+ fi
+}
+
+pkg_postinst() {
+ elog "the sass USE-flag was renamed to extended. the functionality is the" \
+ "same, except it also toggles the dependency on libwebp (for encoding)"
+}