summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWiktor Jaskulski <wjaskulski@adva.com>2023-08-29 16:12:36 +0200
committerJason Zaman <perfinion@gentoo.org>2024-09-08 16:13:15 -0700
commit9a4f9201cc22546ff3dac7747740968113147ade (patch)
tree5dbb189337024afd805fb1c083b4080b879148c8 /sys-process
parentsys-devel/gcc: add 15.0.0_pre20240908 (diff)
downloadgentoo-9a4f9201cc22546ff3dac7747740968113147ade.tar.gz
gentoo-9a4f9201cc22546ff3dac7747740968113147ade.tar.bz2
gentoo-9a4f9201cc22546ff3dac7747740968113147ade.zip
sys-process/audit: fix cross compilation and add arch specific support configure options
Closes: https://github.com/gentoo/gentoo/pull/32507 Signed-off-by: Wiktor Jaskulski <wjaskulski@adva.com> Signed-off-by: Jason Zaman <perfinion@gentoo.org>
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/audit/audit-3.1.2.ebuild3
-rw-r--r--sys-process/audit/audit-3.1.3.ebuild3
-rw-r--r--sys-process/audit/audit-3.1.4-r1.ebuild3
-rw-r--r--sys-process/audit/audit-4.0.1-r1.ebuild3
4 files changed, 12 insertions, 0 deletions
diff --git a/sys-process/audit/audit-3.1.2.ebuild b/sys-process/audit/audit-3.1.2.ebuild
index 8984d7758dcb..858f1d192457 100644
--- a/sys-process/audit/audit-3.1.2.ebuild
+++ b/sys-process/audit/audit-3.1.2.ebuild
@@ -74,6 +74,8 @@ multilib_src_configure() {
$(use_enable ldap zos-remote)
$(use_enable static-libs static)
$(use_with io-uring io_uring)
+ $(use_with arm)
+ $(use_with arm64 aarch64)
--enable-systemd
--without-golang
--without-libwrap
@@ -89,6 +91,7 @@ multilib_src_configure() {
pushd "${BUILD_DIR}" &>/dev/null || die
ECONF_SOURCE="${S}" econf "${myeconfargs[@]}" --with-python3
+ find . -type f -name 'Makefile' -exec sed -i "s;-I/usr/include/python;-I${SYSROOT}/usr/include/python;g" {} +
popd &>/dev/null || die
}
diff --git a/sys-process/audit/audit-3.1.3.ebuild b/sys-process/audit/audit-3.1.3.ebuild
index e185e4615aae..32ea5f173385 100644
--- a/sys-process/audit/audit-3.1.3.ebuild
+++ b/sys-process/audit/audit-3.1.3.ebuild
@@ -74,6 +74,8 @@ multilib_src_configure() {
$(use_enable gssapi gssapi-krb5)
$(use_enable ldap zos-remote)
$(use_enable static-libs static)
+ $(use_with arm)
+ $(use_with arm64 aarch64)
$(use_with io-uring io_uring)
--enable-systemd
--without-golang
@@ -90,6 +92,7 @@ multilib_src_configure() {
pushd "${BUILD_DIR}" &>/dev/null || die
ECONF_SOURCE="${S}" econf "${myeconfargs[@]}" --with-python3
+ find . -type f -name 'Makefile' -exec sed -i "s;-I/usr/include/python;-I${SYSROOT}/usr/include/python;g" {} +
popd &>/dev/null || die
}
diff --git a/sys-process/audit/audit-3.1.4-r1.ebuild b/sys-process/audit/audit-3.1.4-r1.ebuild
index 33f5402ee966..1dadef4e44bb 100644
--- a/sys-process/audit/audit-3.1.4-r1.ebuild
+++ b/sys-process/audit/audit-3.1.4-r1.ebuild
@@ -74,6 +74,8 @@ multilib_src_configure() {
$(use_enable gssapi gssapi-krb5)
$(use_enable ldap zos-remote)
$(use_enable static-libs static)
+ $(use_with arm)
+ $(use_with arm64 aarch64)
$(use_with io-uring io_uring)
--enable-systemd
--without-golang
@@ -90,6 +92,7 @@ multilib_src_configure() {
pushd "${BUILD_DIR}" &>/dev/null || die
ECONF_SOURCE="${S}" econf "${myeconfargs[@]}" --with-python3
+ find . -type f -name 'Makefile' -exec sed -i "s;-I/usr/include/python;-I${SYSROOT}/usr/include/python;g" {} +
popd &>/dev/null || die
}
diff --git a/sys-process/audit/audit-4.0.1-r1.ebuild b/sys-process/audit/audit-4.0.1-r1.ebuild
index 0757b5e9644a..a94dca39c0c5 100644
--- a/sys-process/audit/audit-4.0.1-r1.ebuild
+++ b/sys-process/audit/audit-4.0.1-r1.ebuild
@@ -77,6 +77,8 @@ multilib_src_configure() {
$(use_enable gssapi gssapi-krb5)
$(use_enable ldap zos-remote)
$(use_enable static-libs static)
+ $(use_with arm)
+ $(use_with arm64 aarch64)
$(use_with io-uring io_uring)
--without-golang
--without-libwrap
@@ -91,6 +93,7 @@ multilib_src_configure() {
pushd "${BUILD_DIR}" &>/dev/null || die
ECONF_SOURCE="${S}" econf "${myeconfargs[@]}" --with-python3
+ find . -type f -name 'Makefile' -exec sed -i "s;-I/usr/include/python;-I${SYSROOT}/usr/include/python;g" {} +
popd &>/dev/null || die
}