summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-02-02 04:50:01 +0000
committerSam James <sam@gentoo.org>2024-02-02 04:50:01 +0000
commit1188ec9cacc0ff46734a34247b916dbae00ed6e1 (patch)
treef30bc6c60d765ae62815adca21dc0d4b9e6168ee /sys-apps
parentsys-apps/fakeroot: add 1.33 (diff)
downloadgentoo-1188ec9cacc0ff46734a34247b916dbae00ed6e1.tar.gz
gentoo-1188ec9cacc0ff46734a34247b916dbae00ed6e1.tar.bz2
gentoo-1188ec9cacc0ff46734a34247b916dbae00ed6e1.zip
sys-apps/logwatch: add 7.10
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/logwatch/Manifest1
-rw-r--r--sys-apps/logwatch/logwatch-7.10.ebuild96
2 files changed, 97 insertions, 0 deletions
diff --git a/sys-apps/logwatch/Manifest b/sys-apps/logwatch/Manifest
index 837471d8a81c..31260357e110 100644
--- a/sys-apps/logwatch/Manifest
+++ b/sys-apps/logwatch/Manifest
@@ -1 +1,2 @@
+DIST logwatch-7.10.tar.gz 511766 BLAKE2B 66d7cb09f4c73ca55a3bad9eb2e9a46eabdc0da444e5361ddc10e7bee28de2e58f2c10530f75d40b2689d33624d612f439171b995e9f21a7e48bf211db1f2bd2 SHA512 838bcc7a3b12eb31450a20195fe2ca4ab238500051bb2f50bd1775272fefa412e0a2473c0294a5495ef594fa530b00dac0dc6d18b93e124f36614686502e55cb
DIST logwatch-7.9.tar.gz 501086 BLAKE2B ebfc65c88036244840fe4fbf42c0bea668cac3063771f0042827a2f583d654403b75bdfa428f50a7fdac5f0098ec08ef5a27006db7f7576b361653594462d607 SHA512 d091fbbeb0cac4b661fb066118fd384dbdeabe137c699ea6892d53567a45978c0742b1be9cf2f8b8c2e522314351ee6c2e3710ac2e61bbf1a3c8d63f78a3646f
diff --git a/sys-apps/logwatch/logwatch-7.10.ebuild b/sys-apps/logwatch/logwatch-7.10.ebuild
new file mode 100644
index 000000000000..b83d3ef67595
--- /dev/null
+++ b/sys-apps/logwatch/logwatch-7.10.ebuild
@@ -0,0 +1,96 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit tmpfiles
+
+DESCRIPTION="Analyzes and Reports on system logs"
+HOMEPAGE="https://sourceforge.net/projects/logwatch/"
+
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://git.code.sf.net/p/logwatch/git ${PN}"
+ inherit git-r3
+else
+ SRC_URI="mirror://sourceforge/${PN}/${P}/${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="selinux"
+
+RDEPEND="
+ dev-lang/perl
+ dev-perl/Date-Calc
+ dev-perl/Date-Manip
+ dev-perl/HTML-Parser
+ dev-perl/Tie-IxHash
+ dev-perl/Sys-CPU
+ dev-perl/Sys-MemInfo
+ virtual/cron
+ virtual/mta
+ virtual/mailx
+ selinux? ( sec-policy/selinux-logwatch )
+"
+
+src_install() {
+ dodir /usr/share/logwatch/lib
+ dodir /usr/share/logwatch/scripts/services
+ dodir /usr/share/logwatch/scripts/shared
+ dodir /usr/share/logwatch/default.conf/logfiles
+ dodir /usr/share/logwatch/default.conf/services
+ dodir /usr/share/logwatch/default.conf/html
+ keepdir /etc/logwatch
+
+ # logwatch.pl requires cache dir (bug #607668)
+ newtmpfiles "${FILESDIR}"/logwatch.tmpfile ${PN}.conf
+
+ newsbin scripts/logwatch.pl logwatch.pl
+
+ exeinto /usr/share/logwatch/lib
+ doexe lib/*.pm
+
+ exeinto /usr/share/logwatch/scripts/services
+ doexe scripts/services/*
+
+ exeinto /usr/share/logwatch/scripts/shared
+ doexe scripts/shared/*
+
+ insinto /usr/share/logwatch/default.conf
+ doins conf/logwatch.conf
+
+ insinto /usr/share/logwatch/default.conf/logfiles
+ doins conf/logfiles/*
+
+ insinto /usr/share/logwatch/default.conf/services
+ doins conf/services/*
+
+ insinto /usr/share/logwatch/default.conf/html
+ doins conf/html/*
+
+ # Make sure logwatch is run before anything else (bug #100243)
+ exeinto /etc/cron.daily
+ newexe "${FILESDIR}"/logwatch 00-logwatch
+
+ doman logwatch.8
+ dodoc README HOWTO-Customize-LogWatch
+
+ # Do last due to insopts modification.
+ insinto /usr/share/logwatch/scripts/logfiles
+ insopts -m755
+ doins -r scripts/logfiles/*
+}
+
+pkg_postinst() {
+ # Migration from /etc/cron.daily/logwatch -> /etc/cron.daily/00-logwatch (bug #100243)
+ if [[ -e ${ROOT}/etc/cron.daily/logwatch ]] ; then
+ local md5=$(md5sum "${ROOT}"/etc/cron.daily/logwatch)
+ [[ ${md5} == "edb003cbc0686ed4cf37db16025635f3" ]] \
+ && rm -f "${ROOT}"/etc/cron.daily/logwatch \
+ || ewarn "You have two logwatch files in /etc/cron.daily/"
+ fi
+
+ # Trigger cache dir creation to allow immediate use of logwatch (bug #607668)
+ tmpfiles_process ${PN}.conf
+}