summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2017-01-20 16:09:58 -0500
committerTim Harder <radhermit@gentoo.org>2017-01-20 16:11:13 -0500
commit3ed76694f95a62add5df970312415f15512711ed (patch)
treedb3eed278813b36576f86ff4fdaee9535a2335cb /sys-apps/ripgrep
parentnet-libs/libvncserver: Rev bump to remove sub slot (diff)
downloadgentoo-3ed76694f95a62add5df970312415f15512711ed.tar.gz
gentoo-3ed76694f95a62add5df970312415f15512711ed.tar.bz2
gentoo-3ed76694f95a62add5df970312415f15512711ed.zip
sys-apps/ripgrep: version bump to 0.4.0
Diffstat (limited to 'sys-apps/ripgrep')
-rw-r--r--sys-apps/ripgrep/Manifest1
-rw-r--r--sys-apps/ripgrep/ripgrep-0.4.0.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/sys-apps/ripgrep/Manifest b/sys-apps/ripgrep/Manifest
index c9fb528cb2df..056325704952 100644
--- a/sys-apps/ripgrep/Manifest
+++ b/sys-apps/ripgrep/Manifest
@@ -1,3 +1,4 @@
DIST ripgrep-0.2.9.tar.xz 36405508 SHA256 f5013f18620495a24af5bfa7a58b9f336831f489c34acbd91d963f27ab24a77d SHA512 3196b7e9cc9302e327ef09d87e5f586829deac5394e229b131bb4d76a54db05f12a9207f7b3b0d1d8c0790857ffd86dc4b177a31065f82f31192b3a7e6211399 WHIRLPOOL be4836c70ffc70827fdb2bf187624ddfa2238a97f93e7bb73dc4f3e13ea569f7a80bdb4ca0e956e661440849663891af88d3848eb8bc4758e02cbd6898806e6d
DIST ripgrep-0.3.1.tar.xz 36308304 SHA256 aa53e1518b692ea6de4d533cb6c22c7cf66d37b1d6aa20b0b66916d0796f23ae SHA512 130d987aad1dd9e1834579aaa095bdd0624fdf495418875179b3a0fbeccbb850531be446b86321d1b3d08dbbea157196fb037ecd4d491c44f573501a67ad4a98 WHIRLPOOL 1e421a23f596968444084873ad036ed417beeea8433b9572f4763ef74dc3653a7b49aa4309c531d3414f9f866aa44f8ef8a2474da6171cc535c26a7e2b83397f
DIST ripgrep-0.3.2.tar.xz 36002204 SHA256 a45c2af4efac72c12b8fe9eae05ca5f84f06f7387f94e6dcc614d4334955e44a SHA512 49463d442f1425b591fb17fc33ef8e1a34f368ce7d5862f375094936afc5140f09cece13fa193e9848d85c810e67503f648ec04d19298e23517f1443b7afc426 WHIRLPOOL 6972b47d8b34f76cd2b4ecf0787e8cede8454676dbc1a9cf889bba1d4a877a03eda844b705eea11a42def712c0253a6de7d602a4f0c52d888c36cbd0a9668ef4
+DIST ripgrep-0.4.0.tar.xz 39090216 SHA256 4ebf332e904af6a49195457dc235d8f543a15e130862bf604052a44792406c04 SHA512 a39986b7d08b9661d0d2a3c352a885eeecc0e0dba5fc130ce003f536e1f4638051ba95ab28f0502b778467f3a9a5dc02dd94f38d243b08cb547a8973665e89dd WHIRLPOOL 9b41f8e47cca59ed878283e0fc15211eb745223a54caafc5a9c396a617bbfa9f46783d1cc1ed7d58085de19b0bf3d789e2ec3dbf02216aa0f0f0a44d1042ae1d
diff --git a/sys-apps/ripgrep/ripgrep-0.4.0.ebuild b/sys-apps/ripgrep/ripgrep-0.4.0.ebuild
new file mode 100644
index 000000000000..8dd3de739331
--- /dev/null
+++ b/sys-apps/ripgrep/ripgrep-0.4.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DESCRIPTION="a command line search tool that combines usability with raw speed"
+HOMEPAGE="https://github.com/BurntSushi/ripgrep"
+#SRC_URI="https://github.com/BurntSushi/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+# custom tarball bundling all deps and index, otherwise cargo fetches from the network
+SRC_URI="http://dev.gentoo.org/~radhermit/dist/${P}.tar.xz"
+
+LICENSE="|| ( MIT Unlicense )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ dev-util/cargo
+ >=dev-lang/rust-1.11
+"
+
+src_prepare() {
+ default
+
+ # move cache dir where cargo expects it
+ mv .cargo "${HOME}" || die
+}
+
+src_compile() {
+ cargo build --release --verbose || die
+}
+
+src_test() {
+ cargo test || die "tests failed"
+}
+
+src_install() {
+ dobin target/release/rg
+ doman doc/rg.1
+ dodoc CHANGELOG.md README.md
+}