summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Zaman <perfinion@gentoo.org>2017-04-27 02:02:52 +0800
committerJason Zaman <perfinion@gentoo.org>2017-04-27 02:14:14 +0800
commit24edb9749c6742ef94607ec7d0df94d7d740549d (patch)
tree99a46d77d533afdce8e6d60fc00b78493dfb7ab8 /sys-apps/mcstrans
parentsys-libs/libselinux: build fixes patch merged upsream (diff)
downloadgentoo-24edb9749c6742ef94607ec7d0df94d7d740549d.tar.gz
gentoo-24edb9749c6742ef94607ec7d0df94d7d740549d.tar.bz2
gentoo-24edb9749c6742ef94607ec7d0df94d7d740549d.zip
sys-apps/mcstrans: New Package split from policycoreutils
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'sys-apps/mcstrans')
-rwxr-xr-xsys-apps/mcstrans/files/mcstransd.init31
-rw-r--r--sys-apps/mcstrans/mcstrans-9999.ebuild57
-rw-r--r--sys-apps/mcstrans/metadata.xml14
3 files changed, 102 insertions, 0 deletions
diff --git a/sys-apps/mcstrans/files/mcstransd.init b/sys-apps/mcstrans/files/mcstransd.init
new file mode 100755
index 000000000000..7c90e771b383
--- /dev/null
+++ b/sys-apps/mcstrans/files/mcstransd.init
@@ -0,0 +1,31 @@
+#!/sbin/openrc-run
+# Copyright 2006-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+is_selinux_enabled() {
+ local SE_ENABL="/usr/sbin/selinuxenabled"
+
+ if [ -x "$SE_ENABL" ]; then
+ $SE_ENABL && return 0 || return 1
+ else
+ ewarn "mcstransd: Unable to determine SELinux status"
+ return 1
+ fi
+}
+
+start() {
+ if is_selinux_enabled; then
+ ebegin "Starting mcstransd"
+ checkpath -q -d -m 0755 /run/setrans
+ start-stop-daemon --start --quiet --exec /sbin/mcstransd
+ eend $?
+ fi
+}
+
+stop() {
+ if is_selinux_enabled; then
+ ebegin "Stopping mcstransd"
+ start-stop-daemon --stop --quiet --name mcstransd
+ eend $?
+ fi
+}
diff --git a/sys-apps/mcstrans/mcstrans-9999.ebuild b/sys-apps/mcstrans/mcstrans-9999.ebuild
new file mode 100644
index 000000000000..edb294541632
--- /dev/null
+++ b/sys-apps/mcstrans/mcstrans-9999.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit toolchain-funcs
+
+MY_RELEASEDATE="20161014"
+
+MY_P="${P//_/-}"
+IUSE=""
+
+if [[ ${PV} == *9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/SELinuxProject/selinux.git"
+ S="${WORKDIR}/${MY_P}/${PN}"
+else
+ SRC_URI="https://raw.githubusercontent.com/wiki/SELinuxProject/selinux/files/releases/${MY_RELEASEDATE}/${MY_P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~mips ~x86"
+ S="${WORKDIR}/${MY_P}"
+fi
+
+DESCRIPTION="SELinux context translation to human readable names"
+HOMEPAGE="https://github.com/SELinuxProject/selinux/wiki"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+DEPEND=">=sys-libs/libsepol-${PV}:=
+ >=sys-libs/libselinux-${PV}:=
+ dev-libs/libpcre:=
+ >=sys-libs/libcap-1.10-r10:="
+
+RDEPEND="${DEPEND}
+ !<sys-apps/policycoreutils-2.7_pre"
+
+src_prepare() {
+ default
+
+ sed -i 's/-Werror//g' "${S}"/*/Makefile || die "Failed to remove Werror"
+}
+
+src_compile() {
+ emake \
+ CC="$(tc-getCC)" \
+ LIBDIR="\$(PREFIX)/$(get_libdir)"
+}
+
+src_install() {
+ emake DESTDIR="${D}" \
+ LIBDIR="\$(PREFIX)/$(get_libdir)" \
+ install
+
+ rm -rf "${D}/etc/rc.d" || die
+
+ newinitd "${FILESDIR}/mcstransd.init" mcstransd
+}
diff --git a/sys-apps/mcstrans/metadata.xml b/sys-apps/mcstrans/metadata.xml
new file mode 100644
index 000000000000..4236a792e95c
--- /dev/null
+++ b/sys-apps/mcstrans/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>selinux@gentoo.org</email>
+ <name>SELinux Team</name>
+ </maintainer>
+ <longdescription>
+ MCS translation daemon translates SELinux contexts to human readable format
+ </longdescription>
+ <upstream>
+ <remote-id type="github">SELinuxProject/selinux</remote-id>
+ </upstream>
+</pkgmetadata>