summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2023-02-19 17:57:30 +0100
committerAlfredo Tupone <tupone@gentoo.org>2023-02-19 18:04:00 +0100
commitf90bf1fc42802615a363ca6f58d15be3791dc020 (patch)
tree4307534c790c0e5f95186299431181a1bdc462a9 /sci-visualization/dash/dash-2.8.1.ebuild
parentapp-editors/emacs: Revert to xz distfile (now available upstream) (diff)
downloadgentoo-f90bf1fc42802615a363ca6f58d15be3791dc020.tar.gz
gentoo-f90bf1fc42802615a363ca6f58d15be3791dc020.tar.bz2
gentoo-f90bf1fc42802615a363ca6f58d15be3791dc020.zip
sci-visualization/dash: add 2.8.1, drop 2.3.1
Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'sci-visualization/dash/dash-2.8.1.ebuild')
-rw-r--r--sci-visualization/dash/dash-2.8.1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/sci-visualization/dash/dash-2.8.1.ebuild b/sci-visualization/dash/dash-2.8.1.ebuild
new file mode 100644
index 000000000000..3c12c50685cc
--- /dev/null
+++ b/sci-visualization/dash/dash-2.8.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..11} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1
+
+DESCRIPTION="Python framework for building ML & data science web apps"
+HOMEPAGE="https://github.com/plotly/dash"
+SRC_URI="https://github.com/plotly/${PN}/archive/refs/tags/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+# Test need some packages not yet in the tree
+# flask_talisman
+# percy
+# ...
+RESTRICT="test"
+
+RDEPEND="
+ dev-python/plotly[${PYTHON_USEDEP}]
+ dev-python/flask-compress[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? ( dev-python/beautifulsoup4 )"
+BDEPEND=""
+
+distutils_enable_tests pytest