summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2024-10-07 10:01:54 +0200
committerAlfredo Tupone <tupone@gentoo.org>2024-10-07 10:02:59 +0200
commit4709dac3e97f8b74626b67f737aabbfe84fbf077 (patch)
tree0903eb9fe509fa2acea75d9a0c6220e247c6ff96 /sci-libs
parentapp-emacs/ert-runner: fix ert-runner test launcher (diff)
downloadgentoo-4709dac3e97f8b74626b67f737aabbfe84fbf077.tar.gz
gentoo-4709dac3e97f8b74626b67f737aabbfe84fbf077.tar.bz2
gentoo-4709dac3e97f8b74626b67f737aabbfe84fbf077.zip
sci-libs/transformers: add 4.38.2
Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/transformers/Manifest1
-rw-r--r--sci-libs/transformers/transformers-4.38.2.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/sci-libs/transformers/Manifest b/sci-libs/transformers/Manifest
index ace196dbfd29..e668bdaae146 100644
--- a/sci-libs/transformers/Manifest
+++ b/sci-libs/transformers/Manifest
@@ -1 +1,2 @@
DIST transformers-4.37.2.gh.tar.gz 16632049 BLAKE2B 22501598da911cb685598cb3b33e157ef091425c0c7478d05a0af396c182e8f776435d6b2fe708eaf2550ce6136f195ffac3b464f357ae8e023a030c218fcd3d SHA512 37bdf35e0774f7f26a19465b5e5c64709a85a1d001e01382996891173c59d6e31c1b536ef186b9d6a3dbe85e658ac3bf11f78e2e7f73c6d1d18992035afe3852
+DIST transformers-4.38.2.gh.tar.gz 16891664 BLAKE2B 5877ccecdb417d6cb552d1ae3bcc55fb698614f0c60f38b751cecf6465e3155e44639b34773044dd9befc1902ec19fae634f0f737f4be05e9ef85e4a0701f4d5 SHA512 1d826e0793df85395b00008a80dfe51f5c3e1fec7a607112b817a161dfc375fd20fce47a1c5aead0e9c735b6e23cfe4f8526a19060c19d6c4ee9c2a87b42e382
diff --git a/sci-libs/transformers/transformers-4.38.2.ebuild b/sci-libs/transformers/transformers-4.38.2.ebuild
new file mode 100644
index 000000000000..729e1ae55368
--- /dev/null
+++ b/sci-libs/transformers/transformers-4.38.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+DISTUTILS_SINGLE_IMPL=1
+inherit distutils-r1
+
+DESCRIPTION="State-of-the-art Machine Learning for JAX, PyTorch and TensorFlow"
+HOMEPAGE="
+ https://pypi.org/project/transformers/
+ https://huggingface.co/
+"
+SRC_URI="https://github.com/huggingface/${PN}/archive/refs/tags/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+RESTRICT="test" # Need some modules, not yet packaged
+
+RDEPEND="
+ sci-libs/tokenizers[${PYTHON_SINGLE_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/filelock[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/regex[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/tqdm[${PYTHON_USEDEP}]
+ sci-libs/huggingface_hub[${PYTHON_USEDEP}]
+ >=sci-libs/safetensors-0.4.1[${PYTHON_USEDEP}]
+ ')
+"
+
+distutils_enable_tests pytest