summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2021-08-14 12:13:15 +0200
committerDavid Seifert <soap@gentoo.org>2021-08-14 12:13:15 +0200
commitf7d59a51d40442b70744abca9bbb5639806f60ca (patch)
treec517c05e5a0818babc7d9c60d4fcba79d6b60668 /sci-libs/qrupdate
parentnet-vpn/i2pd: remove USE=static (diff)
downloadgentoo-f7d59a51d40442b70744abca9bbb5639806f60ca.tar.gz
gentoo-f7d59a51d40442b70744abca9bbb5639806f60ca.tar.bz2
gentoo-f7d59a51d40442b70744abca9bbb5639806f60ca.zip
sci-libs/qrupdate: Port to EAPI 8
- Remove static-libs and cleanup patches - Replace ":" with "|" as sed delimiter Closes: https://bugs.gentoo.org/710820 Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sci-libs/qrupdate')
-rw-r--r--sci-libs/qrupdate/files/qrupdate-1.1.1-Makefiles.patch29
-rw-r--r--sci-libs/qrupdate/files/qrupdate-1.1.2-install.patch4
-rw-r--r--sci-libs/qrupdate/qrupdate-1.1.2-r2.ebuild50
3 files changed, 68 insertions, 15 deletions
diff --git a/sci-libs/qrupdate/files/qrupdate-1.1.1-Makefiles.patch b/sci-libs/qrupdate/files/qrupdate-1.1.1-Makefiles.patch
index 9c9ef9317342..1fdbd946e99e 100644
--- a/sci-libs/qrupdate/files/qrupdate-1.1.1-Makefiles.patch
+++ b/sci-libs/qrupdate/files/qrupdate-1.1.1-Makefiles.patch
@@ -1,7 +1,8 @@
-diff -Nur qrupdate-1.1.1.orig/Makefile qrupdate-1.1.1/Makefile
---- qrupdate-1.1.1.orig/Makefile 2009-02-06 09:12:00.000000000 +0000
-+++ qrupdate-1.1.1/Makefile 2010-05-13 17:27:15.000000000 +0100
-@@ -32,22 +32,22 @@
+diff --git a/Makefile b/Makefile
+index f9dbe86..2b11b59 100644
+--- a/Makefile
++++ b/Makefile
+@@ -32,22 +32,22 @@ help:
@echo " make install - installs everything"
lib:
@@ -32,10 +33,11 @@ diff -Nur qrupdate-1.1.1.orig/Makefile qrupdate-1.1.1/Makefile
install-staticlib:
- make -C src/ install-staticlib
+ $(MAKE) -C src install-staticlib
-diff -Nur qrupdate-1.1.1.orig/src/Makefile qrupdate-1.1.1/src/Makefile
---- qrupdate-1.1.1.orig/src/Makefile 2010-01-19 11:32:35.000000000 +0000
-+++ qrupdate-1.1.1/src/Makefile 2010-05-13 17:28:30.000000000 +0100
-@@ -34,6 +34,8 @@
+diff --git a/src/Makefile b/src/Makefile
+index 65ef49a..c338882 100644
+--- a/src/Makefile
++++ b/src/Makefile
+@@ -34,6 +34,8 @@ clup1up.f dlup1up.f slup1up.f zlup1up.f
OBJS = $(SRC:%.f=%.o)
@@ -44,7 +46,7 @@ diff -Nur qrupdate-1.1.1.orig/src/Makefile qrupdate-1.1.1/src/Makefile
lib: ../libqrupdate.a
ifeq ($(shell uname),Darwin)
-@@ -46,19 +48,22 @@
+@@ -46,19 +48,22 @@ solib: ../libqrupdate$(SOEXT)
../libqrupdate.a: $(OBJS)
ar -cr $@ $(OBJS)
@@ -73,10 +75,11 @@ diff -Nur qrupdate-1.1.1.orig/src/Makefile qrupdate-1.1.1/src/Makefile
install: install-shlib install-staticlib
-diff -Nur qrupdate-1.1.1.orig/test/Makefile qrupdate-1.1.1/test/Makefile
---- qrupdate-1.1.1.orig/test/Makefile 2010-02-11 08:25:37.000000000 +0000
-+++ qrupdate-1.1.1/test/Makefile 2010-05-13 17:15:51.000000000 +0100
-@@ -41,7 +41,7 @@
+diff --git a/test/Makefile b/test/Makefile
+index 45a843d..3be917f 100644
+--- a/test/Makefile
++++ b/test/Makefile
+@@ -41,7 +41,7 @@ utils.o: utils.f
$(FC) $(FFLAGS) -c $<
../libqrupdate.a:
diff --git a/sci-libs/qrupdate/files/qrupdate-1.1.2-install.patch b/sci-libs/qrupdate/files/qrupdate-1.1.2-install.patch
index 0eee49ae68f4..67c5b8f007e1 100644
--- a/sci-libs/qrupdate/files/qrupdate-1.1.2-install.patch
+++ b/sci-libs/qrupdate/files/qrupdate-1.1.2-install.patch
@@ -1,5 +1,5 @@
---- src/Makefile.orig 2010-02-07 15:58:01 +0100
-+++ src/Makefile 2010-02-07 16:02:18 +0100
+--- a/src/Makefile
++++ b/src/Makefile
@@ -65,14 +65,17 @@
install-shlib: ../libqrupdate$(SOEXT) install-lib$(SOEXT)
diff --git a/sci-libs/qrupdate/qrupdate-1.1.2-r2.ebuild b/sci-libs/qrupdate/qrupdate-1.1.2-r2.ebuild
new file mode 100644
index 000000000000..3206fe22ce8e
--- /dev/null
+++ b/sci-libs/qrupdate/qrupdate-1.1.2-r2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit fortran-2 flag-o-matic multilib toolchain-funcs
+
+DESCRIPTION="Library for updating of QR and Cholesky decompositions"
+HOMEPAGE="https://sourceforge.net/projects/qrupdate"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~ppc-macos"
+
+RDEPEND="virtual/lapack"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.1.1-Makefiles.patch
+ "${FILESDIR}"/${PN}-1.1.2-install.patch
+)
+
+src_prepare() {
+ default
+
+ # GCC 10 workaround
+ # bug #741524
+ append-fflags $(test-flags-FC -fallow-argument-mismatch)
+
+ sed -i Makeconf \
+ -e "s|gfortran|$(tc-getFC)|g" \
+ -e "s|FFLAGS=.*|FFLAGS=${FFLAGS}|" \
+ -e "s|BLAS=.*|BLAS=$($(tc-getPKG_CONFIG) --libs blas)|" \
+ -e "s|LAPACK=.*|LAPACK=$($(tc-getPKG_CONFIG) --libs lapack)|" \
+ -e "/^LIBDIR=/a\PREFIX=${EPREFIX}/usr" \
+ -e "s|LIBDIR=lib|LIBDIR=$(get_libdir)|" \
+ || die "Failed to set up Makeconf"
+}
+
+src_compile() {
+ emake solib
+}
+
+src_install() {
+ emake DESTDIR="${D}" install-shlib
+ dosym libqrupdate.so.$(ver_cut 1) /usr/$(get_libdir)/libqrupdate.so
+ dodoc README ChangeLog
+}