summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2019-08-05 00:40:59 -0500
committerMatthias Maier <tamiko@gentoo.org>2019-08-05 01:51:18 -0500
commite61609590882ab99a4d82be73fbcce50b296aa91 (patch)
tree4364cb25d690c2ff74fb965fa63f1fd6babd9cd3 /sci-libs/med
parentsci-mathematics/slepc: package migration from ::science overlay (diff)
downloadgentoo-e61609590882ab99a4d82be73fbcce50b296aa91.tar.gz
gentoo-e61609590882ab99a4d82be73fbcce50b296aa91.tar.bz2
gentoo-e61609590882ab99a4d82be73fbcce50b296aa91.zip
sci-libs/med: package migration from ::science overlay
* version bump * new upsteam website and repo * EAPI=7 * fixup installation Package-Manager: Portage-2.3.70, Repoman-2.3.16 Signed-off-by: Matthias Maier <tamiko@gentoo.org>
Diffstat (limited to 'sci-libs/med')
-rw-r--r--sci-libs/med/Manifest1
-rw-r--r--sci-libs/med/med-4.0.0.ebuild48
-rw-r--r--sci-libs/med/metadata.xml12
3 files changed, 61 insertions, 0 deletions
diff --git a/sci-libs/med/Manifest b/sci-libs/med/Manifest
new file mode 100644
index 000000000000..cec3ed3d3f8a
--- /dev/null
+++ b/sci-libs/med/Manifest
@@ -0,0 +1 @@
+DIST med-4.0.0.tar.gz 47849098 BLAKE2B 0bc6710f7b5156e09962e3125349573989429e614a203f649843f00dea06217040ebee70e481eed9c0dd304cb7d167efcd216c3600f6954a74f262cc845fff63 SHA512 2840437010481fc5f12a56e3282f8ca5e94df541899e2b511756702f86d0f87dbf2f6e086d8e591e2bd370d8f4bab8089e7f7f939fea16354a23e2b5a4d96cd7
diff --git a/sci-libs/med/med-4.0.0.ebuild b/sci-libs/med/med-4.0.0.ebuild
new file mode 100644
index 000000000000..721d2173d35b
--- /dev/null
+++ b/sci-libs/med/med-4.0.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit eutils flag-o-matic
+
+DESCRIPTION="Modeling and Exchange of Data library"
+HOMEPAGE="https://www.salome-platform.org/user-section/about/med"
+SRC_URI="https://files.salome-platform.org/Salome/other/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="mpi"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ >=sci-libs/hdf5-1.10.5[mpi=]
+ mpi? ( virtual/mpi )
+"
+
+DEPEND="
+ ${DEPEND}
+"
+
+src_prepare() {
+ default
+ append-cppflags -DH5_USE_16_API
+}
+
+src_configure() {
+ local myconf=(
+ --docdir="/usr/share/doc/${PF}"
+ --disable-python
+ )
+
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+
+ mv "${ED}"/usr/$(get_libdir)/libmed3.settings \
+ "${ED}"/usr/share/doc/${PF}/ || die "mv failed"
+
+ rm -rf "${ED}"/usr/include/2.3.6 || die "rm failed"
+}
diff --git a/sci-libs/med/metadata.xml b/sci-libs/med/metadata.xml
new file mode 100644
index 000000000000..dd66d18ef4fd
--- /dev/null
+++ b/sci-libs/med/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>tamiko@gentoo.org</email>
+ <name>Matthias Maier</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+</pkgmetadata>