summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-chemistry/probe
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-chemistry/probe')
-rw-r--r--sci-chemistry/probe/Manifest2
-rw-r--r--sci-chemistry/probe/files/2.12.110413-as-needed.patch38
-rw-r--r--sci-chemistry/probe/files/as-needed.patch21
-rw-r--r--sci-chemistry/probe/files/probe-2.13.110909-as-needed.patch25
-rw-r--r--sci-chemistry/probe/metadata.xml5
-rw-r--r--sci-chemistry/probe/probe-2.12.110413.ebuild38
-rw-r--r--sci-chemistry/probe/probe-2.13.110909.ebuild34
7 files changed, 163 insertions, 0 deletions
diff --git a/sci-chemistry/probe/Manifest b/sci-chemistry/probe/Manifest
new file mode 100644
index 000000000000..f5dd9226d404
--- /dev/null
+++ b/sci-chemistry/probe/Manifest
@@ -0,0 +1,2 @@
+DIST probe.2.12.110413.src.zip 262460 SHA256 90cd0a693683958a8ac05d13a47c2b464f2939df24369bf5c568f59913756de4 SHA512 ac6a92f1666d1819c0dede5ea97113c9e03271c42b829d88a2b65041dec7f853441fc61e94e48782078884a9a69c1043432ca3576768d31bfe9190d3ea1da4c8 WHIRLPOOL f6e6ec43016d14114ae5cbfdbfd1cdb5bdf0c6a1c34742b0fef0cfe5ee39409a41b4b2127fbefe526d66d99c33b91ef5e3ea4c9de33784f9ea493700e8bc8784
+DIST probe.2.13.110909.src.zip 131063 SHA256 df14b76d27a7c43b2b57c315d0ad71cdf6acc7943c43195a797162be7816fa71 SHA512 5efa066873d0e139da66bf8edb541fe42df94e99cab171ad8d06a8a6f5caada982ef5b18481e748b224dbed86f63c99237d04ecd107c82855b44de91fb6d2b16 WHIRLPOOL 12f6fefe1b03b71268f39fa3aa7ad796230c76c2e029b8dc86955abd43c8e3f09f7591f84cd79c7ba11037d5b323c922ddf36abf6911d556981f5cc21378912f
diff --git a/sci-chemistry/probe/files/2.12.110413-as-needed.patch b/sci-chemistry/probe/files/2.12.110413-as-needed.patch
new file mode 100644
index 000000000000..95368625505d
--- /dev/null
+++ b/sci-chemistry/probe/files/2.12.110413-as-needed.patch
@@ -0,0 +1,38 @@
+ Makefile | 13 ++++++-------
+ 1 files changed, 6 insertions(+), 7 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index e6a740e..8f74d6a 100644
+--- a/Makefile
++++ b/Makefile
+@@ -1,14 +1,12 @@
+-MACHINEFLAGS =
+-CFLAGS = $(MACHINEFLAGS)
+-LFLAGS = -lm $(MACHINEFLAGS)
++LIBS = -lm
+ OBJLIST = dots.o abin.o readPDBrecs.o geom3d.o utility.o select.o \
+- parse.o atomprops.o stdconntable.o autobondrot.o
++ parse.o atomprops.o stdconntable.o autobondrot.o hybrid_36_c.o
+
+ .c.o:
+- cc -c $*.c $(CFLAGS)
++ $(CC) $(CFLAGS) -c $*.c
+
+ probe: probe.o $(OBJLIST)
+- cc -o $@ probe.o $(OBJLIST) $(LFLAGS)
++ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ probe.o $(OBJLIST) $(LIBS)
+
+ clean:
+ @rm -f *.o *.ckp
+@@ -30,9 +28,10 @@ parse.o: ./parse.h ./utility.h parse.c
+ probe.o: ./abin.h ./atomprops.h ./autobondrot.h ./dots.h ./geom3d.h \
+ ./parse.h ./probe.h ./readPDBrecs.h ./select.h \
+ ./stdconntable.h ./utility.h probe.c
+-readPDBrecs.o: ./geom3d.h ./readPDBrecs.h ./utility.h readPDBrecs.c
++readPDBrecs.o: ./geom3d.h ./readPDBrecs.h ./utility.h ./hybrid_36_c.h readPDBrecs.c
+ select.o: ./abin.h ./atomprops.h ./geom3d.h ./parse.h ./select.h \
+ ./stdconntable.h ./utility.h select.c
+ stdconntable.o: ./stdconntable.h stdconntable.c
+ utility.o: utility.c
++hybrid_36_c.o: ./hybrid_36_c.h hybrid_36_c.c
+ # DO NOT DELETE THIS 2nd LINE -- make depend uses it
diff --git a/sci-chemistry/probe/files/as-needed.patch b/sci-chemistry/probe/files/as-needed.patch
new file mode 100644
index 000000000000..9ddecf5f569e
--- /dev/null
+++ b/sci-chemistry/probe/files/as-needed.patch
@@ -0,0 +1,21 @@
+diff --git a/Makefile b/Makefile
+index 68d7469..bcb821c 100644
+--- a/Makefile
++++ b/Makefile
+@@ -1,6 +1,6 @@
+ MACHINEFLAGS =
+ CFLAGS = $(MACHINEFLAGS)
+-LFLAGS = -lm $(MACHINEFLAGS)
++LFLAGS = -lm
+ OBJLIST = dots.o abin.o readPDBrecs.o geom3d.o utility.o select.o \
+ parse.o atomprops.o stdconntable.o autobondrot.o hybrid_36_c.o
+
+@@ -8,7 +8,7 @@ OBJLIST = dots.o abin.o readPDBrecs.o geom3d.o utility.o select.o \
+ cc -c $*.c $(CFLAGS)
+
+ probe: probe.o $(OBJLIST)
+- cc -o $@ probe.o $(OBJLIST) $(LFLAGS)
++ cc $(MACHINEFLAGS) -o $@ probe.o $(OBJLIST) $(LFLAGS)
+
+ clean:
+ @rm -f *.o *.ckp
diff --git a/sci-chemistry/probe/files/probe-2.13.110909-as-needed.patch b/sci-chemistry/probe/files/probe-2.13.110909-as-needed.patch
new file mode 100644
index 000000000000..df7040c3ba1d
--- /dev/null
+++ b/sci-chemistry/probe/files/probe-2.13.110909-as-needed.patch
@@ -0,0 +1,25 @@
+ Makefile | 8 +++-----
+ 1 files changed, 3 insertions(+), 5 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index 9031bd0..8f74d6a 100644
+--- a/Makefile
++++ b/Makefile
+@@ -1,14 +1,12 @@
+-MACHINEFLAGS =
+-CFLAGS = $(MACHINEFLAGS)
+-LFLAGS = -static -lm $(MACHINEFLAGS)
++LIBS = -lm
+ OBJLIST = dots.o abin.o readPDBrecs.o geom3d.o utility.o select.o \
+ parse.o atomprops.o stdconntable.o autobondrot.o hybrid_36_c.o
+
+ .c.o:
+- cc -c $*.c $(CFLAGS)
++ $(CC) $(CFLAGS) -c $*.c
+
+ probe: probe.o $(OBJLIST)
+- cc -o $@ probe.o $(OBJLIST) $(LFLAGS)
++ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ probe.o $(OBJLIST) $(LIBS)
+
+ clean:
+ @rm -f *.o *.ckp
diff --git a/sci-chemistry/probe/metadata.xml b/sci-chemistry/probe/metadata.xml
new file mode 100644
index 000000000000..e42d0af60f42
--- /dev/null
+++ b/sci-chemistry/probe/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-chemistry</herd>
+</pkgmetadata>
diff --git a/sci-chemistry/probe/probe-2.12.110413.ebuild b/sci-chemistry/probe/probe-2.12.110413.ebuild
new file mode 100644
index 000000000000..bb0a36a232de
--- /dev/null
+++ b/sci-chemistry/probe/probe-2.12.110413.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils toolchain-funcs
+
+MY_P="${PN}.${PV}"
+
+DESCRIPTION="Evaluates atomic packing within or between molecules"
+HOMEPAGE="http://kinemage.biochem.duke.edu/software/probe.php"
+SRC_URI="http://kinemage.biochem.duke.edu/downloads/software/probe/${MY_P}.src.zip"
+
+SLOT="0"
+LICENSE="richardson"
+KEYWORDS="amd64 ppc x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+S="${WORKDIR}"/trunk
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PV}-as-needed.patch
+ # Respect CC
+ sed -i \
+ -e 's:cc:$(CC):g' \
+ "${S}"/Makefile || die
+ tc-export CC
+}
+
+src_install() {
+ dobin "${S}"/probe
+ dodoc "${S}"/README*
+}
diff --git a/sci-chemistry/probe/probe-2.13.110909.ebuild b/sci-chemistry/probe/probe-2.13.110909.ebuild
new file mode 100644
index 000000000000..a841b16de30f
--- /dev/null
+++ b/sci-chemistry/probe/probe-2.13.110909.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils toolchain-funcs
+
+MY_P="${PN}.${PV}"
+
+DESCRIPTION="Evaluates atomic packing within or between molecules"
+HOMEPAGE="http://kinemage.biochem.duke.edu/software/probe.php"
+SRC_URI="http://kinemage.biochem.duke.edu/downloads/software/probe/${MY_P}.src.zip"
+
+SLOT="0"
+LICENSE="richardson"
+KEYWORDS="amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+S="${WORKDIR}"/${MY_P}.src
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-as-needed.patch
+ tc-export CC
+}
+
+src_install() {
+ dobin "${S}"/probe
+ dodoc "${S}"/README*
+}