summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRick Farina <zerochaos@gentoo.org>2022-03-16 20:49:16 -0400
committerRick Farina <zerochaos@gentoo.org>2022-03-16 20:50:55 -0400
commit6b3fba66b43f3a0f2fe88d05bd45ad1c5d7ac27b (patch)
tree1c819e72cede615b23a0308b5c2d79dcb44d525d /net-wireless
parentwww-servers/apache: Stabilize 2.4.52-r1 arm, #829787 (diff)
downloadgentoo-6b3fba66b43f3a0f2fe88d05bd45ad1c5d7ac27b.tar.gz
gentoo-6b3fba66b43f3a0f2fe88d05bd45ad1c5d7ac27b.tar.bz2
gentoo-6b3fba66b43f3a0f2fe88d05bd45ad1c5d7ac27b.zip
net-wireless/osmo-fl2k: ebuild cleanup/updates
Fixes: https://bugs.gentoo.org/727984 Fixes: https://bugs.gentoo.org/835085 Signed-off-by: Rick Farina <zerochaos@gentoo.org>
Diffstat (limited to 'net-wireless')
-rw-r--r--net-wireless/osmo-fl2k/osmo-fl2k-0.1.1-r1.ebuild (renamed from net-wireless/osmo-fl2k/osmo-fl2k-0.1.1.ebuild)20
-rw-r--r--net-wireless/osmo-fl2k/osmo-fl2k-9999.ebuild20
2 files changed, 22 insertions, 18 deletions
diff --git a/net-wireless/osmo-fl2k/osmo-fl2k-0.1.1.ebuild b/net-wireless/osmo-fl2k/osmo-fl2k-0.1.1-r1.ebuild
index 0df5cfc8b4b9..f8ab9250ade2 100644
--- a/net-wireless/osmo-fl2k/osmo-fl2k-0.1.1.ebuild
+++ b/net-wireless/osmo-fl2k/osmo-fl2k-0.1.1-r1.ebuild
@@ -1,12 +1,11 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
-inherit cmake-utils flag-o-matic linux-info udev
+inherit cmake flag-o-matic linux-info udev
DESCRIPTION="turns FL2000-based USB 3.0 to VGA adapters into low cost DACs"
-
HOMEPAGE="https://osmocom.org/projects/osmo-fl2k/wiki"
if [[ ${PV} == "9999" ]]; then
@@ -24,9 +23,9 @@ SLOT="0"
IUSE="udev"
DEPEND="virtual/libusb:1"
-RDEPEND="${DEPEND}"
-PDEPEND="media-sound/sox
- sys-apps/pv"
+RDEPEND="${DEPEND}
+ media-sound/sox
+ sys-apps/pv"
# continguous memory allocator can optionally be used for zero-copy transfer
# TODO: tell users to set CONFIG_CMA_SIZE_MBYTES or boot with cma=... parameter
@@ -41,12 +40,15 @@ src_configure() {
#https://gcc.gnu.org/bugzilla/show_bug.cgi?id=49653
replace-flags -O0 -O2
replace-flags -Os -O2
- cmake-utils_src_configure
+ cmake_src_configure
}
src_install() {
if use udev; then
udev_newrules ${PN}.rules 99-${PN}.rules
fi
- cmake-utils_src_install
+ cmake_src_install
+ # https://bugs.gentoo.org/727984
+ # No obvious way to prevent build
+ find "${ED}" -name libosmo-fl2k.a -delete
}
diff --git a/net-wireless/osmo-fl2k/osmo-fl2k-9999.ebuild b/net-wireless/osmo-fl2k/osmo-fl2k-9999.ebuild
index 148e9614dedc..f8ab9250ade2 100644
--- a/net-wireless/osmo-fl2k/osmo-fl2k-9999.ebuild
+++ b/net-wireless/osmo-fl2k/osmo-fl2k-9999.ebuild
@@ -1,12 +1,11 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
-inherit cmake-utils flag-o-matic linux-info udev
+inherit cmake flag-o-matic linux-info udev
DESCRIPTION="turns FL2000-based USB 3.0 to VGA adapters into low cost DACs"
-
HOMEPAGE="https://osmocom.org/projects/osmo-fl2k/wiki"
if [[ ${PV} == "9999" ]]; then
@@ -24,9 +23,9 @@ SLOT="0"
IUSE="udev"
DEPEND="virtual/libusb:1"
-RDEPEND="${DEPEND}"
-PDEPEND="media-sound/sox
- sys-apps/pv"
+RDEPEND="${DEPEND}
+ media-sound/sox
+ sys-apps/pv"
# continguous memory allocator can optionally be used for zero-copy transfer
# TODO: tell users to set CONFIG_CMA_SIZE_MBYTES or boot with cma=... parameter
@@ -41,12 +40,15 @@ src_configure() {
#https://gcc.gnu.org/bugzilla/show_bug.cgi?id=49653
replace-flags -O0 -O2
replace-flags -Os -O2
- cmake-utils_src_configure
+ cmake_src_configure
}
src_install() {
if use udev; then
udev_newrules ${PN}.rules 99-${PN}.rules
fi
- cmake-utils_src_install
+ cmake_src_install
+ # https://bugs.gentoo.org/727984
+ # No obvious way to prevent build
+ find "${ED}" -name libosmo-fl2k.a -delete
}