summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-06-20 21:17:12 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2021-06-20 22:02:05 +0200
commite867fdd79c00a41a10d4bf28ad605d79390c6c26 (patch)
tree4317f3086932e522967a01d5e080b4d72365ff26 /net-libs
parentmedia-sound/kid3: 3.8.7 version bump (diff)
downloadgentoo-e867fdd79c00a41a10d4bf28ad605d79390c6c26.tar.gz
gentoo-e867fdd79c00a41a10d4bf28ad605d79390c6c26.tar.bz2
gentoo-e867fdd79c00a41a10d4bf28ad605d79390c6c26.zip
net-libs/libquotient: 0.6.7 version bump
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/libquotient/Manifest1
-rw-r--r--net-libs/libquotient/libquotient-0.6.7.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/net-libs/libquotient/Manifest b/net-libs/libquotient/Manifest
index 3b30202be129..0f672f5a3cb3 100644
--- a/net-libs/libquotient/Manifest
+++ b/net-libs/libquotient/Manifest
@@ -1 +1,2 @@
DIST libquotient-0.6.6.tar.gz 560130 BLAKE2B a8f12af320e0f67b0fe40ec3892cfb2bb7686f066633c061936007e0eceefe5133d3c021a0d1856504f606b5c1bdb66ffa9d8d304b0b631be34f938ffaa061d6 SHA512 7560194bee5b6478ac8efd15d6cfef9cc003073744b4860e3177e51e49135cf2ad96c69e8cd21e64c1f9902ea4d27c26d84d200fc862c5c0daeb0cc4bb4ea65d
+DIST libquotient-0.6.7.tar.gz 560174 BLAKE2B 1f0fe371bf84925c7a8b7728a1e484e9cb7c7d5887539c86a863d05d34727b2385425743260c7c0b33205473215475c7bd5ec8b709032a00591dbfd7cafa721c SHA512 7f7c56ef5f775d38a0bd9f112f2fb7473d42d1e886d17e84d4be1afda146999658eea8691c38071fd87aec7ece52b97bc837cc98452cc698cf152003474193f2
diff --git a/net-libs/libquotient/libquotient-0.6.7.ebuild b/net-libs/libquotient/libquotient-0.6.7.ebuild
new file mode 100644
index 000000000000..ebeb0a0321d5
--- /dev/null
+++ b/net-libs/libquotient/libquotient-0.6.7.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="Qt5-based SDK to develop applications for Matrix"
+HOMEPAGE="https://github.com/quotient-im/libQuotient"
+SRC_URI="https://github.com/quotient-im/libQuotient/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/libQuotient-${PV}"
+
+LICENSE="LGPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64"
+IUSE=""
+
+DEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtmultimedia:5
+ dev-qt/qtnetwork:5
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ # downstream patches
+ "${FILESDIR}"/${PN}-0.6.3-no-android.patch
+ "${FILESDIR}"/${PN}-0.6.3-no-tests.patch
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DQuotient_INSTALL_TESTS=OFF
+ -DQuotient_ENABLE_E2EE=OFF # TODO: libolm, libqtolm not packaged
+ -DCMAKE_DISABLE_FIND_PACKAGE_Git=ON # no thanks.
+ )
+ cmake_src_configure
+}