summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-libs/iax
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-libs/iax')
-rw-r--r--net-libs/iax/Manifest1
-rw-r--r--net-libs/iax/files/0.2.2-debug.patch21
-rw-r--r--net-libs/iax/files/0.2.2-memset.patch12
-rw-r--r--net-libs/iax/files/0.2.2-sandbox.patch19
-rw-r--r--net-libs/iax/iax-0.2.2-r1.ebuild42
-rw-r--r--net-libs/iax/iax-0.2.2-r3.ebuild34
-rw-r--r--net-libs/iax/iax-0.2.2.ebuild30
-rw-r--r--net-libs/iax/metadata.xml8
8 files changed, 167 insertions, 0 deletions
diff --git a/net-libs/iax/Manifest b/net-libs/iax/Manifest
new file mode 100644
index 000000000000..250a8db5884f
--- /dev/null
+++ b/net-libs/iax/Manifest
@@ -0,0 +1 @@
+DIST iax-0.2.2.tar.gz 139379 SHA256 7c3caf939a821440407931a13838dd0dfea21fbec373d1985e2604df5d149cb8 SHA512 f86fc56c9f31665e849e8528d2852e06abd803e8d02fa6098d68eefecccc263ded97d1870e9ee157ec1610fefc92b8f14f2d858fbce115c5da83a6dec1eea210 WHIRLPOOL c5b3c1148b93fc2411f316e80aad73c1c5eb83ad8c01dd6ecabf6d62b64f4cafd20bb83bfb1ba7a197e27afc71ba48c4ac8571489f48c298783f8f94865518ed
diff --git a/net-libs/iax/files/0.2.2-debug.patch b/net-libs/iax/files/0.2.2-debug.patch
new file mode 100644
index 000000000000..68efdfdd237a
--- /dev/null
+++ b/net-libs/iax/files/0.2.2-debug.patch
@@ -0,0 +1,21 @@
+diff -uNr iax-0.2.2.ORIG/configure.in iax-0.2.2/configure.in
+--- iax-0.2.2.ORIG/configure.in 2014-05-13 13:23:35.083867921 +0100
++++ iax-0.2.2/configure.in 2014-05-13 13:24:25.879870451 +0100
+@@ -25,6 +25,8 @@
+ fi
+
+ if test "$enable_extreme_debug" = yes ; then
++ AC_DEFINE(DEBUG_SUPPORT)
++ AC_DEFINE(DEBUG_DEFAULT)
+ AC_DEFINE(EXTREME_DEBUG)
+ fi
+
+diff -uNr iax-0.2.2.ORIG/src/Makefile.am iax-0.2.2/src/Makefile.am
+--- iax-0.2.2.ORIG/src/Makefile.am 2014-05-13 13:23:35.082867921 +0100
++++ iax-0.2.2/src/Makefile.am 2014-05-13 13:24:32.439870777 +0100
+@@ -1,5 +1,4 @@
+ CFLAGS += -g -Wall -Wstrict-prototypes -I .
+-CFLAGS += -DDEBUG_SUPPORT -DDEBUG_DEFAULT
+ CFLAGS += $(UCFLAGS)
+
+
diff --git a/net-libs/iax/files/0.2.2-memset.patch b/net-libs/iax/files/0.2.2-memset.patch
new file mode 100644
index 000000000000..08408eef98f7
--- /dev/null
+++ b/net-libs/iax/files/0.2.2-memset.patch
@@ -0,0 +1,12 @@
+diff -uNr iax-0.2.2.ORIG/src/md5.c iax-0.2.2/src/md5.c
+--- iax-0.2.2.ORIG/src/md5.c 2014-05-13 13:26:51.570877706 +0100
++++ iax-0.2.2/src/md5.c 2014-05-13 13:27:08.567878553 +0100
+@@ -165,7 +165,7 @@
+ MD5Transform(ctx->buf, (uint32 *) ctx->in);
+ byteReverse((unsigned char *) ctx->buf, 4);
+ memcpy(digest, ctx->buf, 16);
+- memset(ctx, 0, sizeof(ctx)); /* In case it's sensitive */
++ memset(ctx, 0, sizeof(*ctx)); /* In case it's sensitive */
+ }
+
+ #ifndef ASM_MD5
diff --git a/net-libs/iax/files/0.2.2-sandbox.patch b/net-libs/iax/files/0.2.2-sandbox.patch
new file mode 100644
index 000000000000..2dc141a73b18
--- /dev/null
+++ b/net-libs/iax/files/0.2.2-sandbox.patch
@@ -0,0 +1,19 @@
+diff -uNr iax-0.2.2.ORIG/src/Makefile.am iax-0.2.2/src/Makefile.am
+--- iax-0.2.2.ORIG/src/Makefile.am 2014-05-13 12:45:58.343755528 +0100
++++ iax-0.2.2/src/Makefile.am 2014-05-13 12:46:30.044757107 +0100
+@@ -9,10 +9,9 @@
+ EXTRA_DIST = md5.h frame.h iax-client.h iax.h
+
+ install:
+- mkdir -p $(includedir)/iax
+- install -m 644 md5.h $(includedir)/iax
+- install -m 644 frame.h $(includedir)/iax
+- install -m 644 iax.h $(includedir)/iax
+- install -m 644 iax-client.h $(includedir)/iax
+- /sbin/ldconfig
++ mkdir -p $(DESTDIR)$(includedir)/iax
++ install -m 644 md5.h $(DESTDIR)$(includedir)/iax
++ install -m 644 frame.h $(DESTDIR)$(includedir)/iax
++ install -m 644 iax.h $(DESTDIR)$(includedir)/iax
++ install -m 644 iax-client.h $(DESTDIR)$(includedir)/iax
+
diff --git a/net-libs/iax/iax-0.2.2-r1.ebuild b/net-libs/iax/iax-0.2.2-r1.ebuild
new file mode 100644
index 000000000000..34a200fa188f
--- /dev/null
+++ b/net-libs/iax/iax-0.2.2-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+
+DESCRIPTION="IAX (Inter Asterisk eXchange) Library"
+HOMEPAGE="http://www.asterisk.org/"
+SRC_URI="http://downloads.asterisk.org/pub/telephony/libiax/${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc x86"
+IUSE="debug snomhack"
+
+src_prepare() {
+ if ! use debug; then
+ sed -i -e "s:-DDEBUG_SUPPORT -DDEBUG_DEFAULT ::" src/Makefile.in \
+ || die "sed failed"
+ fi
+
+ # use users CFLAGS and LDFLAGS
+ sed -i -e "s:CFLAGS =:CFLAGS+=:" src/Makefile.in || die "sed failed"
+ sed -i -e "s:\(libiax_la_LDFLAGS = \):\1@LDFLAGS@:" src/Makefile.in \
+ || die "sed failed"
+
+ # fix sandbox violations
+ sed -i -e "s:\(\$(includedir)/iax\):\$(DESTDIR)\1:" src/Makefile.in \
+ || die "sed failed"
+ sed -ie -e "/\/sbin\/ldconfig/d" src/Makefile.in || die "sed failed"
+}
+
+src_configure() {
+ econf \
+ $(use_enable debug extreme-debug) \
+ $(use_enable snomhack)
+}
+
+src_install () {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog NEWS README || die "dodoc failed"
+}
diff --git a/net-libs/iax/iax-0.2.2-r3.ebuild b/net-libs/iax/iax-0.2.2-r3.ebuild
new file mode 100644
index 000000000000..00bf6148f81a
--- /dev/null
+++ b/net-libs/iax/iax-0.2.2-r3.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit autotools eutils
+
+DESCRIPTION="IAX (Inter Asterisk eXchange) Library"
+HOMEPAGE="http://www.asterisk.org/"
+SRC_URI="http://downloads.asterisk.org/pub/telephony/libiax/${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="debug snomhack"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PV}-debug.patch"
+ epatch "${FILESDIR}/${PV}-memset.patch"
+ epatch "${FILESDIR}/${PV}-sandbox.patch"
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable debug extreme-debug) \
+ $(use_enable snomhack)
+}
+
+src_install () {
+ default
+ dodoc AUTHORS ChangeLog NEWS README || die "dodoc failed"
+}
diff --git a/net-libs/iax/iax-0.2.2.ebuild b/net-libs/iax/iax-0.2.2.ebuild
new file mode 100644
index 000000000000..c7ba31de0f91
--- /dev/null
+++ b/net-libs/iax/iax-0.2.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+IUSE=""
+
+DESCRIPTION="IAX (Inter Asterisk eXchange) Library"
+HOMEPAGE="http://www.digium.com/"
+LICENSE="LGPL-2"
+DEPEND=""
+RDEPEND=""
+SLOT="0"
+SRC_URI="http://www.digium.com/pub/libiax/${P}.tar.gz"
+
+D_PREFIX=/usr
+
+KEYWORDS="x86 ppc"
+
+src_compile() {
+ ./configure --prefix=${D_PREFIX} --enable-autoupdate
+
+ export UCFLAGS="${CFLAGS}"
+
+ emake || die
+}
+
+src_install () {
+ make prefix="${D}"/${D_PREFIX} install
+ dodoc NEWS AUTHORS README
+}
diff --git a/net-libs/iax/metadata.xml b/net-libs/iax/metadata.xml
new file mode 100644
index 000000000000..34479aea5739
--- /dev/null
+++ b/net-libs/iax/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer><email>chainsaw@gentoo.org</email></maintainer>
+ <use>
+ <flag name='snomhack'>Use slower memset for SNOM phoneem</flag>
+ </use>
+</pkgmetadata>