summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetr Vaněk <arkamar@atlas.cz>2022-05-23 17:29:15 +0200
committerJoonas Niilola <juippis@gentoo.org>2022-05-27 09:53:10 +0300
commitfc0df4819cf65619f4df3d4f8b76945c44c37abd (patch)
tree7c457230597ebaff41dd9ba559fe0ee509213b41 /net-analyzer
parentdev-go/act: use go-module.eclass (diff)
downloadgentoo-fc0df4819cf65619f4df3d4f8b76945c44c37abd.tar.gz
gentoo-fc0df4819cf65619f4df3d4f8b76945c44c37abd.tar.bz2
gentoo-fc0df4819cf65619f4df3d4f8b76945c44c37abd.zip
net-analyzer/sslsplit: fix openssl3 support
Upstream-issue: https://github.com/droe/sslsplit/issues/290 Closes: https://bugs.gentoo.org/805536 Signed-off-by: Petr Vaněk <arkamar@atlas.cz> Closes: https://github.com/gentoo/gentoo/pull/25611 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/sslsplit/files/sslsplit-0.5.5-openssl3.patch31
-rw-r--r--net-analyzer/sslsplit/sslsplit-0.5.5.ebuild2
2 files changed, 33 insertions, 0 deletions
diff --git a/net-analyzer/sslsplit/files/sslsplit-0.5.5-openssl3.patch b/net-analyzer/sslsplit/files/sslsplit-0.5.5-openssl3.patch
new file mode 100644
index 000000000000..10807bee3899
--- /dev/null
+++ b/net-analyzer/sslsplit/files/sslsplit-0.5.5-openssl3.patch
@@ -0,0 +1,31 @@
+From: Soner Tari <sonertari@gmail.com>
+Date: Fri, 4 Feb 2022 19:46:58 +0300
+Subject: [PATCH] Fix build errors with OpenSSL 3.0.x, but not deprecation
+ warnings, issue #290
+
+This patch fixes errors only, so that build succeeds, but deprecation
+warnings remain. It seems we need considerable changes to replace those
+deprecated functions in the warnings.
+---
+
+Upstream-commit: e17de8454a65 ("Fix build errors with OpenSSL 3.0.x, but not deprecation warnings, issue #290")
+Upstream-issue: https://github.com/droe/sslsplit/issues/290
+
+diff --git a/pxyconn.c b/pxyconn.c
+index e69de20..09a8b80 100644
+--- a/pxyconn.c
++++ b/pxyconn.c
+@@ -72,6 +72,10 @@ bufferevent_openssl_set_allow_dirty_shutdown(UNUSED struct bufferevent *bev,
+ }
+ #endif /* LIBEVENT_VERSION_NUMBER < 0x02010000 */
+
++#if OPENSSL_VERSION_NUMBER >= 0x30000000L
++#define ERR_GET_FUNC(x) 0
++#define ERR_func_error_string(x) ""
++#endif
+
+ /*
+ * Maximum size of data to buffer per connection direction before
+--
+2.35.1
+
diff --git a/net-analyzer/sslsplit/sslsplit-0.5.5.ebuild b/net-analyzer/sslsplit/sslsplit-0.5.5.ebuild
index c6f530a49947..7d9691cbbcef 100644
--- a/net-analyzer/sslsplit/sslsplit-0.5.5.ebuild
+++ b/net-analyzer/sslsplit/sslsplit-0.5.5.ebuild
@@ -32,6 +32,8 @@ DEPEND="${RDEPEND}
test? ( dev-libs/check )"
BDEPEND="virtual/pkgconfig"
+PATCHES=( "${FILESDIR}/${P}-openssl3.patch" )
+
src_prepare() {
default