summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2023-06-11 13:44:30 -0500
committerWilliam Hubbs <williamh@gentoo.org>2023-06-11 13:47:04 -0500
commit811cf293723f33afad9c6f4aa692e471dd5eff8d (patch)
tree4f6a416cb8084b90db134b76808afc7eb977a8b4 /net-analyzer/telegraf
parentdev-python/pyqtgraph: Stabilize 0.13.3 ALLARCHES, #908360 (diff)
downloadgentoo-811cf293723f33afad9c6f4aa692e471dd5eff8d.tar.gz
gentoo-811cf293723f33afad9c6f4aa692e471dd5eff8d.tar.bz2
gentoo-811cf293723f33afad9c6f4aa692e471dd5eff8d.zip
net-analyzer/telegraf: 1.26.3-r1 revbump to fix documentation
Closes: https://bugs.gentoo.org/908302 Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'net-analyzer/telegraf')
-rw-r--r--net-analyzer/telegraf/telegraf-1.26.3-r1.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/net-analyzer/telegraf/telegraf-1.26.3-r1.ebuild b/net-analyzer/telegraf/telegraf-1.26.3-r1.ebuild
new file mode 100644
index 000000000000..7cef4e8b9482
--- /dev/null
+++ b/net-analyzer/telegraf/telegraf-1.26.3-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit go-module systemd
+MY_PV="${PV/_rc/-rc.}"
+COMMIT=90f4eb29
+BRANCH=HEAD
+VERSION=v${MY_PV}
+
+DESCRIPTION="The plugin-driven server agent for collecting & reporting metrics"
+HOMEPAGE="https://github.com/influxdata/telegraf"
+
+SRC_URI="https://github.com/influxdata/telegraf/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~williamh/dist/${P}-deps.tar.xz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+
+RESTRICT+=" test"
+
+DEPEND="acct-group/telegraf
+ acct-user/telegraf"
+ RDEPEND="${DEPEND}"
+
+src_compile() {
+ unset LDFLAGS
+ emake -j1 \
+ COMMIT=${COMMIT} \
+ BRANCH=${BRANCH} \
+ VERSION=v${MY_PV}
+}
+
+src_install() {
+ dobin telegraf
+ insinto /etc/logrotate.d
+ doins etc/logrotate.d/telegraf
+ keepdir /etc/telegraf
+ keepdir /etc/telegraf/telegraf.d
+ systemd_dounit scripts/telegraf.service
+ newconfd "${FILESDIR}"/telegraf.confd telegraf
+ newinitd "${FILESDIR}"/telegraf.rc telegraf
+ dodoc -r *.md docs
+ keepdir /var/log/telegraf
+ fowners telegraf:telegraf /var/log/telegraf
+}