summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMario Haustein <mario.haustein@hrz.tu-chemnitz.de>2024-02-14 22:01:18 +0100
committerFlorian Schmaus <flow@gentoo.org>2024-02-28 10:11:21 +0100
commit7bde9a713a6eec589ddeceb5a3ada987fc94fd02 (patch)
tree4852f3a66fec45b67cf3f72f11d531ac25f7b72d /net-analyzer/shodan
parentapp-arch/patool: add 2.2.0 (diff)
downloadgentoo-7bde9a713a6eec589ddeceb5a3ada987fc94fd02.tar.gz
gentoo-7bde9a713a6eec589ddeceb5a3ada987fc94fd02.tar.bz2
gentoo-7bde9a713a6eec589ddeceb5a3ada987fc94fd02.zip
net-analyzer/shodan: add 1.31.0
Signed-off-by: Mario Haustein <mario.haustein@hrz.tu-chemnitz.de> Closes: https://github.com/gentoo/gentoo/pull/35330 Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'net-analyzer/shodan')
-rw-r--r--net-analyzer/shodan/Manifest1
-rw-r--r--net-analyzer/shodan/shodan-1.31.0.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/net-analyzer/shodan/Manifest b/net-analyzer/shodan/Manifest
index 2c81189db4da..bf9c67712bf3 100644
--- a/net-analyzer/shodan/Manifest
+++ b/net-analyzer/shodan/Manifest
@@ -1,2 +1,3 @@
DIST shodan-1.30.0.tar.gz 57790 BLAKE2B 1c3c030e84d31dc79ad737b71e63ce6c9218441be04ec94b4144013545e0d7dd79f1e25e51af1811cdd624f2f32b128e5aeb7dbc8d71b21741712733ca4b6d39 SHA512 996555945f4d874cb0fa3c596e6fad9298f7af396c0e94d75b8e9e103d4a2d7dd33ed8af24a218c753117231a0713caa971106f2152bc429d7c8b5c07b00dbc6
DIST shodan-1.30.1.tar.gz 57908 BLAKE2B 21ef6f4ae2fd6a487e478627f8623dde4e2092fe9dec893e443fc27e94dc3e65a3483317c6819c947f053542414babcfa57ddb82c40f8a83d43bd9e2d9e84d44 SHA512 498d9057271e112940f00dda76a0ecb80a30ea66df84cfecb6e4b77197225714dc1a22d848e6b14a71a48bb4ded5e77a0924bc3915b552acb4ee35f3444cf558
+DIST shodan-1.31.0.tar.gz 57939 BLAKE2B 7d22e8ec9e32669494838ddef76115ce80ba4600ca71e5c7e9e6c91d82bbf2a55e5e754d7fd4018545c9dbba01fd21bd9fd444d4f2090938f09c7b1610b98100 SHA512 fe66fdd4ae1088d165a2acd67f85a54a9fcbed8130ee5e2a5764d318fa0c50fb472fd5a76ce72f84fcfdb4c74c29ae2e14881f86468fb177ddc3191cb95d3b67
diff --git a/net-analyzer/shodan/shodan-1.31.0.ebuild b/net-analyzer/shodan/shodan-1.31.0.ebuild
new file mode 100644
index 000000000000..3afaf54e6485
--- /dev/null
+++ b/net-analyzer/shodan/shodan-1.31.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+inherit distutils-r1
+
+DESCRIPTION="The official Python library for Shodan"
+HOMEPAGE="https://github.com/achillean/shodan-python"
+
+MY_PN="${PN}-python"
+
+if [[ ${PV} = "9999" ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/achillean/shodan-python.git"
+else
+ inherit pypi
+ KEYWORDS="~amd64 ~loong ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="
+ dev-python/click[${PYTHON_USEDEP}]
+ dev-python/click-plugins[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.2.1[${PYTHON_USEDEP}]
+ dev-python/tldextract[${PYTHON_USEDEP}]
+ dev-python/xlsxwriter[${PYTHON_USEDEP}]
+"
+
+# Test requires API key
+RESTRICT="test"