summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-03 20:05:44 +0100
committerSam James <sam@gentoo.org>2021-04-03 20:52:48 +0100
commitdc5f5393bd2a32529396f2707c17d3607c62bab9 (patch)
tree8d1b7cecb5621d556acc2f8559400cf425ae00db /net-analyzer/nagios-plugin-check_raid
parentnet-analyzer/tsung: eutils-- (diff)
downloadgentoo-dc5f5393bd2a32529396f2707c17d3607c62bab9.tar.gz
gentoo-dc5f5393bd2a32529396f2707c17d3607c62bab9.tar.bz2
gentoo-dc5f5393bd2a32529396f2707c17d3607c62bab9.zip
net-analyzer/nagios-plugin-check_raid: eutils--, missing dies
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-analyzer/nagios-plugin-check_raid')
-rw-r--r--net-analyzer/nagios-plugin-check_raid/nagios-plugin-check_raid-4.0.10-r1.ebuild (renamed from net-analyzer/nagios-plugin-check_raid/nagios-plugin-check_raid-4.0.10.ebuild)12
-rw-r--r--net-analyzer/nagios-plugin-check_raid/nagios-plugin-check_raid-4.0.8-r1.ebuild (renamed from net-analyzer/nagios-plugin-check_raid/nagios-plugin-check_raid-4.0.8.ebuild)12
2 files changed, 12 insertions, 12 deletions
diff --git a/net-analyzer/nagios-plugin-check_raid/nagios-plugin-check_raid-4.0.10.ebuild b/net-analyzer/nagios-plugin-check_raid/nagios-plugin-check_raid-4.0.10-r1.ebuild
index b20b26a5183c..a7b1bfc31c27 100644
--- a/net-analyzer/nagios-plugin-check_raid/nagios-plugin-check_raid-4.0.10.ebuild
+++ b/net-analyzer/nagios-plugin-check_raid/nagios-plugin-check_raid-4.0.10-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=6
-inherit eutils perl-module
+inherit perl-module
DESCRIPTION="Nagios/Icinga plugin to check current server's RAID status"
HOMEPAGE="https://github.com/glensc/nagios-plugin-check_raid"
@@ -31,22 +31,22 @@ RDEPEND="${DEPEND}
megaraid-scsi? ( sys-block/megarc )
mpt-sas2? ( sys-block/sas2ircu )
mpt? ( sys-block/mpt-status )
- "
+"
S="${WORKDIR}/${MY_P}"
src_prepare() {
# Upstream has a custom Makefile that is meant to build bundles.
- mv -f Makefile Makefile.upstream
- sed -i '/CPANfile/d' Makefile.PL
+ mv -f Makefile Makefile.upstream || die
+ sed -i '/CPANfile/d' Makefile.PL || die
default
}
src_install() {
default
plugindir="/usr/$(get_libdir)/nagios/plugins"
- dodir "$plugindir"
- mv -f "${D}"/usr/bin/check_raid.pl "${D}"/"${plugindir}"
+ dodir "${plugindir}"
+ mv -f "${ED}"/usr/bin/check_raid.pl "${ED}"/"${plugindir}" || die
dodoc README.md CHANGELOG.md CONTRIBUTING.md check_raid.cfg
}
diff --git a/net-analyzer/nagios-plugin-check_raid/nagios-plugin-check_raid-4.0.8.ebuild b/net-analyzer/nagios-plugin-check_raid/nagios-plugin-check_raid-4.0.8-r1.ebuild
index b20b26a5183c..a7b1bfc31c27 100644
--- a/net-analyzer/nagios-plugin-check_raid/nagios-plugin-check_raid-4.0.8.ebuild
+++ b/net-analyzer/nagios-plugin-check_raid/nagios-plugin-check_raid-4.0.8-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=6
-inherit eutils perl-module
+inherit perl-module
DESCRIPTION="Nagios/Icinga plugin to check current server's RAID status"
HOMEPAGE="https://github.com/glensc/nagios-plugin-check_raid"
@@ -31,22 +31,22 @@ RDEPEND="${DEPEND}
megaraid-scsi? ( sys-block/megarc )
mpt-sas2? ( sys-block/sas2ircu )
mpt? ( sys-block/mpt-status )
- "
+"
S="${WORKDIR}/${MY_P}"
src_prepare() {
# Upstream has a custom Makefile that is meant to build bundles.
- mv -f Makefile Makefile.upstream
- sed -i '/CPANfile/d' Makefile.PL
+ mv -f Makefile Makefile.upstream || die
+ sed -i '/CPANfile/d' Makefile.PL || die
default
}
src_install() {
default
plugindir="/usr/$(get_libdir)/nagios/plugins"
- dodir "$plugindir"
- mv -f "${D}"/usr/bin/check_raid.pl "${D}"/"${plugindir}"
+ dodir "${plugindir}"
+ mv -f "${ED}"/usr/bin/check_raid.pl "${ED}"/"${plugindir}" || die
dodoc README.md CHANGELOG.md CONTRIBUTING.md check_raid.cfg
}