summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz93@gmail.com>2024-06-30 11:36:54 -0400
committerSam James <sam@gentoo.org>2024-07-01 09:19:12 +0100
commitf91e6697fba4b081fff1cc188040c34aee59ea58 (patch)
tree2df2a5409ce687e525b87b8e19bbe24a42636ed3 /media-video/pipewire
parentmedia-video/pipewire: backport patch to fix automagic webrtc dependency (diff)
downloadgentoo-f91e6697fba4b081fff1cc188040c34aee59ea58.tar.gz
gentoo-f91e6697fba4b081fff1cc188040c34aee59ea58.tar.bz2
gentoo-f91e6697fba4b081fff1cc188040c34aee59ea58.zip
media-video/pipewire: fix file conflicts with pulseaudio-daemon
We don't *have* to be replacing it as the sound server, that's why a USE flag exists for precisely that. But pipewire 1.2.0+ offers to install files from pulseaudio-daemon on the theory it can be replacing it... which means we need to tell it not to do so when USE="-sound-server". Previously, we installed this whenever gsettings was enabled, even though its purpose was to enable API usage independent of being the main sound server. Closes: https://bugs.gentoo.org/935139 Signed-off-by: Eli Schwartz <eschwartz93@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-video/pipewire')
-rw-r--r--media-video/pipewire/pipewire-1.2.0.ebuild11
-rw-r--r--media-video/pipewire/pipewire-9999.ebuild11
2 files changed, 20 insertions, 2 deletions
diff --git a/media-video/pipewire/pipewire-1.2.0.ebuild b/media-video/pipewire/pipewire-1.2.0.ebuild
index bffc3587f167..785496b22c13 100644
--- a/media-video/pipewire/pipewire-1.2.0.ebuild
+++ b/media-video/pipewire/pipewire-1.2.0.ebuild
@@ -205,7 +205,6 @@ multilib_src_configure() {
$(meson_native_use_feature gstreamer)
$(meson_native_use_feature gstreamer gstreamer-device-provider)
$(meson_native_use_feature gsettings)
- $(meson_native_use_feature gsettings gsettings-pulse-schema)
$(meson_native_use_feature systemd)
$(meson_native_use_feature system-service systemd-system-service)
@@ -280,6 +279,16 @@ multilib_src_configure() {
-Dsnap=disabled
)
+ # This installs the schema file for pulseaudio-daemon, iff we are replacing
+ # the official sound-server
+ if use !sound-server; then
+ emesonargs+=( '-Dgsettings-pulse-schema=disabled' )
+ else
+ emesonargs+=(
+ $(meson_native_use_feature gsettings gsettings-pulse-schema)
+ )
+ fi
+
meson_src_configure
}
diff --git a/media-video/pipewire/pipewire-9999.ebuild b/media-video/pipewire/pipewire-9999.ebuild
index bffc3587f167..785496b22c13 100644
--- a/media-video/pipewire/pipewire-9999.ebuild
+++ b/media-video/pipewire/pipewire-9999.ebuild
@@ -205,7 +205,6 @@ multilib_src_configure() {
$(meson_native_use_feature gstreamer)
$(meson_native_use_feature gstreamer gstreamer-device-provider)
$(meson_native_use_feature gsettings)
- $(meson_native_use_feature gsettings gsettings-pulse-schema)
$(meson_native_use_feature systemd)
$(meson_native_use_feature system-service systemd-system-service)
@@ -280,6 +279,16 @@ multilib_src_configure() {
-Dsnap=disabled
)
+ # This installs the schema file for pulseaudio-daemon, iff we are replacing
+ # the official sound-server
+ if use !sound-server; then
+ emesonargs+=( '-Dgsettings-pulse-schema=disabled' )
+ else
+ emesonargs+=(
+ $(meson_native_use_feature gsettings gsettings-pulse-schema)
+ )
+ fi
+
meson_src_configure
}