summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-05-21 23:48:52 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-05-21 23:55:04 +0200
commit2ec025cfb18c105c97dbeac18b7eb1ef5112fab1 (patch)
treeadcd7cda0f57d53778ec75adbcb5ae06591726e8 /media-libs/Field3D
parentmedia-libs/ptex: 2.3.2 version bump (diff)
downloadgentoo-2ec025cfb18c105c97dbeac18b7eb1ef5112fab1.tar.gz
gentoo-2ec025cfb18c105c97dbeac18b7eb1ef5112fab1.tar.bz2
gentoo-2ec025cfb18c105c97dbeac18b7eb1ef5112fab1.zip
media-libs/Field3D: EAPI-7 bump, USE mpi, add proper src_configure()
Properly disabling Doxygen (don't even build it if it ain't finished). Closes: https://bugs.gentoo.org/573440 Package-Manager: Portage-2.3.66, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'media-libs/Field3D')
-rw-r--r--media-libs/Field3D/Field3D-1.7.2.ebuild29
1 files changed, 18 insertions, 11 deletions
diff --git a/media-libs/Field3D/Field3D-1.7.2.ebuild b/media-libs/Field3D/Field3D-1.7.2.ebuild
index 2238a60f8640..1af0862f0c6d 100644
--- a/media-libs/Field3D/Field3D-1.7.2.ebuild
+++ b/media-libs/Field3D/Field3D-1.7.2.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
inherit cmake-utils
@@ -12,17 +12,24 @@ SRC_URI="https://github.com/imageworks/Field3D/archive/v${PV}.tar.gz -> ${P}.tar
LICENSE="BSD"
SLOT="0"
KEYWORDS="amd64 ~x86"
+IUSE="mpi"
+BDEPEND="virtual/pkgconfig"
RDEPEND="
>=dev-libs/boost-1.62:=
>=media-libs/ilmbase-2.2.0:=
sci-libs/hdf5:=
- virtual/mpi"
-
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-
-PATCHES=( "${FILESDIR}/Field3D-1.7.2-Use-PkgConfig-for-IlmBase.patch" )
-
-# Docs are not finished yet.
-mycmakeargs=( -DINSTALL_DOCS=OFF )
+ mpi? ( virtual/mpi )
+"
+DEPEND="${RDEPEND}"
+
+PATCHES=( "${FILESDIR}/${P}-Use-PkgConfig-for-IlmBase.patch" )
+
+src_configure() {
+ local mycmakeargs=(
+ -DINSTALL_DOCS=OFF # Docs are not finished yet.
+ -DCMAKE_DISABLE_FIND_PACKAGE_Doxygen=ON
+ $(cmake-utils_use_find_package mpi MPI)
+ )
+ cmake-utils_src_configure
+}