summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOz N Tiram <oz.tiram@gmail.com>2022-04-24 13:56:59 +0200
committerSam James <sam@gentoo.org>2022-05-14 02:52:57 +0000
commit1d243c83f60b00ca05328f5241696c0286f4e2e5 (patch)
tree03eaf6599ab14a618de93c667e530f0199c5f318 /mate-extra
parentmate-base/caja: add 1.26.0 (diff)
downloadgentoo-1d243c83f60b00ca05328f5241696c0286f4e2e5.tar.gz
gentoo-1d243c83f60b00ca05328f5241696c0286f4e2e5.tar.bz2
gentoo-1d243c83f60b00ca05328f5241696c0286f4e2e5.zip
mate-extra/mate-polkit: add 1.26.0
Signed-off-by: Oz N Tiram <oz.tiram@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'mate-extra')
-rw-r--r--mate-extra/mate-polkit/Manifest1
-rw-r--r--mate-extra/mate-polkit/mate-polkit-1.26.0.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/mate-extra/mate-polkit/Manifest b/mate-extra/mate-polkit/Manifest
index 0ec07eea023a..f72e469d84f7 100644
--- a/mate-extra/mate-polkit/Manifest
+++ b/mate-extra/mate-polkit/Manifest
@@ -1 +1,2 @@
DIST mate-polkit-1.24.0.tar.xz 332652 BLAKE2B 293d964f2410d2f60047d1e01e2ba864c22e8bda00e5b659329d097391b2988349c70dfbd953f223c4212887d16d54f1f5a7eb21e38b69b553d54b1966647cb1 SHA512 8d759bd5f78750c75dc92ffa27e555ae36ae7199b76483cbfe7e0848d3a66cda5b82c98bf334068eb79a1344757665cf7d1bf403e4e908e332ca929c8ebe2a98
+DIST mate-polkit-1.26.0.tar.xz 335768 BLAKE2B 15b1fd38efcb157802ff96f09879a8790d6a8356d6fe75f833bcd4b9f088e30b019a7e0739d48000aed4a7d9b5634727c2176ce7b725d82431118c7da4e04f04 SHA512 393a8a0a9567ec75762dcd1e776a1544756f4b9b88b8bbb4f6d1ed87dcc25c30025e27d6f4e18c04c79f5f02152490f577fb89c758ce042dc466a387d9202e0f
diff --git a/mate-extra/mate-polkit/mate-polkit-1.26.0.ebuild b/mate-extra/mate-polkit/mate-polkit-1.26.0.ebuild
new file mode 100644
index 000000000000..cb5060a320ce
--- /dev/null
+++ b/mate-extra/mate-polkit/mate-polkit-1.26.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit mate
+
+if [[ ${PV} != 9999 ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+fi
+
+DESCRIPTION="A MATE specific DBUS service that is used to bring up authentication dialogs"
+LICENSE="LGPL-2"
+SLOT="0"
+
+IUSE="accountsservice appindicator"
+
+COMMON_DEPEND="x11-libs/gdk-pixbuf:2
+ virtual/libintl:0
+ >=x11-libs/gtk+-3.22.0:3
+ appindicator? ( dev-libs/libappindicator:3 )"
+
+RDEPEND="${COMMON_DEPEND}
+ >=dev-libs/glib-2.50:2
+ >=sys-auth/polkit-0.102
+ accountsservice? ( sys-apps/accountsservice )"
+
+BDEPEND="${COMMON_DEPEND}
+ dev-util/gtk-doc
+ dev-util/gtk-doc-am
+ >=dev-util/intltool-0.35
+ sys-devel/gettext
+ >=sys-devel/libtool-2.2.6
+ virtual/pkgconfig"
+
+src_configure() {
+ mate_src_configure \
+ --disable-static \
+ $(use_enable accountsservice) \
+ $(use_enable appindicator)
+}