summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-03-15 12:58:01 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2020-03-15 14:31:55 +0100
commit386a2b3b4aae0468fdce1a80683d2c76287a4d48 (patch)
treebc76153bb555db8f4e32c12072f66894d52d309a /kde-frameworks/sonnet
parentsys-apps/coreutils: sh stable wrt bug #711616 (diff)
downloadgentoo-386a2b3b4aae0468fdce1a80683d2c76287a4d48.tar.gz
gentoo-386a2b3b4aae0468fdce1a80683d2c76287a4d48.tar.bz2
gentoo-386a2b3b4aae0468fdce1a80683d2c76287a4d48.zip
kde-frameworks: Add KDE Frameworks 5.68.0
Package-Manager: Portage-2.3.94, Repoman-2.3.21 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks/sonnet')
-rw-r--r--kde-frameworks/sonnet/Manifest1
-rw-r--r--kde-frameworks/sonnet/sonnet-5.68.0.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/kde-frameworks/sonnet/Manifest b/kde-frameworks/sonnet/Manifest
index 7cb33bc228b3..0a6829d9fcc3 100644
--- a/kde-frameworks/sonnet/Manifest
+++ b/kde-frameworks/sonnet/Manifest
@@ -1 +1,2 @@
DIST sonnet-5.67.0.tar.xz 288752 BLAKE2B 7ebacd4d94e587db6e84874d093f1ca2110274ff9232f2561b14f825865bde7ee91fb39509989de0f88fa4b8522d92b183d1bd835ff622008c5060815932a3d0 SHA512 b31d4cf8dd13553a1e8caeeefbc8aa3bcdbb08fe84139784922fd7475c9dcc3e86e55f90d34e744e743b0c9f78127455752996f519d7279d9505d946dbd4b878
+DIST sonnet-5.68.0.tar.xz 290792 BLAKE2B 214b1cf896cac87cc463e1c264287fb995459b98f78f04013220ccfbd25aad2b7fce8ae56f9cb4f61f23c462fb516387f70a92152d705e50c17e7342bfb0f284 SHA512 add681532d2cfe371662306376da07bd337446f67d2b375a878bf53355e08407d24e1e63155f313e31b737a70014a052c19a1d120bbc67aeffd6be525f0aada3
diff --git a/kde-frameworks/sonnet/sonnet-5.68.0.ebuild b/kde-frameworks/sonnet/sonnet-5.68.0.ebuild
new file mode 100644
index 000000000000..93eac7f8dfbf
--- /dev/null
+++ b/kde-frameworks/sonnet/sonnet-5.68.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ECM_DESIGNERPLUGIN="true"
+QTMIN=5.12.3
+VIRTUALX_REQUIRED="test"
+inherit ecm kde.org
+
+DESCRIPTION="Framework for providing spell-checking through abstraction of popular backends"
+LICENSE="LGPL-2+ LGPL-2.1+"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="aspell +hunspell nls"
+
+BDEPEND="
+ nls? ( >=dev-qt/linguist-tools-${QTMIN}:5 )
+"
+DEPEND="
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ aspell? ( app-text/aspell )
+ hunspell? ( app-text/hunspell:= )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake_use_find_package aspell ASPELL)
+ $(cmake_use_find_package hunspell HUNSPELL)
+ )
+
+ ecm_src_configure
+}
+
+src_test() {
+ # bugs: 680032
+ local myctestargs=(
+ -E "(sonnet-test_settings|sonnet-test_highlighter)"
+ )
+
+ ecm_src_test
+}