summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2022-11-03 12:56:23 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2022-11-03 17:38:53 +0100
commitbbc2a08ea5c4b1a0f4abeac58503a1aba73e0802 (patch)
tree0ad3835fc5b904412fafb5d4c0ebd4cf10baa62b /kde-apps/kopete
parentkde-apps/krfb: 22.08.3 version bump (diff)
downloadgentoo-bbc2a08ea5c4b1a0f4abeac58503a1aba73e0802.tar.gz
gentoo-bbc2a08ea5c4b1a0f4abeac58503a1aba73e0802.tar.bz2
gentoo-bbc2a08ea5c4b1a0f4abeac58503a1aba73e0802.zip
kde-apps/kopete: 22.08.3 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-apps/kopete')
-rw-r--r--kde-apps/kopete/Manifest1
-rw-r--r--kde-apps/kopete/kopete-22.08.3.ebuild169
2 files changed, 170 insertions, 0 deletions
diff --git a/kde-apps/kopete/Manifest b/kde-apps/kopete/Manifest
index dfca5b7201be..667eadbf52d4 100644
--- a/kde-apps/kopete/Manifest
+++ b/kde-apps/kopete/Manifest
@@ -1,2 +1,3 @@
DIST kopete-22.04.3.tar.xz 9665112 BLAKE2B f50fb872bf8834afc0a19b5241a08ed7206c8d0329b5c3fa61df4de078360c2a1476381b8d179c32751fecc5f1ee4a9cbb5557d08e2e29dc5aed610616af3bca SHA512 efbb9d96a5ae9b9a54e319c424bef4fe4720e6f60e4a28747c29d899ebe511bb32d0925834cdc269730cc75dbdcb910a1107e16a51a9a6a1b1d9d852056dbc44
DIST kopete-22.08.2.tar.xz 9668316 BLAKE2B e9d7f8e27f163e9ce962d430667a91e0d9b14040f1900ac779737182a67d3c6f2d2d32d76eebebcebc58230c06a17f94e88c4882e557e6f77d2c4137d5577a13 SHA512 421908e8469ef212b6ee13b0b80b84f3ed9931487747f8368613797f58245488f26ee2d5a322a97483b1aec29f1373fa2db72406d56c6987733f55189a02f867
+DIST kopete-22.08.3.tar.xz 9668280 BLAKE2B f844bbd82e196507c16c568c32994b5d06077075f53a5d2fb99e74f2bcd972eb6350bdb38f597a937fdb6040bd7c232689bf2eef1b903dbccb919f3ed3b63cf6 SHA512 91e9a0e76e5b633e7e0454e7eba6fd163a912ad72675f3a2e049aba1f7cd306e54383894e783d417dde3961e91ec9b96f5b55772b4f29cd9c107acc185ef346c
diff --git a/kde-apps/kopete/kopete-22.08.3.ebuild b/kde-apps/kopete/kopete-22.08.3.ebuild
new file mode 100644
index 000000000000..fef666a962e7
--- /dev/null
+++ b/kde-apps/kopete/kopete-22.08.3.ebuild
@@ -0,0 +1,169 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_HANDBOOK="forceoptional"
+ECM_TEST="forceoptional"
+PVCUT=$(ver_cut 1-3)
+KFMIN=5.96.0
+QTMIN=5.15.5
+inherit ecm gear.kde.org
+
+DESCRIPTION="Multi-protocol IM client based on KDE Frameworks"
+HOMEPAGE="https://apps.kde.org/kopete/"
+
+LICENSE="GPL-2" # TODO: CHECK
+SLOT="5"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+IUSE="ssl v4l"
+
+# Available plugins
+# addbookmarks: NO DEPS
+# alias: NO DEPS (disabled upstream)
+# autoreplace: NO DEPS
+# contactnotes: NO DEPS
+# cryptography: BROKEN (app-crypt/gpgme[cxx,qt5], kde-apps/libkleo:5)
+# highlight: NO DEPS
+# history: NO DEPS
+# latex: virtual/latex as RDEPEND
+# nowlistening: NO DEPS
+# otr: libotr
+# pipes: NO DEPS
+# privacy: NO DEPS
+# statistics: dev-db/sqlite:3
+# texteffect: NO DEPS
+# translator: NO DEPS
+# urlpicpreview: NO DEPS
+# webpresence: libxml2 libxslt
+# NOTE: By default we enable all plugins that don't have any dependencies
+PLUGINS="+addbookmarks +autoreplace +contactnotes +highlight history latex nowlistening
+otr pipes +privacy +statistics +texteffect translator +urlpicpreview webpresence"
+
+# Available protocols
+# gadu: net-libs/libgadu @since 4.3
+# groupwise: app-crypt/qca:2
+# irc: NO DEPS, probably will fail so inform user about it
+# xmpp: net-dns/libidn app-crypt/qca:2 ENABLED BY DEFAULT NETWORK
+# meanwhile: net-libs/meanwhile
+# oscar: NO DEPS
+# telepathy: net-libs/decibel
+# testbed: NO DEPS
+# winpopup: NO DEPS (we're adding samba as RDEPEND so it works)
+# zeroconf (bonjour): NO DEPS
+PROTOCOLS="gadu groupwise meanwhile oscar testbed winpopup +xmpp zeroconf"
+
+# disabled protocols
+# irc: NO DEPS
+# jingle: media-libs/speex net-libs/ortp DISABLED BY UPSTREAM
+# qq: NO DEPS
+# telepathy: net-libs/decibel
+# skype, sms (until fixed)
+
+IUSE="${IUSE} ${PLUGINS} ${PROTOCOLS}"
+
+COMMON_DEPEND="
+ app-crypt/gpgme:=[cxx,qt5]
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtsql-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=dev-qt/qtxml-${QTMIN}:5
+ >=kde-apps/kidentitymanagement-${PVCUT}:5
+ >=kde-apps/libkleo-${PVCUT}:5
+ >=kde-frameworks/kcmutils-${KFMIN}:5
+ >=kde-frameworks/kconfig-${KFMIN}:5
+ >=kde-frameworks/kcontacts-${KFMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/kcrash-${KFMIN}:5
+ >=kde-frameworks/kdbusaddons-${KFMIN}:5
+ >=kde-frameworks/kdelibs4support-${KFMIN}:5
+ >=kde-frameworks/kemoticons-${KFMIN}:5
+ >=kde-frameworks/khtml-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/knotifyconfig-${KFMIN}:5
+ >=kde-frameworks/kparts-${KFMIN}:5
+ >=kde-frameworks/ktexteditor-${KFMIN}:5
+ >=media-libs/phonon-4.11.0
+ x11-libs/libX11
+ x11-libs/libXScrnSaver
+ gadu? ( >=net-libs/libgadu-1.8.0[threads] )
+ groupwise? ( >=app-crypt/qca-2.3.0:2[qt5(+)] )
+ meanwhile? ( net-libs/meanwhile )
+ otr? ( >=net-libs/libotr-4.0.0 )
+ statistics? ( dev-db/sqlite:3 )
+ v4l? ( media-libs/libv4l )
+ webpresence? (
+ dev-libs/libxml2
+ dev-libs/libxslt
+ )
+ xmpp? (
+ >=app-crypt/qca-2.3.0:2[qt5(+)]
+ net-dns/libidn:0=
+ sys-libs/zlib
+ )
+ zeroconf? (
+ >=kde-apps/kidentitymanagement-${PVCUT}:5
+ >=kde-frameworks/kdnssd-${KFMIN}:5
+ )
+"
+# jingle? (
+# dev-libs/expat
+# dev-libs/openssl:0=
+# >=media-libs/mediastreamer-2.3.0
+# media-libs/speex
+# net-libs/libsrtp:0=
+# net-libs/ortp:=
+# )
+RDEPEND="${COMMON_DEPEND}
+ latex? (
+ || (
+ media-gfx/imagemagick
+ media-gfx/graphicsmagick[imagemagick]
+ )
+ virtual/latex-base
+ )
+ ssl? ( >=app-crypt/qca-2.3.0:2[qt5(+),ssl] )
+ xmpp? ( >=app-crypt/qca-2.3.0:2[qt5(+),ssl?] )
+"
+# sms? ( app-mobilephone/smssend )
+# winpopup? ( net-fs/samba )
+DEPEND="${COMMON_DEPEND}
+ x11-base/xorg-proto
+"
+# jingle? ( dev-libs/jsoncpp )
+
+# tests hang, last checked for 4.2.96
+RESTRICT="test"
+
+src_configure() {
+ local x x2
+ # Handle common stuff
+ local mycmakeargs=(
+ -DWITH_qq=OFF
+ -DDISABLE_VIDEOSUPPORT=$(usex !v4l)
+ )
+# $(cmake_use_find_package jingle LiboRTP)
+# $(cmake_use_find_package jingle Mediastreamer)
+# $(cmake_use_find_package jingle Speex)
+
+ # enable protocols
+ for x in ${PROTOCOLS}; do
+ case ${x/+/} in
+ jingle) x2=libjingle ;;
+ xmpp) x2=jabber ;;
+ zeroconf) x2=bonjour ;;
+ *) x2=${x/+/} ;;
+ esac
+ mycmakeargs+=( -DWITH_${x2}=$(usex ${x/+/}) )
+ done
+
+ # disable until fixed:
+ mycmakeargs+=( -DWITH_{cryptography,libjingle,skype,sms}=OFF )
+
+ # enable plugins
+ for x in ${PLUGINS}; do
+ mycmakeargs+=( -DWITH_${x/+/}=$(usex ${x/+/}) )
+ done
+
+ ecm_src_configure
+}