summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorViorel Munteanu <ceamac@gentoo.org>2024-08-24 19:53:24 +0300
committerViorel Munteanu <ceamac@gentoo.org>2024-08-24 20:06:25 +0300
commit2ca8e6db7d6b31e91bf76cd0df36cea2c11229da (patch)
treece2e3962dad45428c7d55a7b7966f809f95f33b4 /gui-apps
parentgui-apps/wf-shell: sync live ebuild (diff)
downloadgentoo-2ca8e6db7d6b31e91bf76cd0df36cea2c11229da.tar.gz
gentoo-2ca8e6db7d6b31e91bf76cd0df36cea2c11229da.tar.bz2
gentoo-2ca8e6db7d6b31e91bf76cd0df36cea2c11229da.zip
gui-apps/wcm: sync live ebuild
Signed-off-by: Viorel Munteanu <ceamac@gentoo.org>
Diffstat (limited to 'gui-apps')
-rw-r--r--gui-apps/wcm/wcm-9999.ebuild28
1 files changed, 20 insertions, 8 deletions
diff --git a/gui-apps/wcm/wcm-9999.ebuild b/gui-apps/wcm/wcm-9999.ebuild
index d08911344293..a2161dc88469 100644
--- a/gui-apps/wcm/wcm-9999.ebuild
+++ b/gui-apps/wcm/wcm-9999.ebuild
@@ -11,7 +11,7 @@ HOMEPAGE="https://github.com/WayfireWM/wcm"
if [[ ${PV} == 9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/WayfireWM/wcm.git"
- SLOT="0/0.9"
+ SLOT="0/0.10"
else
SRC_URI="https://github.com/WayfireWM/wcm/releases/download/v${PV}/${P}.tar.xz"
KEYWORDS="~amd64 ~arm64"
@@ -22,19 +22,25 @@ LICENSE="MIT"
RESTRICT="test" # no tests
-CDEPEND="
+COMMON_DEPEND="
+ dev-cpp/glibmm:2
+ dev-cpp/gtkmm:3.0[wayland]
+ dev-libs/glib:2
dev-libs/libevdev
+ dev-libs/libsigc++:2
dev-libs/libxml2
dev-libs/wayland
- dev-cpp/gtkmm:3.0[wayland]
- gui-apps/wf-shell
- >=gui-libs/wf-config-0.6.0
- gui-wm/wayfire
+ gui-apps/wf-shell:${SLOT}
+ gui-libs/wf-config:${SLOT}
+ gui-wm/wayfire:${SLOT}
+ media-libs/libepoxy
+ x11-libs/cairo
+ x11-libs/gtk+:3
x11-libs/libxkbcommon
"
-RDEPEND="${CDEPEND}"
+RDEPEND="${COMMON_DEPEND}"
DEPEND="
- ${CDEPEND}
+ ${COMMON_DEPEND}
dev-libs/wayland-protocols
"
BDEPEND="
@@ -42,6 +48,12 @@ BDEPEND="
virtual/pkgconfig
"
+src_prepare() {
+ default
+
+ sed 's/DestkopSettings/DesktopSettings/' -i wayfire-config-manager.desktop
+}
+
src_configure() {
local emesonargs=(
-Dwf_shell=enabled